Quest stuck on Power Off screen — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Quest stuck on Power Off screen

JuhrafJuhraf Posts: 2
NerveGear
I've had my Quest for about a week and today it went belly up on me. I was in the middle of a game when it said something about how it lost tracking, I didn't quite remember it all as within a few seconds the screen went off on me. Then when I removed the headset and put it back on it was on that Power Off screen with the message about if the controller is not working use the volume button. Well my controllers are not doing anything (they are not dead, they were at 70% power when I started and was on the Quest for less then an hour when this happened.) But also the volume button isn't doing anything on that screen either to select one of the options. And finally, holding down the power button to force a reboot/restart isn't working either, it just turns the screen off, and then when I push it again it just pops back into the Power Off screen. The Quest only has two thinks to click on for the headset so I really don't know what else I can do now since already tried both. Please help if anyone knows how to fix this or something I can do.

Comments

  • JuhrafJuhraf Posts: 2
    NerveGear
    In case this happens to anyone else I tried something and it seems to have worked to fix the issue, for now. Since the screen was stuck in the Power Off screen mode and naturally wouldn't turn off on its own after being idle, I left it on and unplugged. I figured maybe I could force a restart if it powered down all the way on its own. And it seems to have worked. I left the Quest on and unplugged all night and checked it again this morning. It was dead and when I pushed the power button it just showed me the dead battery symbol. I plugged it in for a few minutes to get a little juice in there to test and and powered it back on. It powered on like normal. So I guess that works! I hope if anyone else ends up with this issue my little trial and experience first hand helps them with it as well.
  • TheOculusLoverTheOculusLover Posts: 1
    NerveGear
    I have the same problem, I'll try to let the battery go down, cause i JUST got this quest, like a day ago
Sign In or Register to comment.