New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S USB driver update recommended warning

2

Comments

  • Initial-DInitial-D Posts: 12
    NerveGear
    Initial-D said:
    I fixed this!
    ok Goto device manager and find what USB it’s telling you to update and click uninstall. You have to restart PC and when it starts up it will auto update that driver and it will be fixed.  Just make sure you don’t have the oculus app running but leave it plugged in
    What device (exact name please) did you uninstall?

    The Intel® USB 3.0 eXtensible Host Controller doesn't have any updates.
    Which ever one it tells you, click it then uninstall in device manager
    Yes but can you share the exact name of the one that appeared for you please?
  • MrBluePlaydohMrBluePlaydoh Posts: 36
    Brain Burst
    Don’t worry the fix don’t work as I went out for the day came back and it’s back so it has to be there software!

    mine was Intel(R) USB 3.1 extensible host controller - 1.10 (microsoft)
  • clemencaclemenca Posts: 28
    Brain Burst
    edited July 2019
    Don’t worry the fix don’t work as I went out for the day came back and it’s back so it has to be there software!

    mine was Intel(R) USB 3.1 extensible host controller - 1.10 (microsoft)

    Yes it must be a problem of oculus software, same as the flickering thing...
  • LameDuckWarriorLameDuckWarrior Posts: 31
    Brain Burst
    Same here. Working fine though.
  • philrleephilrlee Posts: 9
    Brain Burst
    I just checked before switching my PC off and the HMD is now green. I rearranged my USB devices so they are now connected to different ports. I have an Asus Maximus XI Hero and have the 2 USB 2 ports in use with a wheel and pedals for sim racing. The Rift is the only device plugged into a USB 3.1 Gen 2 port. I have my mouse and keyboard plugged into the two USB 3.1 Gen 1 ports. Finally all my other device are plugged via powered USB 3 hubs to 2 ports on a HighPoint RocketU RU1144D USB3 card. I am completely up to date with Windows 10 (18362.239) and have installed 431.

    I have previously tried using the Rift S connected to the HighPoint card. When I plug it in it is unable to complete the tracking check during HMD setup (see https://forums.oculusvr.com/community/discussion/76267/rift-s-tracking-not-working-with-highpoint-rocketu-ru1144d-usb3-card#latest). I previously used this card for 2 Rift sensors.
  • philrleephilrlee Posts: 9
    Brain Burst
    edited July 2019
    I just booted my PC up again with everything connected the same as in the previous post. The orange warning is back again.
  • MrBluePlaydohMrBluePlaydoh Posts: 36
    Brain Burst
    Just talking to my friend who also has a headset and we compared USB drivers and my drivers are more up to date then his! and he don’t have the warning.
  • Initial-DInitial-D Posts: 12
    NerveGear
    So on the ASRock Z370 Pro4 board, I enabled Thunderbolt (which presumably only affects USB-C) and this caused the indicator in Oculus Software to turn green. I don't know exactly what changes internally on the board because the Rift S is still plugged in a standard USB 3 port, but it appears to have worked. I'm not sure if this applies to other boards, but it may have something to do with how the USB ports get initialized or what they advertise to support when Oculus probes them to read their capabilities. Interesting find nonetheless since I did not update any drivers..
  • MrBluePlaydohMrBluePlaydoh Posts: 36
    Brain Burst
    Initial-D said:
    So on the ASRock Z370 Pro4 board, I enabled Thunderbolt (which presumably only affects USB-C) and this caused the indicator in Oculus Software to turn green. I don't know exactly what changes internally on the board because the Rift S is still plugged in a standard USB 3 port, but it appears to have worked. I'm not sure if this applies to other boards, but it may have something to do with how the USB ports get initialized or what they advertise to support when Oculus probes them to read their capabilities. Interesting find nonetheless since I did not update any drivers..
    How did you do that? 
  • Initial-DInitial-D Posts: 12
    NerveGear
    Initial-D said:
    So on the ASRock Z370 Pro4 board, I enabled Thunderbolt (which presumably only affects USB-C) and this caused the indicator in Oculus Software to turn green. I don't know exactly what changes internally on the board because the Rift S is still plugged in a standard USB 3 port, but it appears to have worked. I'm not sure if this applies to other boards, but it may have something to do with how the USB ports get initialized or what they advertise to support when Oculus probes them to read their capabilities. Interesting find nonetheless since I did not update any drivers..
    How did you do that? 
    From the UEFI bios settings of my motherboard. But I should note that nothing changes performance wise the Rift S works the same as before
  • VortimousVortimous Posts: 64
    Brain Burst
    Not only do I have this problem as well (just started today after the windows update) but now my Rift S wont even turn on.  When I place it on my head the lights are lit up but the screen is all black and nothing comes on.  The occulus app opens and it says its connected but I cant do anything its all black like its not on.  I do have the update USB warnings and another notification that says that guardian cant be detected do you want to play without it.  It has been working since day 1 with no problems now windows update and nothing works.  I want to roll back the update on windows 10 but I don't see where you can do that anymore under the settings.  It use to be so easy, now I cant even find it....
  • TheFonz89TheFonz89 Posts: 1
    NerveGear
    So is oculus going to update their software or what? my new processor isn't even recognized by oculus. this update usb 3.0 is annoying
  • Initial-DInitial-D Posts: 12
    NerveGear
    Just to be clear, doesn't sound like anyone is actually having issues because of the indicator , it's like a false positive. Sounds like people are having unrelated issues with their pc hardware and/or windows
  • AzayelAzayel Posts: 1
    NerveGear
    I have issue. I only have " real camera " active with that USB warning...
  • VortimousVortimous Posts: 64
    Brain Burst
    Initial-D said:
    Just to be clear, doesn't sound like anyone is actually having issues because of the indicator , it's like a false positive. Sounds like people are having unrelated issues with their pc hardware and/or windows

    I am having issues...  ever since that update, my headset wont even turn on anymore.  I was seeing the notification, but since then, I place the headset on my head and nothing lights up or comes on.  Before that, it has been working fine (since day 1 purchase)….  more than frustrated....  even did a full reinstall today as recommended by the tech support...  still nothing...
  • Initial-DInitial-D Posts: 12
    NerveGear
    Vortimous said:
    Initial-D said:
    Just to be clear, doesn't sound like anyone is actually having issues because of the indicator , it's like a false positive. Sounds like people are having unrelated issues with their pc hardware and/or windows

    I am having issues...  ever since that update, my headset wont even turn on anymore.  I was seeing the notification, but since then, I place the headset on my head and nothing lights up or comes on.  Before that, it has been working fine (since day 1 purchase)….  more than frustrated....  even did a full reinstall today as recommended by the tech support...  still nothing...
    Tried plugging into another pc just in case? 
  • ShiroiSakuraVRShiroiSakuraVR Posts: 17
    NerveGear
    i get the error away after i update my mainboard bios now. Never did it and saw i had a version from 2015 on, not its updatet and dont have the usb error. maybe u guys check your bios version and try to update it!
  • Initial-DInitial-D Posts: 12
    NerveGear
    So looking at all the posts again, the indicator doesn't seem to tell us anything useful at all, it's just annoying to see it. Some people that have real issues don't really seem to be related to the indicator at all. Perhaps Oculus should remove it altogether or at least tell us what triggers it. I've still got the indicator warning and the headset and games run just as well as before if not better
  • Max_ImmelmannMax_Immelmann Posts: 12
    Brain Burst
    well, this same problem popped up for me.  checked all my usb drivers.  every thing is up to date.
    read thru this thread, saw some one say to go to settings>beta>then click "restart oculus".  warning disappeared.
    no, i was not having any issues in performance.  i just hate warnings, like some others here, lol
  • PhilaironePhilairone Posts: 1
    NerveGear
    I have Rift S since day 1, never had problems, but after Win 10  update 1903... Orange warning for me too (update USB)
  • AzrefAzref Posts: 8
    NerveGear
    Also geting the anoying update USB drivers issue. All my drivers are updated so I dont know what more to do. I'm enrolled in the beta channel and the update USB warning did disappear for a few days, then came back yesterday.

  • DarklordukDarklorduk Posts: 25
    Brain Burst
    philrlee said:
    My Rift S has been working well all week. Today it has started showing an orange indicator in the Devices section. In there it displays the warning:

    USB driver update recommended

    When I go into the headset it has a warning triangle next to USB. When I hover over the ? it shows the following tooltip:

    Your headset is plugged in correctly. If you encounter tracking issues, updating your driver (Intel) may improve performance.

    I have made now changes to the PC so don't understand why this message is suddenly being displayed. All my USB drivers are up to date so I'm at a loss on how to fix it. I am currently opted into the PTC and have 1.38.0.256587 installed.
    like wise worked fine and now it asking me to update usb3 drivers but theres no new driver so i think like everyone else it odculus software is fubar .i didnt have this trouble with the orignal rift why o why did i upgrade 
  • VortimousVortimous Posts: 64
    Brain Burst
    Initial-D said:
    Vortimous said:
    Initial-D said:
    Just to be clear, doesn't sound like anyone is actually having issues because of the indicator , it's like a false positive. Sounds like people are having unrelated issues with their pc hardware and/or windows

    I am having issues...  ever since that update, my headset wont even turn on anymore.  I was seeing the notification, but since then, I place the headset on my head and nothing lights up or comes on.  Before that, it has been working fine (since day 1 purchase)….  more than frustrated....  even did a full reinstall today as recommended by the tech support...  still nothing...
    Tried plugging into another pc just in case? 

    Yes, and it worked fine...   I found a workaround but not happy about it.  I had to create a new NON Microsoft user account for windows (a dummy user account with admin permissions) and if I log off my main account and log into the dummy account (with a simple name like Tony) it works....  if I switch back to my normal account, it doesn't work.  I hate having to switch back and forth between window accounts just to play VR....  I hope they fix this soon... it is getting annoying.  They say it has something to do with the new windows update and your windows user account having special characters in the name like spaces or @ or periods, etc....  Wish we could get an update on whether this will be fixed soon or not.  The sad thing is, it has worked fine on my original windows log in since day 1, but then after the last windows update last week... black screen (along with the still orange warning about the USB being outdated....)
  • MrBluePlaydohMrBluePlaydoh Posts: 36
    Brain Burst
    I have a fix for the USB maybe it might fix other issues, I will post the fix when I get home from work.
  • FlipolipoFlipolipo Posts: 1
    NerveGear
    same issue mine oculus rift s was working perfectly fine but today the orange triangle pop up with usb 3.0 update, when I turned on oculus the tracking was horrible I checked drivers and everything was up to date I cant play now pls help
  • hugepumphugepump Posts: 1
    NerveGear
    That worked for me, or it could also just be switching usb
  • geoff.killickgeoff.killick Posts: 35
    Brain Burst
    Just started happening for me after updating windows 10 to 1903, before the update never had the problem. Rift S still works (with static flashes)  Must be a Windows problem? 
  • LameDuckWarriorLameDuckWarrior Posts: 31
    Brain Burst
    Initial-D said:
    Initial-D said:
    So on the ASRock Z370 Pro4 board, I enabled Thunderbolt (which presumably only affects USB-C) and this caused the indicator in Oculus Software to turn green. I don't know exactly what changes internally on the board because the Rift S is still plugged in a standard USB 3 port, but it appears to have worked. I'm not sure if this applies to other boards, but it may have something to do with how the USB ports get initialized or what they advertise to support when Oculus probes them to read their capabilities. Interesting find nonetheless since I did not update any drivers..
    How did you do that? 
    From the UEFI bios settings of my motherboard. But I should note that nothing changes performance wise the Rift S works the same as before

    This worked for me. Also I noticed that Oculus Home performance increased to high graphics from medium. Devices all green.
Sign In or Register to comment.