New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Computer reboots when Rift S goes to sleep

aaronrryanaaronrryan Posts: 6
NerveGear
I'm having a very strange behavior with my Rift S.  If I take my Rift S off, and set it down for more than 20-30 seconds the whole computer reboots.
If I keep it on my head, it works fine with no reboots.  Only when I leave it idle after using it.

Has anyone else had this issue?  It has done it since the beginning, with update 1.37, 1.38 and 1.38.1
I have tried switching to all the different USB ports, but it happens on all of them.

I have :
  • Gigabyte Aorus Z370 Gaming 5 Motherboard
  • i9-9900k CPU
  • Gigabyte GTX 1080 GPU
  • Windows Pro 1903
«1

Comments

  • LZoltowskiLZoltowski Posts: 6,774 Volunteer Moderator
    Do you have any warnings in Windows Event log?

    What PSU do you have?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • darthian66darthian66 Posts: 6
    NerveGear
    I'm having a similar issue, but it didn't start until the 1.38 firmware update.  It seems to restart my PC most frequently when the displays in the headset turn off automatically after removing the headset.

    I have a 750 watt PSU, and have never had any issues until the most recent update.

    I have a lot of USB peripherals for flight simulators, which can be power hungry so I thought maybe that was the issue and I've offloaded all of them to a separately powered USB hub and no fix.
  • aaronrryanaaronrryan Posts: 6
    NerveGear
    edited June 23
    I have a Corsair RM850i, so should be more than enough.  It usually runs about 85watts when idle and 330w when in VR game. No warnings in Windows Event Logs.

    I unplugged all my other USB devices, and it still happens.  It's so strange.  I may try a full OS reinstall incase it's software/driver related
  • darthian66darthian66 Posts: 6
    NerveGear
    I've done some more troubleshooting.  I've tried every USB port on my PC and I've tried offloading all USB peripherals (including the headset itself) to the powered USB hub and nothing fixes the problem.

    I have noticed that I can induce the problem myself by simply unplugging the Rift S displayport cable.  No matter what configuration of USB devices are plugged in and where, if that Rift S displayport goes to sleep on its own or if it gets physically unplugged, the PC reboots.  Any other display device, like a normal monitor plugged into the same displayport works just fine and doesn't cause any problems upon being unplugged, only the Rift S hmd.
  • razaicerazaice Posts: 8
    NerveGear
    I'm having the same issue as darthian66 and aaronrryan.  My Rift S forces my computer to restart about 10 seconds after taking the headset off.  The only detail that's different in my case is that I'm able to unplug the displayport cable without making the restart occur.  Other than that, the issue appears to be identical.  Has anyone else come across this problem?
  • sraurasraura Posts: 589
    Trinity
    Interesting issue... may I ask are you all using gigabyte motherboards or gigabyte gpu's ?
    Also has any of you tried tweaking some power management settings from computer bios and seeing if that makes any difference?
  • razaicerazaice Posts: 8
    NerveGear
    edited July 5
    Gigabyte motherboard and EVGA GPU here.  Z97MX-Gaming 5 and a 1070.  I took a quick glance at the bios a few days ago, but wasn't sure which setting may be related.  Do you have any suggestions?
  • sraurasraura Posts: 589
    Trinity
    edited July 5
    Looks like the motherboard might be the common factor here then. You don't have same models, but it might have some bios settings which explains this. Unfortunately I don't know much about bios Gigabyte is using.
    You probably want to find settings which are related to acpi/uefi or apm. Also if you your motherboard has integrated graphics you might want to disable it or at least set your discrete graphics card as primary.

  • razaicerazaice Posts: 8
    NerveGear
    edited July 5
    Great troubleshooting sraura, thanks.  The fix for me was to enable ErP mode in the bios under Power Management.  ErP mode has something to do with allowing the system to be in a low power state.  The signal being sent to the computer when the headset goes into sleep mode must have conflicted with the setting being disabled somehow.
    Let me know if that fixes it for you darthian66 and aaronrryan.
  • darthian66darthian66 Posts: 6
    NerveGear
    I actually have the same exact mother board as razaice, the Z97MX-Gaming 5, unfortunately, enabling ErP mode did not solve the problem for me.  I'm going to continue to play around with the various power management settings in the BIOS and see if I can figure it out.  I did disable the integrated graphics through BIOS as well, but still no luck.  I'll keep pressing and let everyone know if I come up with something.
  • razaicerazaice Posts: 8
    NerveGear
    edited July 5
    I spoke too soon...  I thought it was resolved by enabling ErP Mode, but my computer restarted after an hour of play.  I'll keep looking and report back if I figure it out.  At least we can say our motherboards are almost certainly the cause.
  • sraurasraura Posts: 589
    Trinity
    ErP mode should not make difference when computer is running. It just cuts some power usage while computer is shutdown and disables certain features like power on by keyboard button press and such...
  • razaicerazaice Posts: 8
    NerveGear
    I didn't have any luck messing with bios settings, but I think I did find a workaround.  It's pretty ridiculous though.  First of all, it involves using the Oculus Tray Tool.  While still in VR, when you're ready to take the headset off, you open up the virtual desktop option on the right of the menu that appears when you press the menu button on the controllers.  You'd then navigate to the OTT on your desktop, choose the Service and Startup menu, and press the stop button along the top to stop the Oculus Service.  This will close the Oculus program and turn off your headset.  In my experience at least, the computer does not restart after exiting this way.
  • sraurasraura Posts: 589
    Trinity
    edited July 6
    Sounds like something oculus should be able to fix then (or at least let Gigabyte know if they need to fix something). Would recommend contacting oculus support and letting them know what you found out. Maybe this helps them to solve also some other usb/displayport compatibility issues they've been having.
  • razaicerazaice Posts: 8
    NerveGear
    Fortunately I have a ticket open with Oculus for this issue and I've been keeping them updated on my progress.  They've been pretty responsive in trying to help, which is great when a company is trying to get a new product off the ground.
  • darthian66darthian66 Posts: 6
    NerveGear
    edited July 11
    Hey guys, I thought I would provide an update.  I've been working with support via an open ticket and we've been doing more troubleshooting.  The last thing we tried was to reboot in safe mode, completely remove all of the oculus software, and then reinstall everything fresh.  This seems to have changed the behavior of the reboots for me.  It's become less frequent, but frustratingly less predictable for me now.  The headset going to sleep isn't an auto-reboot like it was before, and I've noticed that sometimes when I put the headset back on it will reboot the PC a few seconds later.  For example, I was playing around in the virtual desktop and put on a YouTube video.  I took the headset off for about 2 minutes and when I put it back on, the displays turned back on and about 5 seconds later the PC rebooted.

    Anyone else make any headway?
  • razaicerazaice Posts: 8
    NerveGear
    Thanks for the update.  I'm happy someone is still looking into our issue.  Ever since I discovered my method of using the Oculus Tray Tool to end the Oculus Service while still in VR, I've kind of given up on finding the root cause.  I guess it's good enough for me, and having it resolved completely would just be a bonus.

    As a side note, I've also experienced times where the headset causes the computer to restart about 5 seconds after putting it on.  It's only happened a few times.  It must be some weird quirk relating to the sleep mode for the headset.  This is especially annoying for me because I haven't figured out a way around it, though like I said, it's been pretty rare.
  • sraurasraura Posts: 589
    Trinity
    edited July 16
    If someone of you gigabyte motherboard guys want to bite the bullet and try new power supply, it might be worth trying. Now I've seen 3 cases where this has fixed either power downs or black screens. In all of the cases old power supply has been 550W. However it is good to keep in mind, that performance of PSU will degrade over time. This also means that even more powerful PSU's will eventually face the same fate.
    Your symptoms are very similar to those 3 other cases, but I am still bit puzzled with the gigabyte motherboard on the equation. One explanation could be, that it could be more power hungry than most boards out there and hence trigger the power downs more frequently...
    Anyways this is really roll of the dice... just wanted to bring options to the table if some1 wants to take the shot...
  • MallratsMallrats Posts: 4
    NerveGear
    Hi guys!

    One more with the same problem. I just updated my PC to have more power and I find this mess.

    I have : 
    • Gigabyte Z370 AORUS Gaming K3 (rev 1.0) Motherboard
    • i9-9900k CPU
    • Gigabyte RTX 2080 Ti GPU
    • Corsair RM850i PSU
    • Windows 10 Home 1903

    Has anyone been able to fix it?
  • darthian66darthian66 Posts: 6
    NerveGear
    Hi Mallrats, sorry to hear this is happening to you too! Unfortunately no, it was never resolved for me. Interesting that you also have a gigabyte mobo. I recently switched out my old gtx 970 SLI configuration for a single gigabyte rtx 2070 super and the problem persisted. The make of motherboard seems to be the primary commonality between those of us having this problem. 

    I went through extensive troubleshooting with Oculus support but nothing worked. The support ticket basically concluded with them stating that the issue is not with the headset... 

    I've been using razaice's workaround. I load the Oculus tray tool before using the headset and then when I'm done I peak under the headset and use the tray tool to manually kill the Oculus service, then I can safely take off the headset and no reboot.  It works great but it's annoying that I can't just take the headset off for a quick break without having to completely kill the Oculus service and then restart it when I'm done, but it works.
  • MallratsMallrats Posts: 4
    NerveGear
    Thank you darthian66! I will try that trick! ;)

  • Error-401Error-401 Posts: 27
    Brain Burst
    Same here, will reboot when you take the headset off, however this is fairly recent.  The only issue I could see (but maybe not related) in the event log it mentions OVRServiceLauncher is missing.

    GIGABYTE Z390 I AORUS PRO WiFi, Corsair Vengeance ddr4 3200, SilverStone SX700-LPT, Gigabyte Geforce RTX 2080 windforce 8G, Samsung 970 Pro PCIe M.2, Intel Core i9-9900K




    PC: Intel Core i9-9900K | Corsair Vengeance DDR4 3200 16GB | MSI RTX 2080 Ventus | Samsung 970 Pro NVMe | SilverStone SX700-LPT | GIGABYTE Z390 I AORUS PRO WiFi | SilverStone RVZ03B-ARGB

  • JoeKsuxJoeKsux Posts: 1
    NerveGear
    I just started having this issue after upgrading from an 8600k to a 9900k. Im curious, does everyone who's having this same problem have a 9900k?

    I have : 9900k, Gigabyte z370 Aorus Gaming Wifi, Gigabyte Aorus 2080 TI, 32 GB G.Skill DDR4 ram, 1000 Watt EVGA Supernova Platinum PSU
  • MarvzzVRMarvzzVR Posts: 1
    NerveGear
    Hey guys, same issue for me. i upgraded from a i7 8700k to an i9 9900k and needed to update my bios for the Gigabyte Aorus 370... Looks like the i9 might be the problem too... before this update and upgrade, there was no reboot after unplugging the headset. i also did some power adjustments but this doesnt seem to work for me. Hopefully we can find a way trough this :sweat_smile:
  • dburnedburne Posts: 2,843 Valuable Player
    No problem on my end with a 9900k and Z390 board.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • SGMRockSGMRock Posts: 7
    NerveGear
    I just got the Rift S today and I have had my system reboot itself 2x now, and as I was typing this my keyboard, mouse and a gamepad that all have RGB colors seem to have gone dark for a few seconds then recovered and allowed me to continue typing.  This event also generated an event log Event ID 0 from source OVRServiceLauncher cannot be found.  2 of them warnings.  The times my system rebooted completely there were 3 of these events, the same 2 warnings then a red error all related to OVRServiceLauncher.  

    Never had this issue until I installed the Rift S.  I put my system under a lot of gaming stress all the time with no issues.  
    System Specs:
    Asus ROG Rampage VI Apex
    Intel i9-7900X, 32GB RAM
    EVGA RTX 2080Ti FTW3 Ultra Hybrid
    Sound Blaster AE-5 
    EVGA 1200P2 power supply as I used to run crossfire before I got the 2080Ti, I have a big PSU.

    Only thing I can think of is this must be USB related.  I'm thinking I might need a powered USB hub to plug the Rift S into?  Thoughts?  
  • darthian66darthian66 Posts: 6
    NerveGear
    SGMRock said:
    Only thing I can think of is this must be USB related.  I'm thinking I might need a powered USB hub to plug the Rift S into?  Thoughts?  
    Didn't work for me, but if it does for you let us know. I've tried a separate powered USB hub and went through every USB device I have one at a time to rule everything out including the rift S. The headset is the only device that causes this problem, and for me, it doesn't matter if it's connected to the powered hub or directly to one of my motherboard's on-board USB ports (any of them).  The only thing that works for me is the Oculus Tray Tool workaround described above (kill the service before the headset goes to sleep).
  • SGMRockSGMRock Posts: 7
    NerveGear
    I got the tray tool and I set it to close down the service every time I open or close the tray tool. but I will also take the extra step that you said and see what happens.  I can't remember if the 2 times it rebooted where when i took it off my head, but I think they were.
  • SGMRockSGMRock Posts: 7
    NerveGear
    it keeps rebooting my machine sometimes when I restart the service after its been disable because i'm about to use it.  Or like you said I just took it off my head and set it down and boom reboot.
  • SGMRockSGMRock Posts: 7
    NerveGear
    edited December 1
    My RTX 2080Ti also has the VirtualLink port on it that is Gen 2 class C, I read using that to power the device a good way to fix issues with the Rift S but I didn't have an adapter for it handy.  You still have to use the Displayport as well because evidently no one makes a VirtualLink adapter for Rift S to just have a single hookup into your graphics card that was designed for VR.... silliness.

    Option 2 was that my motherboard has a few USB controllers, some Intel and some ASMedia.  I had the Rift S plugged into one of them that was multiple ports of USB 3.1 Gen 1 with lots of other devices connected to that MB hub. I think controlled by ASMedia I believe.  I also have a ASMedia 3.1 Gen 2 controller on the board that has one A and one C port on the MB back plate.  I don't have any of these devices right now so I have had nothing plugged into those.  I decided to put the Rift S into that 3.1 Gen 2 A port as it would be the only device running on that controller. 

    So far no more reboots since I did that last night and I have been playing Elite Dangerous off and on all day removing the headset several times and sitting it on my desk without stopping the service.  So this is encouraging.  Of course now that I put this on the forums it will crash in 20 minutes. LOL knock on wood.
Sign In or Register to comment.