New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Problem Running TF2

mikesigmikesig Posts: 4
edited November 2013 in Games and Apps
Hey, all: I downloaded the orange box version of TF2 on steam (not the beta, the actual tf2) and added the command line -vr, but TF2 is not working properly. The valve/steam logos are in normal 1200x800 resolution, as are the menus. When I get into the game, it splits the screen in half, but not oculus-style (i.e. the Tuscany demo). Running vr_configure also does nothing: it elicits no response from the console. Note that I have the rift plugged into my laptop via HDMI as a cloned monitor, and the Tuscany demo runs perfectly fine. Any suggestions would be much appreciated!
«1

Comments

  • KleptoKlepto Posts: 8
    I just posted almost the exact same thing. I've got the same problem. Adding this reply to track and to confirm the problem.
  • I too was just about to post this very issue. The split image is not pre-warped and moving the oculus around does nothing for the view. I guess Valve broke VR mode in a recent update.
  • AGr_AGr_ Posts: 8
    NerveGear
    I'm having the same problem, I just got my Rift today and this was the first thing I was trying to get working :(
  • bizarrobrianbizarrobrian Posts: 2
    NerveGear
    Add me to the list of people having the same issue. I switched from hdmi to DVI but it didn't make any difference. Did they recently push an update or something?
  • ZyxtZyxt Posts: 1
    Same here, looked all over the place for a fix but couldn't find any.
  • +1

    Notes:
    The tuscony demo works great.

    TF2 in the console vr_calibration is recognised as a command but doesn't do anything
    When loading a multiplayer the screen splits but not in vr mode.
  • mikesigmikesig Posts: 4
    At this point, it looks likely that there was either a new update to TF2 that bonked the Rift support or that downloading it today caused us to get a new version that doesn't have the proper Rift update but also makes Steam think it's the latest version. Has anyone with the problem had TF2 on their PC before today?
  • jhericojherico Posts: 1,419
    Nexus 6
    I discovered this trying it out on a new machine, but moving back to a machine I had working last night still exhibited the problem. Yeah, looks like Valve broke the one working game.
    Brad Davis - Developer for High Fidelity
    Co-author of Oculus Rift in Action

  • braaadbraaad Posts: 7
    NerveGear
    I just tried it also, not working.

    I haven't played TF2 in ages and it had to convert file formats or whatever it does.

    I just get a plain split screen with no head tracking. All other games work fine.
  • cmoskicmoski Posts: 3
    NerveGear
    Yeah. I was playing at around 3 AM this morning PST. Everything was fine, and then Valve must have issued an update between then and 2 PM PST..

    Of course, they issued an update right before I brought a few developer friends from Microsoft over to check out the Rift. So, I fired it up and sure enough, split screen goodness with no head tracking :) Not before recompressing the GCFs and leaving us with an hour wait to 'improve performance.'

    One of these days Steam...
  • KajosKajos Posts: 19
    FYI I fixed this by reinstalling steam and team fortress.
  • WookieeWookiee Posts: 79
    Hiro Protagonist
    -vr gets me split screen... both showing the same perspective.
    vr_calibration does nothing.
    Menu is truncated and left eye only.
    No warp
    No head tracking.
  • braaadbraaad Posts: 7
    NerveGear
    Kajos wrote:
    FYI I fixed this by reinstalling steam and team fortress.

    I am re-installing it now *sigh*. I will update with results.
  • braaadbraaad Posts: 7
    NerveGear
    braaad wrote:
    Kajos wrote:
    FYI I fixed this by reinstalling steam and team fortress.

    I am re-installing it now *sigh*. I will update with results.

    Still not working...
  • SlortzSlortz Posts: 3
    Working for me yesterday, fired up steam tonight and d/l the optimization updates...now broken.
  • SirKnightTGSirKnightTG Posts: 28
    Kajos wrote:
    FYI I fixed this by reinstalling steam and team fortress.


    No that will not fix it. I installed a fresh steam and TF2 on my new notebook and the problem is still there. It's Valve's latest patch that broke it.
  • WookieeWookiee Posts: 79
    Hiro Protagonist
    Hope they are busy trying to fit all the console commands into a nifty menu... I can dream.
  • joejoe Posts: 102
    Brain Burst
    Looking into it...
  • Thanks Joe! Greatly appreciated!
  • joejoe Posts: 102
    Brain Burst
    We have a fix. There were just some VR-related files missing after the Steam Pipe update yesterday.

    The fill will be rolled out to everyone soon, but if you want to play in VR before that just open the Steam properties for TF2 and pick "prerelease" from the Beta tab. The pre-release build has the fix.
  • papersackpapersack Posts: 10
    Thanks for the quick response!
  • SirKnightTGSirKnightTG Posts: 28
    I just tried the prerelease option and while the game is split in two with the proper pre-warp and tracking, it's not in fullscreen and I still see some of my desktop. Looking through the rift it's all screwed up because of this.

    I guess I'll have to wait for the "official" roll out. :)
  • 320x200320x200 Posts: 125
    Hiro Protagonist
    I just tried the prerelease option and while the game is split in two with the proper pre-warp and tracking, it's not in fullscreen and I still see some of my desktop. Looking through the rift it's all screwed up because of this.

    I guess I'll have to wait for the "official" roll out. :)

    It showed up like that for me on first launch too. If you can fiddle with the mouse until you can find it in the game window, go to video options and re-select fullscreen.
  • SirKnightTGSirKnightTG Posts: 28
    Yep that did it.
  • dm18dm18 Posts: 25
    Brain Burst
    Ah i'm glad I found this threat. I just assume TF2 had no head tracking. I couldn't find a way to use the variable to set "C" lens rendering. BUT I didn't try that hard to find it.
  • davew2040davew2040 Posts: 7
    Just got this working, and it's truly an amazing experience! The fast-paced nature is a little bit off-putting at first, but wow!
  • Great work! Thanks! :D
  • Brian221Brian221 Posts: 2
    Tried all these recommendations and could not get it to function on the iMac...will try on the PC tomorrow.
    I also tried my install of TF-2 Beta with no luck.
  • vrdevvrdev Posts: 14
    edited May 2013
    I got my rift a couple of days ago and cant seem to get tf2 working at all. I've added the -vr tag to launch options in steam but the game just loads as normal (no split screen). I've also tried the prerelease beta mode as discussed but no change. Hoping I'm just missing something simple. All other demos etc have worked instantly with rift. Any suggestions?

    --update--
    All working now! In case anyone else has the same silly issue, in the launch options mine were surrounded by quotation marks, maybe thats how steam used to accept these, not sure, as I didn't add them recently. In any case, removing the quotation marks surrounding the various launch options such as -vr fixed things for me.
  • dpkaydpkay Posts: 12
    I suppose Mac users still have to wait for the final rollout :(
«1
Sign In or Register to comment.