[Support/Issue][Rift S] Headset tracking or microphone not working because of USB 3.0 drivers Win10 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

[Support/Issue][Rift S] Headset tracking or microphone not working because of USB 3.0 drivers Win10

Right, I usually don't feel the need to report an error like this as most of them have been fixed, but this one has been stumping me for three weeks now, and I'm still no closer to learning why and how it happens.

The issue:
While using Windows 10's native USB 3.0 drivers, the Rift S sensors will work properly, and the headset will have no issue tracking. However, the microphone (while normally detected by Windows, Device manager, and even Oculus itself) will not work. Specifically, no matter how much noise you make, it will not pick up any sort of sound and transmit it through the device. 

Alternatively, using the native motherboard's (AsusTek H81M-Plus) USB drivers (ASMedia USB 3.0 eXtensible Host Controller, the non-Microsoft version, acquired by updating the drivers "automatically"), the Rift's microphone starts to work, the USB 3.0 connection establishes, DisplayPort functions normally, but the headset's sensor tracking is broken, resulting in both the Oculus software reporting an error, and the black screen with "in-your-face" controller display error.

Relevant information:
-- Rift S is brand new, barely two weeks old (this was an issue at first install).
-- All connections, physical and software, work normally (this means everything is registered without complaints or issues)
-- All required drivers and software are up to date, including firmware (BIOS), Windows updates, and Oculus Software
-- The issue persists on both a beta version of Oculus Software, and the regular version
-- The issue persists across two graphics cards (tested on NVidia's 6600 GT and NVidia's 1080Ti). Both graphics cards are capable of running Oculus without issue with the windows drivers
-- Other USB 3.0 devices are able to establish connection with the ports and function normally (tested by transferring files between an SSD and a USB drive, clocking in at appropriate speeds of around 40 MB/s)
-- Device Manager reports all components to function normally, without need of driver updates
-- Extensive testing was done on the Rift S, confirming that all of its components work normally, INCLUDING the microphone (tested by using Audacity to record mic output with ASMedia/"Updated" drivers). The Rift's internal speakers likewise function normally, without issue.
-- Rift S is normally detected via USB 3.0 on a different PC, and the microphone immediately works there as well. NOTE: Haven't been able to check sensor tracking as the laptop doesn't have a sufficient GPU to support the Displayport for a sensor check, but am confident it would work normally, as there have been no errors.
-- The issue was tested on both an old, half-clogged, and a clean Windows 10 install, with a reformatted SSD, and no additional software (save for NVidia's GPU drivers) installed. The results were consistent.

Attempted fixes and debugging:
-- Reinstalling Oculus Software (numerous times)
-- Resetting Rift S
-- Updating and reverting all Drivers to new and old versions
-- Reinstalling Windows 
-- Trying different USB ports, including 2.0 versions
-- Running through Oculus support and troubleshooting
-- Installing a Beta version of Oculus software
-- Screaming at the sky in frustration

Conclusion:
The most that I've managed to figure out is that there is SOMETHING wrong with how the motherboard's USB 3.0 ports are communicating with the Rift, and are in some sense faulty. Unfortunately, I'm not in the position to be changing the motherboard, as I'd have to completely replace my CPU as well, which is currently out of my price range, but if I'm able to do it in the future, I'll report the results. 

If anyone has any feedback, suggestions or ideas on the topic, please post them down below, and I sincerely hope this issue doesn't plague anyone else!
Sign In or Register to comment.