New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

USB Driver Update Recommended

I keep getting the usb driver update recommended error when i load up the oculus app. I can still play games and it doesnt mess with it at all? Also if i go into my device manager and uninstall the drivers for usb ports that my rift is plugged into and then restart my computer and let windows reinstall the drivers,  it seems to temporarily fix it? Is anyone else having the issue. I never had the issue with the original rift only my new rift s
«1

Comments

  • vahdyxvahdyx Posts: 5
    NerveGear
    Same issue for me, also looking for advice. 
  • darbosssdarbosss Posts: 4
    NerveGear
    Same problem. 2 different rift s. I have a Maximus hero xi and inatech card tried reinstalling. Tried manufacturer drivers and MS. Now it started only playing audio in the left ear. 
  • k4rst3nk4rst3n Posts: 5
    NerveGear
    Yep same here, even before and after I got a PCI-E USB 3.0 card, which btw fixed all my tracking and no passthrough problem. So I guess it's just a recommendation.
  • timj2456timj2456 Posts: 4
    NerveGear
    I've got the same problem.   I thought it started after the most recent Windows updates.   I know mine has been acting wierd, and have been having to power off my tower to get the Rift S to wake up so that I can use it.   It's getting a little frustrating.

  • oldroddy54oldroddy54 Posts: 12
    Brain Burst
    Same here,working fine yesterday morning,then in the afternoon i get the message,with the orange in the picture,something not right Rift s side.
  • AzrefAzref Posts: 8
    NerveGear
    Getting the same on my end, checked my USB drivers and they're all updated to the most recent. Seems to be a problem with the Oculus software.
  • dburnedburne Posts: 3,509 Valuable Player
    Azref said:
    Getting the same on my end, checked my USB drivers and they're all updated to the most recent. Seems to be a problem with the Oculus software.
    Yep same here.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • Reinart_The_FoxReinart_The_Fox Posts: 19
    NerveGear
    same here.
  • GlarcanGlarcan Posts: 7
    NerveGear
    same here.
  • rVRclosetrVRcloset Posts: 386
    Trinity
    Yup, got this yesterday cutting my voice out from a stream.. Fixed by opting out of the Oculus beta, but just now I have the same issue again..
    All USB drivers are up to date.

    The Closet Sim Rig
    Aourus Pro Z390 - i7 8086K 32GB Ram - MSI RTX 2080 Ti Gaming X Trio 11GB - Windows 10  / GT Omega WS - NLR V3 - RS6 - Jetseat kw-908 / Fanatec CSW 2.5 / Fanatec ClubSport V3 pedals / Fanatec SQ Shifter 1.5 / Fanatec CS HB V.1.5 / HE SQ Shifter / SHH Shifter / TH8A Shifter / G27 Shifter - Button Box / DSD Button Box / BBJ Button Box / Wind simulator / Rift - S
  • hobinmhobinm Posts: 5
    NerveGear
    I believe a number of us started getting this after the recent windows update for some reaon

  • timj2456timj2456 Posts: 4
    NerveGear
    I got the PTR upgrade and it cleared my problem with the USB driver.

  • RosgilliesRosgillies Posts: 170
    Art3mis
    Done the upgrade, still got usb warning.
  • Schrammo2019Schrammo2019 Posts: 1
    NerveGear
    Have this as well... since yesterday... still working but get the orange "!"
  • dburnedburne Posts: 3,509 Valuable Player
    Have this as well... since yesterday... still working but get the orange "!"
    Yep same here also. All USB drivers updated to latest.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • GamingTC2GamingTC2 Posts: 38
    Brain Burst
    Same here.  Only a orange sign on the device page.
    Everythings works the same.
  • dburnedburne Posts: 3,509 Valuable Player
    GamingTC2 said:
    Same here.  Only a orange sign on the device page.
    Everythings works the same.
    Yeah and that orange warning is bugging the crap out of me LOL.
    Even though everything working great, much rather see everything green!
    C'mon Oculus I am sure you have your hands full but please correct this.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • MrBluePlaydohMrBluePlaydoh Posts: 33
    Brain Burst
    I just been in teamspeak with a mate who has a headset and we compared diver dates etc and mine is more upto date than his and he dont have a warning, this has to be a bug!
  • SesharimSesharim Posts: 7
    NerveGear
    ouhh my orange  usb warning is gone  since the update hooray
  • LameDuckWarriorLameDuckWarrior Posts: 31
    Brain Burst
    Was there an update today? I'm aware of yesterdays.
  • dburnedburne Posts: 3,509 Valuable Player
    Was there an update today? I'm aware of yesterdays.
    Just yesterday's I think. I still have the orange.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • gjelliottgjelliott Posts: 1
    NerveGear
    I've got the same orange warning for my Rift S after updating Windows 10 to 1903.  Very frustrating as all was green before that, even with my Rift CV1.  I even use a Fresco usb card recommended by Oculus.   How is the best way to let Oculus know about this issue?  
  • dburnedburne Posts: 3,509 Valuable Player
    Mine turned back green today, after being orange with a warning for several days.

    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • DaftnDirectDaftnDirect Posts: 5,707 Volunteer Moderator

    This seems to happen for me every time Windows updates.

    Usually fixed by uninstalling and reinstalling the 3.0 and 3.1 eXtensible Host Controller drivers, making sure the Microsoft version of the 3.0 drivers are installed not the Fresco logic version (they're still called Fresco logic but has Microsoft in brackets) then restarting the Oculus service.

    Well it worked for me the last time Windows updated and the same this time.

    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18363.720)
  • keebzkeebz Posts: 8
    Brain Burst

    Usually fixed by uninstalling and reinstalling the 3.0 and 3.1 eXtensible Host Controller drivers

    OK so I uninstalled this and the orange warning immediately went away. Everything back to green. Soon as I rebooted my PC it reinstalled this driver and the warning returned. So yes, that's the cause of the error on my end, but there doesn't seem to be a way to fix it.   
  • EthrelaedEthrelaed Posts: 10
    NerveGear
    edited July 2019
    Did somebody a fresh Win10 1903 installation with the latest drivers this week? I want to know if it could cure this problems. My Rift S does not accept my USB 3.1 Slot with high datarate since this week which was running my Rift S flawless since launch... and the other 3.1 are laggy at the moment.
  • profman5profman5 Posts: 9
    Brain Burst
    edited July 2019
    I asked Oculus Support, during a different Oculus issue, about my USB issue and got a response.  The portion of my correspondence which dealt with the USB issue and the response are reproduced below:
    Me to Oculus Support:  Could you, perhaps, give reply to the problem of the apparently fictitious "USB drivers out of date" warning that myself and others seem to be getting from the device section of the Oculus App? For me, it is not always present, and, in any case, the warning is not indicative of a real problem.
    Oculus Support Reply:  The USB error should be fixed soon with a update we will be releasing soon.
    BTW, I can say that doing a complete uninstall of the Oculus App under Windows Safe Mode and manually deleting any remaining bits of Oculus files, followed by an install of the Oculus App did NOT eliminate my USB warnings.

  • clemencaclemenca Posts: 28
    Brain Burst
    edited July 2019
    The usb warning was gone with 1.39 home and firmware update, then comes MS update kb4512937 and the usb warning was back again. I am on the latest usb intel driver for my tuf z390 mainboard released bei Asus on 22.07.19.
    Also i get a warning that my default audio device isnt Rift S audio device

  • kidshibuyakidshibuya Posts: 4
    NerveGear
    profman5 said:

    Oculus Support Reply:  The USB error should be fixed soon with a update we will be releasing soon.


    That is the standard response they say for everything they have no clue about it seems.  
  • DaftnDirectDaftnDirect Posts: 5,707 Volunteer Moderator

    Generally speaking Oculus tend to say what they mean. Sometimes they're poor at giving out information but when they do state something, it tends to be true.


    Microsoft have updated the USB drivers in the latest Windows 10 release (drivers dated 19/06) and I suspect those drivers need to be checked out before Oculus give them the green light. In the mean time the orange advisory doesn't seem to affect anything at all that I'm aware of.

    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18363.720)
Sign In or Register to comment.