Unpleasant introduction the the Rift S — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Unpleasant introduction the the Rift S

wolf_walker78wolf_walker78 Posts: 8
NerveGear
edited July 4 in Oculus Rift S and Rift
So we've had a Rift for a year or so, late adopters, it's been pretty trouble free other than it's built in shortcomings.
Bought an S a couple weeks ago and just now got to play with it, have submitted the following on a support ticket. 
I get the impression from a quick google online and look around here that I'm not the
only one having a less than awesome experience with this model.

Also, the new controllers suck compared to the Rift.  Nowhere to rest ones 
thumb, and maybe it's just my hands but I have a hard time keeping my trigger
finger resting, lightly but not too lightly, on the trigger while operating the grab
button.  And they are weighted funky.  Someone with vastly different ergonomic ideals
than my average sized hands must have designed and tested these.

I also decided not to bother mentioning the multiple right controllers and persistent 
low battery warning that won't go away since a clean reinstall got rid of it, for now.
But I'd bet it comes back.

Support Ticket:

New Rift S, MSI B450 motherboard, 2700X, GTX1080, Windows 10, all bios/drivers etc are current.  Setup runs fine, everything installs fine, can play for five-ish minutes before controllers freeze at about eye level.  They still show rotational movement but will not change position in space.  Some variation has been happening on this from the start, I've un-re installed Oculus app several times, manually removed any trace of it between un-re installs, checked the batteries in the controller, made sure the board USB drivers were current, tried several USB ports, etc, etc.  Also, when it is working, releasing objects such as when you throw them is hit or miss, there is often a delay that just basically ruins the mechanic.  I've found that if you keep the trigger finger depressed, not just on the button but holding the trigger down, on the throwing hand it works as expected.  This and several other lesser issues have been mentioned more than a few times on your user forums it looks like, can you at least asure me you guys are working on this?  I have a Rift I bought after it'd been out awhile and it's been nearly trouble free, as of right now the Rift S is basically $400 worth of useless.  Thank you for any advice.

Comments

  • FangzhouFangzhou Posts: 41
    Brain Burst
    Many people faced this problem. My rift s got this problem twice, the controller position fixed at headset position (rotation still works somehow). After I turn on PTC and upgrade Oculus to 1.39 patch this problem is gone (at least I have never got this problem until now). 
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    Tech support responded suggesting to roll back to an older NV driver and gave the exact procedure for clean removal of the Oculus software, and suggested the beta channel.  Haven't had time to try either but I'll get to it eventually.  I think the hardware is beta, maybe the beta software will work with it lol....  
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    Did a clean install of oculus app following the removal instructions, full removal and reinstall of geforce driver and tried the beta channel for oculus app before installing hardware, pretty much the same result.  About ten minutes of playing around in the home space and my avatar hands stuck in space near my head.  Tech support suggested geforce driver version 398.35, which is so old I didn't readily find a download source for it and I'm loathe to go so far back anyway as I do play some newer games.  I am quite annoyed and may just return it.  I don't mind a bug here and there but flat out unuseable is another matter.
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    Today's suggestion was to kill VMware and MSI's MysticLight software, and reseat the cable at the headset, which I did all of.  No change.  I'm running up on the time to decide if I just put it in the box and wait to see if they fix it later, or if I return it.  I was going to try it on another intel-motherboard'd PC here but I notice you have to have windows 10 for the S, and nobody else in the house is willing to give up 8.1 but me yet lol...  So....

    If AMD or Nvidia released a GPU that worked, or didn't work as the case may be, to the degree that seems to be the case with this, there would be torches and pitchforks.  I have every suspicion that this thing just don't like the USB implementation/drivers AMD has for the B450 with the current oculus software/firmware.  I expect the " reinstall windows" suggestion to come soon.
    I hope not, since that ain't happening as this is a 9-5 work PC too.
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    Update.  Oculus very kindly sent me a new unit, which I was pretty sure was not the problem.
    It was not.
    Clean full removal of Oculus software per customer support instructions, reinstall, at the setup point where you defend the floor height the "world" goes to static, all of it.  Twice.  Never saw that before.
    I enabled the beta channel, no more static, got me through setup and into the home space, 3 minutes in, my 
    hands are stuck in position again.  Exactly like before.
    They have an issue with the motherboard USB or GPU drivers or something along those lines is my guess, I have an MSI B450, 2700X and GTX 1080, all newest reference drivers, windows 10 on newest updates.
    I can honestly say since having started my computing/gaming career with a shareware copy of wolfenstein 3D I have never, ever been able to flat out not get a piece of hardware or software to work like this.
    Especially a relatively expensive one.

    Can you imagine if AMD or Nvidia sold a GPU at this price point, or any price point for that matter, that flat out 
    wouldn't work lol?  What a mess.  

    I think I'm going to ebay the thing and just take the loss.
    Call it lesson learned, buy Oculus stuff two or three years after it releases maybe.
    I did that with my original Rift and it's been a champ.

  • sraurasraura Posts: 589
    Trinity
    If they suggest for windows reinstall, try easier solution 1st by creating new local admin account and installing Oculus software there... If that makes any difference - at least you have plenty of new data to help troubleshooting...

    Sounds funny but that solution has fixed numerous weird issues from many users - specially from the ones who have been using Micro$oft account.

    I've gathered more detailed instructions to this post.
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    Thanks for the suggestions, I'll add them to my list.  This PC doubles as a work box so it's not getting a re-install, though I guess I could do a 2nd install temporarily on a spare ssd.  I'm using a local login so that shouldn't be a problem, but I can create a new local admin and try that.

    I should mention that support has been pretty good, they haven't fixed it, but they are still actively engaging and trying and I appreciate it.  I have a feeling they are swamped.
  • sraurasraura Posts: 589
    Trinity
    Yep... they are probably getting tons of tickets about the "usb driver recommended"-issue, which appeared after micro$oft updated windows and some drivers along with that. It may be that some tracking issues are also caused by this, so yea - I bet they are swamped.
    Anyways I did read this thread through again and one more pointer... If you get that "multible right controllers"-issue back, you can use this tool to remove 'em.
  • wolf_walker78wolf_walker78 Posts: 8
    NerveGear
    I only used it briefly, till it screwed up again, so I didn't see the multi controllers again, but I'll keep an eye out.

Sign In or Register to comment.