Gear VR dead with Samsung Galaxy S10+ — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Gear VR dead with Samsung Galaxy S10+

leviathan0999leviathan0999 Posts: 5
NerveGear
In early-mid May, I bought a Samsung Galaxy S10+. Being a big fan of the Gear VR headset, I confirmed with both Samsung and Sprint -- and the Samsung rep at my local Best Buy -- that the Gear VR headset was still compatible. {I also did online research, and saw articles on reliable sites (PCMag, C-Net, I'm not sure of the list) assuring me that, yes, it was still supported.} I actually spent a lot of extra money for the 1TB storage version of the S10, so I could store a lot of VR videos on my phone for use with the Gear VR.

And it worked! I used the Gear VR headset reliably, if not constantly, from the day I brought the phone home. I had a couple of minor issues because the S10+ isn't quite as large as the S8+ (screen is larger, but overall phone a couple of mm smaller) so I learned to be extra sure the phone was seated correctly, but that was the one and only problem. It worked just fine.

Now, I have date records because I worked with Tech Support on an app issue, so I can tell you I successfully used the Gear VR as recently as June 22nd, 2019. (And probably after that, but I can't give dates.) 

But, when I tried this morning, NADA. The phone didn't even seem to know it was plugged into the headset. No black screen, no Oculus Home, no funny little electronic "Gleek!" to let me know it was connected. Just a blurry sideways view of the home screen.

I reset the phone in the headset multiple times, made sure it was fully engaged. I restarted the phone. I blew out the USB port of the phone and the USB connector of the headset with canned air. Nuthin'!

I tried a couple of generic VR apps, and they displayed okay on the Gear VR, but neither the hand-held controller nor the touchpad on the side of the headset did anything.

I called Samsung support. They hemmed and hawed and asked really basic questions, then put me on hold for a long time, and then came back and told me, as if it was the most obvious thing in the world and a longtime fact, that the Model SM-RR324 GearVR headset -- the new one with the hand-held controller which I'm pretty sure is the most recent model -- is not compatible with the Galaxy S10, or any phone more recent than the S8. "You can check on our website and everything!" 

Obviously, I let them have it on that one. It's been supported, and it's worked, as recently as 17 days ago. As I said, "Don't lie to my face. I don't mind if you think I'm stupid, but don't talk to me like you think I'm stupid!" 

I told them that, since I know nobody came into my house and pulled circuitry out of my phone, and since it worked reliably and then stopped working, this was clearly an issue of a change they made in the software. (Samsung rep: "We don't make software." Me: "You mean there's no such thing as Samsung Touch, and all that Samsung-branded bloatware in my app drawer is imaginary?") 

I eventually got as high up the chain of command as a "Manager" who (A) didn't treat me like I was stupid, (B) acknowledged that I had covered all the knucklehead troubleshooting stuff, and then offered the suggestion that I bring my phone to a walk-in service center and have it "re-flashed." I have no faith it will work, but I guess I have to try it next.

Has anybody else run up against this? Anyone come up with a successful fix?

Comments

  • dlfnrdrdlfnrdr Posts: 1
    NerveGear
    Mine is still working, but several apps, including a couple I just bought, are in some kind of loop where they download and install, then say they require an update at which time they re-download and reinstall and then say they require an update and I think you get the picture. 
  • seamus1seamus1 Posts: 1
    NerveGear
    My Galaxy S10+ is working perfectly in my GearVR, I've had S7, S8+ and S9+ working in their respective headsets.

    The only time it ever stopped working was when I downloaded an app that could switch the GearVR to Google Cardboard then back to GearVR, it switches off the Gear VR service.

    Make sure the Gear VR Service is running as the Oculus app won't respond if disabled.



  • ChrisX36ChrisX36 Posts: 1
    NerveGear
    The 325 model is actually the latest model.  That's what I have.  I wasn't able to use my S10+ until I obtained one.
Sign In or Register to comment.