New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Can't Enable Developer Mode

Noti0NNoti0N Posts: 4
NerveGear
I have a new Quest and am attempting to enable Developer mode.   I have followed the guide lines published to setup a new organization - unfortunately when I toggle the developer mode which launched the Create Organization requirement in a web page.  After entering a new organization, the developer mode will not enable.  Does anybody have any idea why this process does not work?
Tagged:

Comments

  • kimrichinskimrichins Posts: 1
    NerveGear
    I am also having this problem. I've actually created 3 organizations now, and it still won't toggle on developer mode, but sends me back to the page to create an organization. I've restarted the app, restarted my phone, and uninstalled/ reinstalled the app. 

    Were you ever able to find a solution?
  • NorgePlayzYTNorgePlayzYT Posts: 23
    Brain Burst
    try to reboot VR
  • Noti0NNoti0N Posts: 4
    NerveGear
    I finally got developer mode initiate but i had to do it from a fourth android device, my tablet.  None of the phones with Oculus apps worked, all attempted to create new organizations.  Try another device.
  • Emilian1978Emilian1978 Posts: 25
    Brain Burst
    For Oculus Quest, if you want to be a developer:

    1. Create the organization on the Oculus Website, using a regular web browser, from your PC.
    2. Enable the Developer Mode on the Android App, having the Oculus Quest connected and online at this point.
    3. Restart your Oculus Quest.
    4. Developer option should be now available on the left column in your All settings menu.
    5. Download all the tools and drivers like in the guides you're following for sure and start programming !

    GL !
  • OrderOfOutOrderOfOut Posts: 3
    NerveGear
    ^This does not work.  We followed all of those steps.  Every single time I try to toggle the developer option on, it redirects me to the exact same website.  I'm signed in, paired, have an organization.  This system is broken.
  • zhyieczhyiec Posts: 1
    NerveGear
    I had the same problem on my smartphone. I tried on my IPad. It worked. Thanks Noti0N said:
    I finally got developer mode initiate but i had to do it from a fourth android device, my tablet.  None of the phones with Oculus apps worked, all attempted to create new organizations.  Try another device.
  • kdayknightkdayknight Posts: 1
    NerveGear
    Did any one resolve this? I have tried multiple devices including iOS and nothing is working?!

    Does anyone have a solid fix for this? 

    Thanks in advance
  • kdmvkdmv Posts: 2
    NerveGear
    edited January 14
    A consideration for this problem maybe - is your phone signed in through Facebook and a different account or name on Oculus' website maybe? I think i had this problem with mine because it did exactly the same thing. I signed into Oculus on a PC to create the organisation (because the website is horrendous to navigate on a phone) but then went through the phone when trying to enable developer mode. When i first set up an account i chose a username and only then did it ask me if i wanted to sign in through Facebook so i'm not sure if it's got two log-ins registered and going in via the phone sends the Facebook log-in by default which won't match the Oculus account and therefore it tries to get you to create a 'new' organisation.
  • AnimatologistAnimatologist Posts: 1
    NerveGear
    I also have this issue, I have created 2 organisations already, I always sign in with email I can connect and use rift apps on my pc using link, I just cannot get developer mode to enable. I get 2 options, no thanks and start creating.It keeps redirecting me to the website when I click start creating. This is where it says to enable developer mode and create an organisation which I have already done.
    So I'm stuck. I do not have another android device to try.
  • dansopansodansopanso Posts: 8
    Brain Burst
    edited May 10
    got the same problem. i don't use facebook login or the facebook app on my device. tried to restart and everything. so the only working solution is to try another device?
  • dansopansodansopanso Posts: 8
    Brain Burst
    ok i think i found the solution... it is very similar to what Emilian1978 posted:

    you need to be logged in with your mobile browser in your oculus account (with a browser that accepts cookies) and you need to have created an organisation.

    The app tries to use your browser and check into your account. if that doesn't work it shows you the creator link... not a very intuitive way to tell me that my browser is not logged-in but i think this was the problem.
  • dansopansodansopanso Posts: 8
    Brain Burst
    ok you can try this without the need of another device or restarting the oculus.

    go to the creator link and scroll down to the part where they write that you need to create an organisation.
    follow this link and log-in to your account. if you don't have an organisation yet, create one.
    make sure you are using a web-browser with enabled cookies and don't log-out.

    when you try to enable the developer mode, the app will access your browser and check into your account. if you are not logged in (and don't have an organisation created?) it won't work.

    It would be nice to get a bit more precise error message here, but i think this should work.
  • AtomVsPilotAtomVsPilot Posts: 1
    NerveGear
    It doesn't work Period. Software is trash.
  • TheRealTempestTheRealTempest Posts: 1
    NerveGear
    OK - I got it...  Make sure that you are logged in on the browser with the same user as the Oculus app....   I had one e-mail address on one and a different email address on the other - hence 2 accounts...  I logged out on the website, logged in with the same account as the Android app (since thats where all my purchases were done) and voila I was able to activate Developer mode...   and it only took an hour and a half to figure that out... there are others that said similar but not as  clear (I think....)
  • irontalirontal Posts: 1
    NerveGear
    the only thing that helped me after hours of searching- install adbGUI

    httpszzzzzz://ez-360.com/knowledge-base/vr-headset-doesnt-show-on-my-computer

    sorry for all the zzzz. Otherwize couldn't paste the link. delete them

    Fix: Follow the steps below

    1. Download the latest version of adbGUI

    2. Unzip the folder

    3. Double click on “adbGUI”

    4. Check in the Oculus Go if you need to give permission

    5. Your Oculus Go should now be connected succesfully.



Sign In or Register to comment.