New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S - No Usb Connection or Any Light Inside the Headset, please help?

orkt.ozdemirciorkt.ozdemirci Posts: 6
NerveGear
Hello

I got my oculus rift s few days ago and i was quite happy with it. I watched a movie last night in virtual desktop and played few games. Then I bought Hellblade from steam to play on Today. I installed the game few hours ago and connected my rift s to my pc. My pc is Asus Rog GL 502Vs notebook by the way and it's a vr ready device. And my rift s just stopped working. 

I connected to usb 3 port and mini display port but there is no light inside the headset, it's not working. I tried to repair oculus home, no fix. I tried to update all my usb drivers, no fix either. Then i uninstalled oculus home and all folders related with it. And I'm connection my rift s to my computer without any driver or oculus software but still there is no light. Nothing. There is no sign that proves it's alive. Is it normal? 

What happens when you connect your rift s to a computer without and oculus software? Is it showing any light etc? 

I really need help, and open to all suggestions. 

Thanks
Tagged:

Comments

  • AsediousAsedious Posts: 1
    NerveGear
    I'm having this same issue, but my Rift S arrived on friday, no luck, did all you did, reinstalled usb drivers, tried on several ports, 3 different pcs and nothing happened, I'm seriously considering a refund.
  • orkt.ozdemirciorkt.ozdemirci Posts: 6
    NerveGear
    Yep this is weird. I contacted with support and they responded quite fast. They haven't resolve my issue yet but at least they are trying to do something about at. We will see what's gonna happen. 
  • AlJ57AlJ57 Posts: 6
    NerveGear
    Hi, do you get a solution? any one?
Sign In or Register to comment.