New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S Software setup issue

Ehahn02Ehahn02 Posts: 1
NerveGear
So this is my first time ever getting a VR headset, and my first time posting on the forums. So I don't know if this is the right place for this, but I'm pretty desperate.

I downloaded the Oculus Rift S software and ran it, it told me that I needed to get 2 windows updates that I didn't have. I did have them, but after downloading them again and restarting it now prompts me with "Upgrade Required     Oculus Setup requires a 64-bit version of either Windows 7 SP1, Windows 8.1, or Windows 10. To continue, please upgrade Windows." Thing is I have a genuine version of Windows 7, with the SP1 package installed. I've looked everywhere but all of the posts are from 2017. I've tried pretty much everything, running it in administrator, disabling antiviruses, running it from commandprompt and Windows run with /bypassHotfixCheck on the end, and NOTHING has worked. I just want to play VR, but I've been trying to fix this for an hour now and nothing is working... Anyone have any help?

Sreenshots are included.

Oh yeah, I have installed all of the updates for Windows 7, except the language ones.

Comments

  • dburnedburne Posts: 3,748 Valuable Player
    You would probably have better luck all around with the Rift if you went ahead and updated to Windows 10.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • sraurasraura Posts: 590
    Trinity
    edited July 2019
    Have installed .Net ReDistributions and related stuff... Don't even know if that could cause that particular issue, but worth the shot I guess...

    When I bought Rift S not too long ago, I moved Rift CV1 to other computer which had exactly same windows than you have. Install went fine with the
    OculusSetup.exe /bypassHotfixCheck
    It should work so is probably just missing something.

    Also not sure if this is related (I didn't need to do this), but worth to read.

    and after saying all the above things...
    ...it is good to know that Oculus Rift minimum requirements have changed and now they seem to mention only windows 10 as operating system which is supported.
  • KameradenschweinKameradenschwein Posts: 1
    NerveGear
    I have the same problem, is there a solution for it? 

    I will upgrade to windows 10 (for reasons) but i would love to play a bit with it already now
  • The_MoepThe_Moep Posts: 1
    NerveGear
    edited December 2019
    I seem to be having the same problem with the Setup for the original oculus under Windows 7 Professional SP1 (build 7601). The dialog still mentions Windows 7 SP1 and iirc. they have said that that OS version will be supported at least until Microsoft drops support and that after that it will still work but not receive updates so I assume this is some issue with the install itself? Getting this in the OculusSetup.log:

    [Debug] [12.12.2019 14:33:59 PM] RunCheck 'Dawn.Preflight.OsVersionCheck' failed.
    [Error] [12.12.2019 14:33:59 PM] Aborting installation due to failed preflight check.

    Interestingly it worked once (but failed at the hotfix check, I have them installed so I bypassed that) and now it doesn't even reach that step anymore but fails directly on the os?

    So whatever that check does, it doesn't seem to like my OS version? Maybe there is an earlier setup version available that doesn't have that issue or does that get queried from remote servers? (shouldn't because according to my Firewall it didn't try to connect yet)

    Trying to figure out if there is a bypass switch like the hotfix one for the setup right now.

    EDIT: I did not figure out a way to bypass that check however I ended up deleting all local files (in %LOCALAPPDATA%\Oculus) and re-downloaded the setup (the file had the same md5sum so it was the same and only the file name was different, not sure if that had something to do with it. Mentioning it for completion sake) and it worked! Os check passed (after bypassing the installed hotfixes) and it's downloading =D

    Another thing I should mention is that I just downloaded and installed 4 additional updates (without restarting) as I noticed they were out right now: KB2310138 (Version 1.307.309), KB890830, KB4530734 and KB4533095. I kinda doubt that has anything to do with it (as I didn't restart Windows yet) but maybe that was just what was missing?
Sign In or Register to comment.