New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Sharing - Video recording broken - fix the encoding please. Thanx

Emilian1978Emilian1978 Posts: 24
Brain Burst
edited August 2019 in Oculus Quest
Hello,

Since this morning I cannot play the today's video recording on my Windows 10 PC. I'm using the latest codecs, VLC, etc. I'm using computers since 1990 so it's not on my end the problem.

I'm usually recording with Quest for debugging purposes.
The videos are playing ok in the Quest galery. As soon as transfer them to the PC, the videos are of correct size but appear corrupted and unplayable.

Not even VLC Media Player cannot play them, and this is a big issue, because I cannot fix them.

Please fix the video encoder.

When trying to upload to YouTube : "The video has failed to process. Please make sure you are uploading a supported file type."

Thank you.

Comments

  • Emilian1978Emilian1978 Posts: 24
    Brain Burst
    After 2 restarts, it works now. Strange bug....

    Anyway, this topic can be closed. The videos now are being copied correctly to the PC.

    Thank you !
  • YoSnesYoSnes Posts: 2
    NerveGear
    What did you restart to get this to work? I have restarted my computer as well as the Quest and I cannot get the videos to play on my Windows 10 PC nor import into Premiere Pro. Anyone else have a similar problem?
  • Emilian1978Emilian1978 Posts: 24
    Brain Burst
    It worked only once. I can confirm that the videos recorded today appear again as 0 length and cannot be played. It's a bug and must be squashed. OCULUS !!! ANYBODY THERE ? :disappointed:
  • Emilian1978Emilian1978 Posts: 24
    Brain Burst
    I installed everything YouTube, Facebook. I've tried Google Photos ... literally EVERY uploading service available for Quest. NOTHING WORKS TO DIRECTLY UPLOAD. I'm mad now. Incredible how you cannot use a wireless device for wireless content. It's stupid.
  • Emilian1978Emilian1978 Posts: 24
    Brain Burst

    Workaround : connect your Oculus Quest directly with an USB to USB C cable to your Android device using an USB C to regular USB phone dongle.
    Browse the videos from the Oculus Quest with your phone and copy them directly to your phone. Then just upload it to youtube, whatsapp, etc using your phone.

    Android is reading all the video files without problems, while Windows 10 is not.
  • IplayGOGIplayGOG Posts: 9
    NerveGear
    Hello from November 2019. Still have this issue on fresh firmware v11.
    ffprobe tells that moov atom not found
    From 9 videos only 1 managed to be recorded correctly. I used videorepair1.5.zip. It can take a valid reference video and reconstruct missing moov, but it didn't quite work. Video alone is passable, but sound is garbled, slower than video. Or video is faster than sound. Audio track becomes full of instant silence gaps.

    Thanks for the tip about different uploading method. Definitely not fan of Android, but another way to introduce differentness. I tried SideQuest, and it worked flawless! In essence, Windows Explorer uses MTP, and SideQuest uses ADB. Of course, it requires registering as developer and enabling developer mode. So ADB is bytewise precise, and MTP is not. Thus, ADB is more reliable.

    I have a guess that Oculus filesystem is backed by some kind of a database for MTP to work. As soon as for some reason Oculus failed to put a duration into database, MTP transfer will fail. So we need some means to autorepair database if duration is missing.
  • SpuzzumSpuzzum Posts: 843
    3Jane

  • IplayGOGIplayGOG Posts: 9
    NerveGear
    Unfortunatelly, ADB-originated videos are still troublesome. That sound thing didn't go away. I discovered that one video has sound from home base, but no sound from application. And another video has good sound when on home screen, but ugly interrupting sound when in application. Copying via ADB only made it clear that videorepair1.5.zip actually did its best

    Update: I was also wrong about the only proper video. Different videos are about different applications. I mostly tried to show YouTube VR shortcomings like not being able to leave a comment or at least browse them. People sometimes pin important information there with e.g. timestamps and rely on our ability to see it. Definitely not in YouTube VR. So when YouTube VR has sound problems, that is soon becomes notable. And the "proper" recorded video was on Mission: ISS. It is mostly fine, but when I went to the part where I watch videos about ISS life, I can see clearly now, sound from those videos is missing, although station ambient sounds are present.

    So sound problems in all cases are related to media file playback, whether in YouTube VR or in Mission: ISS. I noticed Oculus has a complex system of audio in video channels. E.g. when I leave safe place, I can see borders myself, but not on record. And when I change safety zone, I can see my room in passthrough, but on video record my room is gone. Some tweaks are done with sound also, and it does not work good for playable media files.
  • dingofoxvrfoxdingofoxvrfox Posts: 43
    Brain Burst
    I have had no issues with video files at all you need a good high quality usb cable though and windows 10 professional for it to work right
Sign In or Register to comment.