Payments not working for no reason. — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Payments not working for no reason.

nmz3r0nmz3r0 Posts: 2
NerveGear
Hi, I just bought a Quest and when I was trying to add a payment method it simply did not work. After a number of tries with no results (It said "Something went wrong") I called the bank and they said it is 100% on the end of Oculus and nothing is wrong with my account or anything. Then I tried another card, no luck. I tried a PayPal, no luck. I am really puzzled about this and now it says "The payments have been disabled on your account because of unusual activity" Unusual activity resulting from a flawed system that does not accept valid payment methods... Yes I've already put in tickets about this but I want to see if there is a fix I can do like factor resetting.

Comments

  • OculusSupportOculusSupport Posts: 329 Oculus Staff
    Hey @nmz3r0, I'm sorry to hear about you're having issues adding a payment method. A factory reset would not likely help this issue but few other things that you can try are adding a payment method through a different web browser, different network, or use a different device. You can try adding a payment through our website here https://secure.oculus.com/my/payment-methods/. If you're still not able to add your payment, please make sure that you update your support ticket. Thanks! -Rick
  • nmz3r0nmz3r0 Posts: 2
    NerveGear
    I have tried using a web browser, different networks, and different devices. I tried that link as well. Nothing is working. It is obviously some block that you have put on my account mistakenly so please simply remove it.
  • freemotofreemoto Posts: 9
    NerveGear
    When you thought trying to give them money shouldn't be this hard... 
  • enigma01enigma01 Posts: 184
    Art3mis
    Something similar happened to me and I contacted Oculus on live chat 

    https://tickets.oculusvr.com/hc/en-us/requests/new

    They removed the lock on my account there and then and I could then re-add my payment method right away. 
Sign In or Register to comment.