New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

UE4 Rollercoaster [v1.0 Now with real physics!]

1679111215

Comments

  • I am using URE 4.4.3 and I am having the issue where after merging and putting in the plugin, I can not get any movement from the chair. When I look at the level blue prints, there is nothing there. I am trying to make a simple one speed coaster for a class Demo. I made sure that the game mode had both coaster settings in default. Any help would be great.

    Same problem here sadly. I understand the creator might not have time to update or should have to maintain it but it looks like most here haven't even got it working since the changes to physics and UE4.4 updates. I was going to make a cool musical experience without a visible track and stuff. :(
  • Teddy0kTeddy0k Posts: 205
    Hiro Protagonist
    Hey folks,

    If anyone needs help getting started, I've uploaded the full project file for UE4Rollercoaster including all the map with the blueprints;
    http://www.mediafire.com/download/q5nb49sx1n1b95w/UE4RollercoasterProject.zip

    Hope this helps with your projects!
  • Thanks, looks like it's all working now. :)
  • Wont work for me :(
    I try to run it (DK2) and I get the message
    'The program can't start because MSVCP120.dll is missing from your computer. Try re-installing the program to fix this problem.'
  • ZherkkZherkk Posts: 6
    Hey there !

    For my company OpenDay, I had the idea to create an oculus rift virtual reality experience on Mars for the visitors, to show them what it feels like to be on the red planet :p

    A few days after having this idea, I came on to this forum and decided to create a rollercoaster then, using Teddy0k's amazing plugin (thank you to him !). The result was not that bad and it had a lot of success during the OpenDay.

    Basically, I created a 1min30 rollercoaster ride zipping through the Gale Crater on Mars, which I reconstructed in Unreal Engine 4 from the true Digital Terrain Model (DTM) extracted from ESA's Mars Express satellite images. I uploaded it on Youtube so have a look if you're interested ! Here's the link :

    https://www.youtube.com/watch?v=YRnn7qnEhSk

    I'm using the first version of the plugin, which I modified a bit to include a more realistic acceleration/decceleration depending on the slope of the rail. Apparently looking at the last video you uploaded on youtube, you also improved it (and probably in a much better way than I^^). Anyway, I just wanted to share here my project and if people are interested, I would upload my (messy) code or the packaged project with pleasure !
  • Coolpool1Coolpool1 Posts: 7
    Brain Burst
    hello when i play i get ass frames i know my pc specs are not well great but the frames im getting are with playing low about 10 fps and on epic well 1 to 3 fps is there a way i can raise this because it happens with all my oculus rift games and im just not having a good time with my rift


    specs are and i know there shit but its what i have at the moment

    intel celeron (R) 2.16 ghz

    gpu intell grapics
    i know shit right if there is any thing i can do to boost my fps that would be greatly appreciated
  • acarrilhoacarrilho Posts: 402
    Hiro Protagonist
    Coolpool1 wrote:
    i know shit right

    Right.
    Coolpool1 wrote:
    if there is any thing i can do to boost my fps

    Nope.
    G3258 @4.4MHz
    GTX970
    8GB RAM
    Windows 7 64
  • pluggedinpluggedin Posts: 1
    NerveGear
    I must have tried the original demo when Teddy first released it, and it was cool then, but WOW! The physics changes the experience entirely. I almost feel immersed without the rift on - just looking at my monitor.
  • nike258203 wrote:
    For some reason whenever I try to run the game, it runs full screen on my monitor without the rift effect. I tried reinstalling all of the latest updates, however it is still not working.
    I had that problem - then I used the shortcut to run it - and it starts on the DK2
  • Hey,

    I tried making a rollercoaster in 4.4.3. All I ended up was a rollercoaster that didn't move and I couldn't move my mouse; if I tried it was immediately centered again.

    I also tried removing the set add velocity functions but that did nothing. I see others have reported the same problem - has anyone found a solution?
  • ZherkkZherkk Posts: 6
    Hey there !

    I packaged my project and uploaded it on my dropbox so that everybody can download and test it.
    Here is the link to the game : https://www.dropbox.com/sh/bdkbyfr0x02pbcm/AABHTjoJziPsTYBF-6nHpLaqa?dl=0

    Enjoy ! Remarks and comments are welcome =)

    Bye bye !
  • Any chance to have an updated version for 4.5?
  • GhettoRiceGhettoRice Posts: 19
    NerveGear
    Coolpool1 wrote:
    im just not having a good time with my rift

    intel celeron (R) 2.16 ghz

    gpu intell grapics

    The problem is your computer will never run any rift demo well with that rig, might as well sell it to someone who can get some use out of it.
  • For anyone on Mac OS X. Repackaged with UE 4.5.1 with OS X 10.10.1

    https://dl.dropboxusercontent.com/u/35694105/UE4Rollercoaster.zip

    enjoy! :D:D
  • r0cky0ng wrote:
    For anyone on Mac OS X. Repackaged with UE 4.5.1 with OS X 10.10.1

    https://dl.dropboxusercontent.com/u/35694105/UE4Rollercoaster.zip

    enjoy! :D:D

    Could you give Mac OS X plugin version?
  • dudieflukedudiefluke Posts: 21
    Brain Burst
    I really love this demo its the first one I show people that come round to try my rift. I do have one question/problem lately at the bottom of the screen I get a small fps counter flashing away how can I turn this off?

    Thanks
  • Is it possible to use this rollercoaster plugin on an existing rollercoaster 3d model, with a hanging seat? instead of the wagon going on top of the tracks? And, the tracks would be the ones in the existing rollercoaster structure, in that case.
  • Version for 4.5.1 please? It does not work with current.
  • I get some strange behaviour when I add a control point between two other control points. I.e. I've created a complete spline, the player pawn moves around it nicely. Then I insert a control point somewhere along the spline. When I now run the game the pawn move around the track and at specific point jump to an other segment, moves some more and jumps back. It seems to me what happens is that the pawn is moved between the control points in the order that they are created, but this might be wrong. I have looked into the code of the plugin, but I'm not familiar enough with UE4 to see what's wrong and what I should change.

    Edit: I have played around a bit more, and when inserting control points what happens is that the pawn travels the wrong way on some segments and than jumps to the next. What decides the way the pawn travels and the rotation it has?

    Edit:


    I've downloaded the plugin source from github and added it to a 4.5.1 first person shooter C++ project, and as far as I can tell it works nicely, except for the issue I've described.
  • edstoicaedstoica Posts: 1
    NerveGear
    hey brother,

    thanks for this great work.

    your rollercoaster is our favorite demo.
    we show it for free to our guests in our blacklight minigolf park.


    we made a special chair for the demo.
    the chair is so high that your feets do not touch the ground. (the guy on the photo is very tall). and the chair is similar to the rollercoaster chair ;)

    every guests signs a survey after the ride. i guess we have about 1500 surveys already.
    mostly the persons are blasted and satisfied.

    common pro's:
    - strong immersion
    - looking down beside the chair gives real feel of height.
    - impressive 3D
    - first rollercoaster-drop-down is most scary
    - real feel of scale

    common con's:
    - 50% have some kind of soft sea-sickness after use
    - some are real dizzy (but no real-strong problem yet)
    - the chair is empty
    - the legs are felt to be inside the chair
    - some turns are not smooth
    - to look down when the coaster drives down is not natural


    but reactions are greatly varying by individual or by grouped individuals.
    if one freaks out and shouts loud while driving, the others get "inspired" and do similar. funny psychological phenomenas.

    if you are interested, i can send you more data from these surveys.

    for some editing i decided to get an unreal engine account and downloaded the software. its version 4.6
    then i tried to activate you plugin. but it does not work. i get the error
    "the following modules are build with a different engine version:
    UE4Editor-RollercoasterPlugin.dll
    Would you loke to rebuild them now?"

    but this doesn work.

    can you supply a 4.6 compiled version of your plugin?


    one world one family!

    btw: i would like to send you an email. can you supply me an adress?
  • Teddy0kTeddy0k Posts: 205
    Hiro Protagonist
    Hey folks,

    I've uploaded an update version of the RollerCoaster plugin for Unreal 4.6.1;
    http://www.mediafire.com/download/az87qdqxc1yqx4s/RollercoasterPlugin_v4_6_1.zip

    Good luck with your projects, can't wait to see what you guys&gals make!
  • Hi Teddy and thanks a lot for this amazing work.

    I'm afraid your last plugin version isn't working with 4.6.1, saying the "modules missing or different engine version" error (btw the .uplugin file having its "last edited" date in august), are you sure you havn't messed up with the files? ;)

    Thanks again et keep up the hard work !


    Fitz
  • Hi there !

    I've rebuild the whole Unreal Engine with the latest plugin sources and everything seems to work now, except the fact that I don't have the Level Blueprint showing, and that the kart isn't moving at all : I'm downloading the full package Teddy uploaded 2 pages before, and I'll try to find a solution ;)


    Thanks !
  • Hi Fitzrurisk and/or Teddy,

    it would be quite cool, if you get it running again. Let uns know if we could help you in any way.

    Thanks in advance
  • barryzundelbarryzundel Posts: 39
    Brain Burst
    Hello all! Just downloaded the latest plugin, and copied it to my project directory and engine folder, and I'm getting an error when I load the editor that says that the plugin was complied for a different version of the engine (I'm in 4.6.1), then tries to convert it. It can't, so it tells me I should compile it manually. I removed the plugin from the Plugins folder, and then tried to restart the editor, and now the editor won't open because the plugin is not there. Now I can't get into my project. Is there a way to "uncheck" the plugin without being in the editor? Thanks.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    @barryzundel: I'm not sure your question has anything to do with the roller-coaster app. Can you create your own thread in the right section (if you are on Unreal 4, then post in the Unreal 4 Integration section) and provide details as to your OS version and system specs? Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • @barryzundel Just open your *.uproject file with a text editor and remove the plugin you don't want to use (here something like :

    "Plugins": [
    {
    "Name": "RollercoasterPlugin",
    "Enabled": true
    }
    ]"


    Fitz
  • Somebody please plase help me!

    I get the following message every time.


    "The following modules are missing or built with a different engine version:

    UE4Editor-RollercoasterPlugin.dll

    would you like to rebuild them now?"

    I have ue 4.6.1 and the same for the plugin, and copied the folders just like the youtube video says. Content folder to project, and plugin folder to engine ... > runtime.

    Please somebody help me, I really need this and I tried everything I can to make it work, but nothing seems to help.

    I would be very very thankfull!
  • DanielJonesDanielJones Posts: 6
    NerveGear
    I'm having the same problem :cry:
  • I'm also having the same problem
    Help please!
Sign In or Register to comment.