Oculus Rift S not connecting.. — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S not connecting..

Fistful_of_AshFistful_of_Ash Posts: 1
NerveGear
Hi,

So today I bought a brand new Oculus Rift S from Argos. Before installing the Oculus software I plugged it in and there was a light showing on the headset but it just made my screen go black. After that, I installed the software but any attempt at plugging it in a light never came on and nothing happened at all, it was like it wasn’t plugged in.

So I took it back and they’re delivering a new one to me tomorrow morning. I’m hoping to god that works but I have a massive feeling it won’t, my PC does meet the minimum requirements so it should be working fine.


Things I already tried:
Repairing the software
Unplugging and replugging it in (waiting 5 seconds etc)
Tried all USB ports, even on another PC and no matter what, no light comes on the headset.

After taking it back I’ve made sure all my drives are up to date.

Can you please provide me with any solutions incase i get the same issues tomorrow which I believe I will as I probably made a mistake replacing it haha.

Thanks in advance 

Comments

  • Techy111Techy111 Posts: 6,338 Volunteer Moderator
    What are your specs for your PC mate ??
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

  • dburnedburne Posts: 2,591 Valuable Player
    edited September 7
    Well first thing is not to plug the headset in before you have the software installed.
    After starting setup, it will walk you through the process and prompt you when to put the headset on.

    I would uninstall the software first and start over fresh. I suggest doing the below to uninstall - I also suggest going ahead and doing this now.

    Disconnect your computer from the internet.Back up any Oculus content if you want to.  (This step is completely optional.)Reboot your computer into Safe Mode. Uninstall Oculus Home using the Control Panel.Delete all Oculus folders from here:
    • C:\Program Files
    Remove any Oculus folders from here:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    Reboot your computer into normal mode.Reconnect the computer to the internet.Reinstall Oculus  with a new installer once you have the new headset in hand.
    Also yes as Techy mentioned please list all your system specs. Motherboard, CPU, Ram, GPU, etc.




    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
Sign In or Register to comment.