New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift keeps crashing, PC too under powered?

I'm very new to PC gaming, so please bear with me. I have Ryzen 7 2600x with an RTX 2070, 16GB ram. So far, my Rift S seems to not like it. I think.
I get maybe 20 minutes of gameplay, then a low prolonged beep, static, then all black. An orange light flickers in the headset, slow at first but then gets faster. After, I always get a message to update firmware. Then, everything seems ok, but after a few minutes gaming it repeats the whole process. 

I absolutely love the Rift, and this is my first introduction to VR. But after purchasing it two days ago and having to constantly deal with this, I'm getting very frustrated. Any advice or suggestions on how to fix this would be greatly appreciated. Thank you.

Comments

  • TheOfficialPDTheOfficialPD Posts: 2
    NerveGear
    I don't know if this will help you much but I can defiantly tell you how my first experience was when I tried setting up my Rift S. 

    I first unopened the box. Connected it. Then tried to attempt to run it without the Oculus software. After that, I tried to painfully find the software driver for this device while downloading SteamVR. Then I would run the Oculus Rift S Software to apply updated firmware updates to the device which took about an hour or so. When that was done I believe it would ask for you to restart your computer. Then you would be done from there. Boot up your PC and bam, you're all set. If you use Steam, there were recently minor changes but mainly keep those software up to date to avoid those issues.

    Your rig should be able to handle it. I wouldn't see why it will not. Unless it's the CPU compatibility requiring Intel instead of AMD, but I doubt that. 

    My setup is Intel-i7 6700K, Geforce GTX 970, 32GB Corsair Ram, 1TB HDD.
  • OcuclopsOniOcuclopsOni Posts: 14
    NerveGear
    thanks for the response. I am pretty up to date with firmware and updates. I am going back and forth with tech support, so hopefully it all works out. I really am enjoying my time with the headset when its playable. Would love to hold on to it, but would return it if it keeps acting up the next few days. 

  • RattyUKRattyUK Posts: 1,109
    Wintermute
    Not CPU - I can vouch for that!
    Maybe USB - stuck record but...   Is USB Power Management set to not switch off to save power?  You can access either through power settings or Device Manager, all USB Hubs properies / Power Managment should be set to off.
    The time before it crashes out could be simply that.
    PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.
    Rift S
    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)
  • OcuclopsOniOcuclopsOni Posts: 14
    NerveGear
    After going back and forth with help, I was told that multiple USB errors kept popping up in the log that I was asked to send their way. After looking more into USB problems, uploadvr.com had an article on troubleshooting this. It was suggested to use the virtual link port that my graphics card has (not all gpu's have this, apparently. I was lucky enough to have one). Was able to play 2 full stages of Robo Recall so far without any issues. I was not able to go 2 minutes before. So, so relieved. 
  • Digikid1Digikid1 Posts: 2,073 Valuable Player
    What brand/wattage is your power supply. 
  • OcuclopsOniOcuclopsOni Posts: 14
    NerveGear
    edited September 2019
    Digikid1 said:
    What brand/wattage is your power supply. 
    Channel Well gps600s-g PSU
    600 watts
  • OcuclopsOniOcuclopsOni Posts: 14
    NerveGear
    Well. Damn. Now it keeps saying that the display port is not connected over and over. That is messing with the connection now. I'm thinking about giving up and just returning it. 
  • CBET-117CBET-117 Posts: 1
    NerveGear
    Hi everybody, i have a temporal solution for the ones who keep getting the beep and static sound after several minutes playing... What i did was that i uninstalled the nvidia drivers, then, i updated the firmware and the usb controllers. Once i did this, I just installed the 417.71 version of Nvidia Drivers ( From the official Nvidia page ). I restarted and everything is working fine now... I'v been playing for several hours without any beep, static and black screen crash.

    PD: If you don't know where the device manager is, just press "Windos button + R" and then type "devmgmt.msc" without the quotation marks.
Sign In or Register to comment.