New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S / Rift 1.41 Release Rolling Out Now

ShowbizDonkeyShowbizDonkey Posts: 118 Oculus Staff
edited October 16 in Oculus Rift S and Rift
Home
  • We’ve added an Announcements window that shows when you first open your Home. Here you can find info about new items, reward packs, friend’s homes, and more.
  • When you receive a new item for your home, the blue notification indicator will show until you pull the item out of your inventory.
Payments Desktop App
  • We’ve made updates to improve the performance of your library panel and reduce overall load time in the Oculus desktop app.  

Comments

  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    Hopefully it's a slow roll out because 1.40 is already working very well with my Rift cv1, lol!  Pretty lean release notes imho.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • DuxCroDuxCro Posts: 20
    Brain Burst
    Did i dream that or was this announcement already made back in ....August? And this post had a lot of comments with people complaining about 1.41 messing things up? Now deleted comments?
  • NetheriNetheri Posts: 230
    Nexus 6
    Does the panel pullout work now? Or have at least changed the excalamation mark to some other mark for just a little bit of change?  :D
    [email protected], Gigabyte 2080 Gaming OC, Corsair 32gb [email protected] DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • KlodsBrikKlodsBrik Posts: 1,193
    Wintermute
    DuxCro said:
    Did i dream that or was this announcement already made back in ....August? And this post had a lot of comments with people complaining about 1.41 messing things up? Now deleted comments?
    You didnt. However this is the final release, whereas the one you mention was the beta / public test channel.
     Now its finished and released for the masses.
    Be good, die great !
  • ShowbizDonkeyShowbizDonkey Posts: 118 Oculus Staff
    Richooal said:
    Oh boy, this is gonna confuse some people. When they see you've removed "Rift S" from the title of the post, they're gonna think Rift S is dead.
    Updated! :smile:
  • kojackkojack Posts: 5,530 Volunteer Moderator
    KlodsBrik said:
    DuxCro said:
    Did i dream that or was this announcement already made back in ....August? And this post had a lot of comments with people complaining about 1.41 messing things up? Now deleted comments?
    You didnt. However this is the final release, whereas the one you mention was the beta / public test channel.
     Now its finished and released for the masses.


  • huliqanhuliqan Posts: 35
    Brain Burst
    Perfect now!!! 1.41 is Best!!!
    in 1.40 my oculusClient rebooting often .in 1.41 all works fine!
  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    Ok, I just got the new final 1.41 and all seems to be working fine with my Rift cv1 w/2x sensors.  Thanks Oculus!

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • 1029chris1029chris Posts: 1
    NerveGear
    The dash has an issue, my fingertips don't collide with buttons anymore, I now have to embed my hand halfway through the button before it presses. It's making typing difficult.
  • RichooalRichooal Posts: 1,144
    Wintermute
    edited October 2
    I just had something happen that really shouldn't, and hasn't before with any other Oculus Version.

    I just started my PC and did a bit of web browsing using my regular Waterfox browser. I then started my Oculus desktop app, from my Task Bar shortcut, and found this .................



    My browser and Oculus Software aren't related, connected, conjoined or whatever. So why does Oculus need to display this as if it had something to do with it?
    Anyone else have this happen?
    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    edited October 3
    1029chris said:
    The dash has an issue, my fingertips don't collide with buttons anymore, I now have to embed my hand halfway through the button before it presses. It's making typing difficult.
    Actually I had a similar thing happen to me a little while ago.  After a pretty long session of X-Plane 11 in VR, when I exited and went back to my Oculus home I could not seem to get any response when pressing the Dashboard buttons with my VR index finger.  I could point the controller and use the fire button though.  I exited the Oculus App, then restarted it, and all was fine again. 

    I wonder if this is a memory leak thing like we had early this year (1.34?)?  I cannot remember what we did to fix this, think it required nvidia inspector and changing the P2 state?  This option does not appear to be available with my gtx1080ti with the latest nvidia inspector so I cannot try it anyway.

    Next time this happens I'll exit the oculus app, download a logfile, and send it off to Oculus Support.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • HailHogeHailHoge Posts: 22
    Brain Burst
    buffer overrun...invalid memory pointer...

  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    Well, this dash pointer problem happened again so I have collected my logs and sent them to Oculus Support with the following note;

    After using any Steam or other external app (like X plane 11) for ~ 1 hour and then go back to my Oculus Home the Dash buttons do not work properly.  I need to either move the VR touch controllers hands right through the buttons or point and shoot at them to get them to work.  If I exit the Oculus app and restart it everything works fine again.  I have never had this happen with previous versions like 1.40.  This is with a Rift cv1 w/2x sensors btw.

    Hopefully this will get sorted out soon.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • AhamsAhams Posts: 8
    NerveGear
    TomCgcmfc said:
    Well, this dash pointer problem happened again so I have collected my logs and sent them to Oculus Support with the following note;

    After using any Steam or other external app (like X plane 11) for ~ 1 hour and then go back to my Oculus Home the Dash buttons do not work properly.  I need to either move the VR touch controllers hands right through the buttons or point and shoot at them to get them to work.  If I exit the Oculus app and restart it everything works fine again.  I have never had this happen with previous versions like 1.40.  This is with a Rift cv1 w/2x sensors btw.

    Hopefully this will get sorted out soon.
    Dash pointer broken for me too. Dont know what you guys did, but it broke the dash pointer, when i want to touch anything with my virtual hands, in the Dash menu.
  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    edited October 3
    I'm really not getting very much help from Oculus Support on this.  As instructed; did the driver updates, restart, Repair and this did nothing.  Now they want me to do a full uninstall/reinstall, lol!  Hmm, might try 1.42ptc and see if this is any better.

    Update; Switched to 1.42 ptc and this seems to have fixed all my dashboard problems.  Also nice to be able to select whether or not you want to start in your Oculus home or Homeless (Oculus App/setting/general switch is at the bottom of this pane.  Homeless seems to work well and more than halves my cpu/gpu usages compared to within even a pretty bare Home.  I cannot say it makes much difference when you actually go to an app though.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • snowdogsnowdog Posts: 7,035 Valuable Player
    It won't make any difference going into an app because Home shuts down at that point so isn't using any resources.
    "This you have to understand. There's only one way to hurt a man who's lost everything. Give him back something broken."

    Thomas Covenant, Unbeliever
  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    edited October 3
    Ya Snowie, I agree.  Might free up a little memory though.  I have not had time to check that out yet.  Still kinda sad that I needed to update to a PTC (1.42) to solve a problem with final 1.41, lol!

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • RichooalRichooal Posts: 1,144
    Wintermute
    TomCgcmfc said:
     Also nice to be able to select whether or not you want to start in your Oculus home or Homeless (Oculus App/setting/general switch is at the bottom of this pane.  Homeless seems to work well and more than halves my cpu/gpu usages compared to within even a pretty bare Home.  I cannot say it makes much difference when you actually go to an app though.

    I can't believe I'm reading this! I've never wanted to be homeless in RL, but looking forward to it in VR. :o
    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • SnowPine1994SnowPine1994 Posts: 1
    NerveGear
    Since updating to ver.1.41, the LCD often blacks out, and hand tracking is also delayed. Please tell me how to downgrade to ver.1.40.  :(  
  • RichooalRichooal Posts: 1,144
    Wintermute
    Since updating to ver.1.41, the LCD often blacks out, and hand tracking is also delayed. Please tell me how to downgrade to ver.1.40.  :(  

    Not possible to downgrade I'm afraid. Everyone is forced onto the latest version. You could try the PTC version 1.42
    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • lostsoul_mshlostsoul_msh Posts: 1
    NerveGear
    assetto corsa stop working after update 1.41 :/
  • TomCgcmfcTomCgcmfc Posts: 1,369
    Project 2501
    assetto corsa stop working after update 1.41 :/
    That's not true for me with either 1.41 final or 1.42 ptc with my Rift cv1 w/2x sensors.  I doubt that these would effect Rift S either.

    Can you play AC in 2D flat screen mode?  I not, maybe try reinstalling AC and try again.  Also, maybe update your graphics driver.

    Otherwise, start a ticket with Oculus Support and see if they can trace the problem from your logfiles.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • dburnedburne Posts: 2,711 Valuable Player
    edited October 16
    Ah the good ole Red X is back, guess the Rift S software just does not like me having the Rift S mic disabled. It says I have no audio LOL.
    Too bad the mic was such a defective weak spot of the Rift S, at least for me. My USB mic working great.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
Sign In or Register to comment.