New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How to check USB-C compatibility?

DinnoOculusDinnoOculus Posts: 3
NerveGear
edited October 2019 in Oculus Quest 2 and Quest
Hello,
(I do my best in English... please forgive me if you don't understand everything.)

I have issues connecting my Quest to my PC:
-it charges only when OFF.
-continues charging if connected when switched ON. but stops if I reconnect the cable afterwards.
-no "accept connection" alert... ever...
-does appear as a hard drive only when OFF.
-Unity doesn't find it when I "build & run", neither ON or OFF.

BUT, when I try to connect it to another PC/Smartphone/Laptop (5 tried!):
-charges when ON
-shows "accept connection" alert immediately
-appears as a hard drive...

So:
-No problem with my Quest
-No problem with my cable (the one bought with the Quest)
=> The problem comes from my PC

I tried to update every driver, checked the BIOS: nothing....
Searched on forums: nothing BUT I have a possible hint.

Is there a compatibility problem with my USB-C port, on the PC?
I've read somewhere the Quest needs 2.5A minimum, but does my PC port allow that much? I think that it would explain everything, but I'm not an expert at all!
If this may be the problem, how do I check that?

I need this PC to work, not any other.

I tried in developer mode on and off...
Now it is off, so I have the "accept connection" when I connect to another device.

Recap:
What kind of USB port is needed for the Quest? (in terms of protocol, power, intensity....)
How do I know what the PC do have?

Help me please... I did my best but I'm locked!

Answers

  • nalex66nalex66 Posts: 5,922 Volunteer Moderator
    edited October 2019
    You could try a different cable, either a USB 3 C to C, or a USB 3 A to C. The charging cable that comes with the Quest is only USB 2.0, although the Quest itself is capable of USB 3.0. 

    I bought this cable to connect to my PC, because I don’t have a USB C port, and I haven’t had any trouble with it. 
    i7 5820K @ 4.25GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
    SSDs: Intel 660p M.2 2TB, Samsung 860 Evo 1TB, 850 Evo 1TB, 840 Evo 1TB | Startech 4 controller PCIe USB 3.0
  • DaftnDirectDaftnDirect Posts: 6,179 Volunteer Moderator
    edited October 2019
    Can you post your specs @DinnoOculus ?  particularly what motherboard (if the USB-C socket is on the motherboard) or is it a socket on the front panel? or if it's a laptop, what laptop?

    Am I right in assuming you PC doesn't have a second USB-C socket you can try? I'm just wondering if the socket has slight connector damage. Or if it's a front panel connector, the cable may not be properly seated on the motherboard header.
    The other possibility is the USB-C socket is connected to a USB 2 header but that seems unlikely.
    Intel 5820K [email protected], Titan X (Maxwell), 32GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v2004 (19041.508)
  • SpuzzumSpuzzum Posts: 843
    3Jane
    I've had issues with the cables, both the official cable that comes with the Quest, as well as a shorter cable I bought from Amazon. The official cable would give power, but no data connection. I found it was due to the cable being bent near the Quest's usb-c port itself. Not stressing the port, but the wiring in the cable itself. The cable I bought from Amazon was doing perfect...up until a few days ago. Now...depending on how the plug is inserted, I either have communication or I don't. If no communication, I pull the plug, flip it over, then plug back in. All of a sudden, the message pops up on the pc showing it recognizes the connection. Sometimes it's the plug to the pc, sometimes it's the plug to the Quest. It's frustrating as hell.
  • SpuzzumSpuzzum Posts: 843
    3Jane
    Ok...figured it out. I just spent the last 30+ minutes trying to connect my Quest to upgrade Virtual Desktop, and no matter what I did, it just wouldn't connect. Then googling, it seems you just need to delete the adb keys, then recreate them.

    Go to C:/Users/username/.android, then delete adbkey and adbkey.pub, then open a terminal, direct yourself to adb, and run 'adb devices'. It then shows the connection, and you get the prompt in the Quest. Before deleting the keys though, it would just be blank, showing no connection.
  • DinnoOculusDinnoOculus Posts: 3
    NerveGear
    I'm waiting for a potential solution:

    It seems my usb-c port is usb 3.0.
    I tried on a laptop with usb 3.1: it worked.
    I tried on another pc, with usb 3.1: it worked.

    So, I'm waiting for an usb-c 3.1 socket, I will tell you if everything is solved!
Sign In or Register to comment.