New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Quest won't connect to PC on developer mode since last update

rmib200rmib200 Posts: 4
NerveGear
edited October 2019 in Support
Since last update I can't connect my Quest on Developer Mode to my PC. I have to turn off developer mode so that my pc can recognize my device. When I switch on, i never recognize it. No matter how many times I try to switch on/off developer mode. I need the developer mode for work. I tried reinstalling the ADB controllers since it fixed the first time, but now it doesn't work. Any help? I use a Windows 8.

Comments

  • wispherenwispheren Posts: 1
    NerveGear
    Thank you!

    I thought I was going mad. I just got my Quest on Monday, and for the past three days I have tried to connect the Quest to my PC in developer mode, and no matter what I do, it just refuses to connect with developer mode enabled.

    There are a ton of guides that all make it seem so easy, but all of them just mentions that I should respond to the prompt in the headset, when I have installed the ADB driver, enabled developer mode and plugged it in - but no prompt ever shows up.

    However the instant I disable developer mode, the prompt to allow the pc to share files shows up.

    But it makes sense if it is due to a recent update, as my Quest updated itself as the very first thing, when I turned it on and connected it to my Wifi.

    So has anyone gotten developer mode to work on newest update?
  • jonmalavejonmalave Posts: 1
    NerveGear
    edited October 2019
    Hello,

    I am not able to connect a brand new Quest to my PC either. I continue to see Unknown USB Device Error in Device Manager and Notification upon connecting to PC.

    I get the same Error whether Developer Mode is On or Off. I am using a USB-C to USB Cable, I have tried connecting to various USB 2.0 and 3.0 Ports nothing works. Finally, I have tested this on my PC with Windows 8.1 and Laptop with Windows 10. I continue to see the Error on both Window OS versions.

    Please assist.
  • zeljko.zoriciczeljko.zoricic Posts: 3
    NerveGear
    I face the same issue. Help, anyone? It will be strongly appreciated.
  • Fisher007Fisher007 Posts: 13
    Brain Burst
    Same here, which is pretty messed up as I was working with it happily 3-4 weeks ago. 
  • MeatballmachineMeatballmachine Posts: 6
    Brain Burst
    Same prob here. Still no answers, this is very frustrating, Oculus

  • Fisher007Fisher007 Posts: 13
    Brain Burst
    Found the solution! Actually the Oculus forums have subsections, we are in the community one and this question is more something that is occurring for developers, so it worth to check the developer sections in the future. 

    So the solution is:
    "1. Open Device Manager
    2. Find "Interface ADB" and  "Interface XRSP"
    3. Click the right mouse "Interface ADB"
    4. Сlick on the menu "Update Driver"
    5. In the window, click "Browse my computer for driver software"
    6. In new window, click "Let me pick from a list of device drivers on my computer"
    7. Search "Oculus VR, LLC." and click
    8. Choose "Oculus ADB Interface"

    for the Interface XRSP to do the same BUT choose "Oculus Bootloader Interface"

    now QUEST drive in Windows Explorer

    then I change "Oculus ADB Interface" to "Oculus Composite ADB Interface""

    It was a bit different for me, but tried similar steps and it worked eventually. Also when searching in the list, I didn't have Oculus VR, I had to choose Samsung Android Phone, then another list popped up and there was Oculus VR, LLC. So apparently if you used ADB with a different phone maker previously, it might be installed under their name.
  • MeatballmachineMeatballmachine Posts: 6
    Brain Burst
    None Of This Works! Oculus please fix this mess! Link is going to be a disaster for some of us. Get your drivers straight


  • TheCrowingTheCrowing Posts: 3
    NerveGear
    I'm also having this problem.  It seems to only connect to the computer if Developer Mode is turned off.
  • Silenced_PandjaSilenced_Pandja Posts: 1
    NerveGear
    I found a way to do it. Using SideQuest you can access the files on the oculus when you plug it into the computer when in developer mode. 
  • chenxeedchenxeed Posts: 1
    NerveGear
    I'm using Linux Ubuntu as my OS and I found the similar problem here, can't connect to PC while in developer mode. Need help.
  • JeeMoRJeeMoR Posts: 2
    NerveGear
    edited January 2020
    Fisher007,

    Words-can-not-express how grateful I am to you for your solution. Except I haven't found it yet, but I think you are the only one with the real solution to this 'hair-pulling' level annoyance of the quest. I was so close to returning the device. Thanks again man. You are a life-saver!!!
  • JeeMoRJeeMoR Posts: 2
    NerveGear
    Fisher007 said:
    Found the solution! Actually the Oculus forums have subsections, we are in the community one and this question is more something that is occurring for developers, so it worth to check the developer sections in the future. 

    So the solution is:
    "1. Open Device Manager
    2. Find "Interface ADB" and  "Interface XRSP"
    3. Click the right mouse "Interface ADB"
    4. Сlick on the menu "Update Driver"
    5. In the window, click "Browse my computer for driver software"
    6. In new window, click "Let me pick from a list of device drivers on my computer"
    7. Search "Oculus VR, LLC." and click
    8. Choose "Oculus ADB Interface"

    for the Interface XRSP to do the same BUT choose "Oculus Bootloader Interface"

    now QUEST drive in Windows Explorer

    then I change "Oculus ADB Interface" to "Oculus Composite ADB Interface""

    It was a bit different for me, but tried similar steps and it worked eventually. Also when searching in the list, I didn't have Oculus VR, I had to choose Samsung Android Phone, then another list popped up and there was Oculus VR, LLC. So apparently if you used ADB with a different phone maker previously, it might be installed under their name.
    THANK YOU!!!!!!!!!!
  • TokyosushiTokyosushi Posts: 1
    NerveGear
    Fisher007 said:
    Found the solution! Actually the Oculus forums have subsections, we are in the community one and this question is more something that is occurring for developers, so it worth to check the developer sections in the future. 

    So the solution is:
    "1. Open Device Manager
    2. Find "Interface ADB" and  "Interface XRSP"
    3. Click the right mouse "Interface ADB"
    4. Сlick on the menu "Update Driver"
    5. In the window, click "Browse my computer for driver software"
    6. In new window, click "Let me pick from a list of device drivers on my computer"
    7. Search "Oculus VR, LLC." and click
    8. Choose "Oculus ADB Interface"

    for the Interface XRSP to do the same BUT choose "Oculus Bootloader Interface"

    now QUEST drive in Windows Explorer

    then I change "Oculus ADB Interface" to "Oculus Composite ADB Interface""

    It was a bit different for me, but tried similar steps and it worked eventually. Also when searching in the list, I didn't have Oculus VR, I had to choose Samsung Android Phone, then another list popped up and there was Oculus VR, LLC. So apparently if you used ADB with a different phone maker previously, it might be installed under their name.
    Thanks! Stupid Quest wasn't connecting and I noticed the exclamation points and your advice fixed it! Thanks 
  • dave.anteparadave.antepara Posts: 10
    NerveGear
    after 11 days with support i finally got link up and version 13 on pc and quest . now 3 days later i get firmware update required so i cant use link and virtual desktop wont work as quest cant connect to computer and there is no way to update just have to wait , there needs to be a better way to get updates like a update switch that actually updates . this down time is just not acceptable. why is a unit that has no problems made non functional for unknown period of time waiting for a update , leave it working until update is deployed then disable it and update so there is minimal down time. 
  • dane.mahardane.mahar Posts: 1
    NerveGear
    I have tried all of these "fixes" and still have the same problem as everyone else. Oculus is straight trash. Wish  I could get my money back from these turds.
  • spyrospyro Posts: 344
    Art3mis
    Same problem here. Quest isn't even detected any more.
  • JuupuJuupu Posts: 1
    NerveGear
    chenxeed said:
    I'm using Linux Ubuntu as my OS and I found the similar problem here, can't connect to PC while in developer mode. Need help.
    Did anyone find a solution yet? I have the same problem
  • vr_maxvr_max Posts: 1
    NerveGear
    After I installed the Oculus drivers in Windows 10 the device manager showed the entries under "USB Devices". Nevertheless the Quest was not recognized when I connected it to the PC. Looking at the driver details it said the installed drivers were from Microsoft which confused me. The solution from Fisher007 did not work for me because the "Oculus VR, LLC." entry does not show up in the driver list. I fiddled around and was able to get a PC connection by switching the developer mode in the Oculus mobile phone app off and on again while the Quest was connected to the PC. I then started Sidequest and was able to use it. I got two notification windows in the VR environment, the second one being the proper one with the checkbox ("Always allow this connection..."). Maybe this helps someone.
  • Yeetz44Yeetz44 Posts: 1
    NerveGear
    after buying an oculus quest 2 I can safely say that I'm having this exact same issue.
Sign In or Register to comment.