New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Buying Asgards Wrath

ChunkybabbitChunkybabbit Posts: 3
NerveGear
I appear to have a problem with the store. Trying to buy Asgards Wrath, firstly I can't do so in the PC app, it sends me to the web page to purchase.
At the web page store, I've pressed buy, put my pin in, clicked purchase, and it just sits there with purchase greyed out and not doing anything else. Is this a problem my end or with the store? I see lots of other people have managed to buy the game, and reddit doesn't appear to mention anything wrong outside of some preorder problems earlier

Comments

  • ChunkybabbitChunkybabbit Posts: 3
    NerveGear
    Actually it seems I can't use the store at all. I just tried with a purchase of Vader immortal and the same thing happens. Everything looks to be ok otherwise; profile, payment methods are there etc. Just can't buy anything.
  • RuneSR2RuneSR2 Posts: 3,436 Valuable Player
    Try the Oculus phone app - and be patient if the phone app loads for a long time - worked for me (Android). 
    Intel i7 7700K (4.5 GHz); MSI GeForce GTX 1080 8GB Gaming X (oc 2100 MHz gpu boost, 11 GHz mem speed); 16GB Corsair Vengeance LPX DDR4 3200 MHz; MSI Z270I Gaming Pro Carbon AC (VR-Ready) mainboard; Samsung 960 Evo M.2 SSD + Toshiba P300 HD; Windows 10 OS; Valve Index and Oculus Rift CV1 - the latter nearly always using super sampling 2.0. 

    "Ask not what VR can do for you – ask what you can do for VR"
  • ChunkybabbitChunkybabbit Posts: 3
    NerveGear
    It seems to be something to do with payment method. I've managed to buy the game by adding paypal to my account and buying from the store within the headset. But my son's account is now behaving in the exact same way and he's getting the message 'unable to add payment method. This is not shared on the same PC or anything. His is a totally different machine. Anyone know what's going on with this? neither of us are new to Oculus. Everything has been fine till now.
    Done a reinstall of Oculus software and everything else seems to be fine. Just purchases are a no no.
Sign In or Register to comment.