New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus software restart required wont go away, black screen in headset - Rift S

Whenever I connect my headset the software keeps saying that I need to restart my Oculus Software, done so multiple times, still wont go away. If I try to ignore the message then all I will see in my headset is a black screen. The headset is connected and active and the light on the headset is either white or orange. I've tried updating all my drivers (nvidia, usb, device manager, windows, oculus), tried the PTC, went out of the PTC, turned camera settings on and off in windows too. I've sent a message to Oculus Support about a week ago and still have not even recieved an answer... I haven't been able to use my Rift S for more than a month and it only really feels like a waste of money now that I can't even return it since I bought it in June... worked fine then but ever since I tried my rift S after 1.39 I've had this issue.

Comments

  • dburnedburne Posts: 2,780 Valuable Player
    Well the light in the headset should be white, if orange that reflect a problem like maybe needing a firmware update or it is not being recognized.

    Try a manual uninstall of Oculus:

    1. Disconnect your computer from the internet.
    2. Back up any Oculus content if you want to.  Click here for instructions. (This step is completely optional.)
    3.  Reboot your computer into Safe Mode. For instructions, click here.
    4. Uninstall Oculus Home using the Control Panel.
    5. Delete all Oculus folders from here:
      • C:\Program Files
    6. Remove any Oculus folders from here:
      • C:\Users\YourUserProfile\AppData
      • C:\Users\YourUserProfile\AppData\Local
      • C:\Users\YourUserProfile\AppData\LocalLow
      • C:\Users\YourUserProfile\AppData\Roaming
    7. Reboot your computer into normal mode.
    8. Reconnect the computer to the internet.
    9. Reinstall Oculus Home with a new installer by clicking here.


    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • blanesblanes Posts: 1,096
    3Jane
    Great advice,  have bookmarked this in case I ever need to do the same, cheers mate :smile:
  • GammaTheBananaGammaTheBanana Posts: 2
    NerveGear
    dburne said:
    Well the light in the headset should be white, if orange that reflect a problem like maybe needing a firmware update or it is not being recognized.

    Try a manual uninstall of Oculus:

    1. Disconnect your computer from the internet.
    2. Back up any Oculus content if you want to.  Click here for instructions. (This step is completely optional.)
    3.  Reboot your computer into Safe Mode. For instructions, click here.
    4. Uninstall Oculus Home using the Control Panel.
    5. Delete all Oculus folders from here:
      • C:\Program Files
    6. Remove any Oculus folders from here:
      • C:\Users\YourUserProfile\AppData
      • C:\Users\YourUserProfile\AppData\Local
      • C:\Users\YourUserProfile\AppData\LocalLow
      • C:\Users\YourUserProfile\AppData\Roaming
    7. Reboot your computer into normal mode.
    8. Reconnect the computer to the internet.
    9. Reinstall Oculus Home with a new installer by clicking here.


    Okay, I'll try this tomorrow, I'll let you know if it works then! Thanks in advance!
  • gcbraungcbraun Posts: 2
    NerveGear
    This issue has been bothering me for weeks. I already re-installed everything like described above and made sure that I am using USB 3.0 and not USB 3.1 port.

    I have tried both the regular and the test-channel software, with no luck.

    Anything else I can do?
Sign In or Register to comment.