New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Quest won't turn on. Beep-on/off is audible, no image but white light is on/off (Solved)

raronraron Posts: 31
Brain Burst
edited November 4 in Oculus Quest
I'm pretty new to the Quest, had it for under a week but only used it a couple of times. It was working OK just now, except it didn't have WiFi connectivity even though it was "on" and listed my WiFi network in settnigs. Turning WiFi off and then on again, and then it couldn't find my WiFi or any other WiFi's whatsoever. That's when I decided to try the 'ol "turn it off and then on again" trick, but ofc it won't turn on either...

When I turn it on, there's the turn-on sound, and the white light turns on. But there's no image (I can see the display backlight turns on as well). Turning off and there's a turn-off sound and the light goes off. Except when it's charging, then the light stay orange. Battery was at 31%, should be plenty enough to turn it on for a bit. I'm currently charging it anyway.

The only other thing I did just before this, was meddling with a tracking setting which was to set it to 50 Hz, as that's my country's power frequency (not that I had any trouble really.. it was set to auto). Not sure if related. I did not restart the headset after this, as I then tried to fix the WiFi thing described above.

I know there's a hold-down-the-power-button-for-30-seconds trick, though I'm not entirely sure what that does (factory reset it?). I'll try that in a bit I guess unless it turns on.

Comments

  • raronraron Posts: 31
    Brain Burst
    Never mind..
    I could connect to it from my phone (via blutooth). Not sure if this step is important or not, I'm guessing not. I then tried to hold down the power button for a time to see what would happen, and the Oculus logo showed up after 10 seconds or so. It seems to be working OK again, WiFi and all (I'm charging it and downloading stuff atm).
Sign In or Register to comment.