New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

microphone problems with rift s

im currently having problems with my mic on my rift s but it happens occasionaly but as i am a youtuber (Max Tyson) it is kinda frustrating when i look at the audio in my videos. it makes my voice sound crackly and robotic and i cant seem to resolve it. any help?

Comments

  • dburnedburne Posts: 2,767 Valuable Player
    Mic on Rift S is not much good, you could either open support ticket and see if you can get replaced and get lucky with next one, or acquire a USB mic. I did the latter.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • F4CEpa1mF4CEpa1m Posts: 153
    Art3mis
    If you want to upgrade your Mic audio I can recommend the Mod Mic usb.

    As for your actual issue it sounds like a bandwidth problem, or maybe recording software??  Are you using OBS to record?
  • NetheriNetheri Posts: 248
    Nexus 6
    As of lately there's been some weird sound related issues on different sets on Windows 10. I for myself noticed one day, that the my Rifts mic sample rate was changed to 48khz and it was greyed out, no other options. 48kHz can cause i.e. crackling in the stream and also change the sound of the streamer at least to lower than it really is, at least if the input in the stream software (dunno about the capturing video softwares else than Slobs, which is mainly used to streaming) is set to 44.1kHz. My issue solved so that there was some 3rd party driver for the usb-c port installed (i use virtual port on NVIDIA with USB-C adapter) and i chaged that driver to Microsofts own. That way I got the 44.1Khz back to be chosen. 

    So if that's the case with you @max.tyson.0409 this could help?
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MPiresMPires Posts: 127
    Art3mis
    Netheri said:
    As of lately there's been some weird sound related issues on different sets on Windows 10. I for myself noticed one day, that the my Rifts mic sample rate was changed to 48khz and it was greyed out, no other options. 48kHz can cause i.e. crackling in the stream and also change the sound of the streamer at least to lower than it really is, at least if the input in the stream software (dunno about the capturing video softwares else than Slobs, which is mainly used to streaming) is set to 44.1kHz. My issue solved so that there was some 3rd party driver for the usb-c port installed (i use virtual port on NVIDIA with USB-C adapter) and i chaged that driver to Microsofts own. That way I got the 44.1Khz back to be chosen. 

    So if that's the case with you @max.tyson.0409 this could help?
    I have the problem with the mic, sometimes it works well (few) and sometimes (almost always) the sound is chaotic. I use the RTX 2070 card's USB-C input and also verified that the mic sample rate is at 48khz and doesn't allow changes. Netheri, how can I change Nvidia drivers to Microsoft drivers? Thanks
  • NetheriNetheri Posts: 248
    Nexus 6
    @MPires ; upgrade the usb driver for it to Microsofts' driver, if it's something else. At least for me, it returned at least the 44.1kHz option for the mic.

    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MPiresMPires Posts: 127
    Art3mis
    Netheri, The question is how can I force this change? W10 will always fetch nvidia drivers ...
  • NetheriNetheri Posts: 248
    Nexus 6
    From the Device Manager, in the USB-controller theres the NVIDIA USB 3.10 eXtensible Host COntroller. RIght click it, choose properties. Then choose the "driver"-tab and there choose "update driver". Then choose "find driver from computer" then choose !i choose the drivers by myself from the list". Then take the tick off from the "show compatible devices" and from the list which opens, choose "USB xHCI compatible host driver" (or similar as i don't have english Win 10). If that's not found then try "Standard USB Host Controller". Windows will warn about the driver signing but just press yes.  At least with this i got the 44kHz to appear and work. 
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MPiresMPires Posts: 127
    Art3mis
    Netheri, thanks for the support. I have this USB xHCI compatible host driver already installed. The options for mic remain only (greyed) 48khz. It seems that the USB-C port in the RTX2070 GPU only have this option.

  • NetheriNetheri Posts: 248
    Nexus 6
    @MPires does the drivers publisher name say microsoft or somethin else?
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MPiresMPires Posts: 127
    Art3mis
    Drivers USB-C are nvidia drivers (vs 441.12). The mic drivers are Rift S ( audio USB generic).
  • max.tyson.0409max.tyson.0409 Posts: 6
    NerveGear
    dburne said:
    Mic on Rift S is not much good, you could either open support ticket and see if you can get replaced and get lucky with next one, or acquire a USB mic. I did the latter.
    dburne, this is my replacement one haha i took the other one back because there was something wrong with the tracking 
  • max.tyson.0409max.tyson.0409 Posts: 6
    NerveGear
    Netheri said:
    As of lately there's been some weird sound related issues on different sets on Windows 10. I for myself noticed one day, that the my Rifts mic sample rate was changed to 48khz and it was greyed out, no other options. 48kHz can cause i.e. crackling in the stream and also change the sound of the streamer at least to lower than it really is, at least if the input in the stream software (dunno about the capturing video softwares else than Slobs, which is mainly used to streaming) is set to 44.1kHz. My issue solved so that there was some 3rd party driver for the usb-c port installed (i use virtual port on NVIDIA with USB-C adapter) and i chaged that driver to Microsofts own. That way I got the 44.1Khz back to be chosen. 

    So if that's the case with you @max.tyson.0409 this could help?

     netherie my graphics card doesnt have a usb c port though 
  • max.tyson.0409max.tyson.0409 Posts: 6
    NerveGear
    F4CEpa1m said:
    If you want to upgrade your Mic audio I can recommend the Mod Mic usb.

    As for your actual issue it sounds like a bandwidth problem, or maybe recording software??  Are you using OBS to record?
    its not a software problem because my friend can hear it aswell wehn am in a party with them 
Sign In or Register to comment.