New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Fixed my "Sensor cannot track headset" problem by having no other connections on the rear of my PC

pol75pol75 Posts: 1
NerveGear
I just want to share my experience as those of others helped me. First I list my setup and the things I tried (that probably prevented me from having other issues). My personal solution is at the end of the post

I have the following setup
- Oculus Rift S
ASRock H170M Pro 4 motherboard (an older one I guess) with an HDMI and 3 DisplayPorts and Intel i7-6700,
6 USB 3.0 ports in the rear, 1 USB 3.0 and 1 USB 2.0 in the front (this turned out to be important)
Nvidia GXT 1080Ti videocard with 441.12 driver
Windows 10 (10.0.18362)
750W power unit (Focus Plus 750 Gold). 

The Oculus headset was undamaged as I received it but I did not get past "Sensors cannot track headset" like so many others. I tried everything out there on the web in terms of fixes but nothing worked. The helpdesk was very responsive - 6 email rounds in 24 hours and they called me a days later to help more.

Here are the fixes I tried or things to pay attention too (a bit in a random order) that all did not get me past the "Sensor cannot track headset" issue. But probably helped anyway when I finally did

- Check the cables for kinks. There were none
- Removed and reattached the headset connecter after carefully removing the plastic onto which padding is attached
- Installed Oculus software. Removed it again and re-downloaded. 
- Repaired the Oculus software
- Tried the Public Test Channel release from Beta in the Oculus app
- Ensured the USB cable is inserted into the USB slot with the blue plastic bit (USB 3.0 slot)
- Check that there are no "!" marks in the USB section of the device manager 
- In the USB section of the device manager, removed all the drivers and selected "right-click" and updated the driver (automatically).
- I have the Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)  and generic USB host controllers (see attached photo, language is Dutch)
- Run Windows Update to get the latest updates
- Allowed apps  to access the camera in the Windows 10 privacy settings.
- My mouse was connected to the USB 2.0 on the front of the machine, the keyboard to a USB 3.0 port in the rear. I tried the Oculus headset in any the remaining USB 3.0 ports (1 front, 5 rear), also switching around the DisplayPorts but nothing got me past the "Sensors cannot track headset"issue
- On all permutations of the connections I always plug in the USB cable first, wait until the light on the oculus comes, then connect the DisplayPort and wait another few seconds
- In the end, I connected the headset to the "primary"DisplayPort and USB cable to a rear USB 3.0 port. I had to Google the schematics for my motherboard to find out which one was the primary DisplayPort

By this stage, reading through all other people problems, I strongly suspected USB related issues but could not get my finger on what. I almost bought a separate USB 3.0 PCI card as on the web several people reported this worked for them.

As I mentioned I have the keyboard USB attached to the rear of the PC and the mouse to the front. I did that because I sometimes switch the mouse so having it on the front gives easier access. And I put the keyboard on a rear USB so I have a free USB slot on the front to easily connected USB sticks. In a last random attempt I decided to put both the mouse and the keyboard USB connections on the front of my machine. And the Oculus then was the only connection on the 6 rear USB ports. THIS TURNED OUT TO BE THE SOLUTION!! Perhaps the power output of the rear USB was somehow split causing lack of power or caused signal issue. No idea. But that was the fix. Probably logical on some level and maybe not an issue anymore for newer boards. 

Good luck with your issues
Sign In or Register to comment.