New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Stormland crashes and Issues

Bob445566Bob445566 Posts: 4
NerveGear
I tried Stormland today. It ran fine on my Overclocked RTX2080 with the latest drivers on high settings. But it Crashed after like 2 minutes. It tried to play for about 1 hour but it crashed about 30 times. 

I also tried to play it on the lowest settings, which did not have any effect on it crashing.

It seems like it crashes mostly on key moments in the game like "cutscenes". Probably always when it loads something in the Background. 
The most crashes are at the scene where you meet that little AI thing and need to put it on your chest. I nearly did not came past that scene because it crashed about 6 times, always getting about 5 seconds further in the scene.

Does any of you have the same Problem? Or a Idea to fix it?

The rest of my specs are
32gb of Ram
and an i7 with 4.9 ghz


Comments

  • Bob445566Bob445566 Posts: 4
    NerveGear
    I fixed it by reinstalling it. Runs ok now.
  • Bob445566Bob445566 Posts: 4
    NerveGear
    I noticed that the game also likes to crash when I overclock my GPU to the max.
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 16
    Have the exact same issue. Reinstalling didn't fix anything. System is rock-solid in all other games (RTX 2080 (non-OC), R5 3600, 16 GB DDRAM4, latest drivers. Just stressed tested my system in the insane Unigine Superposition VR test with Future presets and my system maintained average of 60 FPS and no crashes or errors ( 100 FPS average on VR Maximum preset). Then loaded the game, killed the first enemy I saw => System Crash!

    If I don't do anything in the game but stand around and shoot at the environment, it won't crash. Only crashes when I complete an objective or navigate to a new portion of the map just like OP.

    Dropped an email to developers. Doubt I'll get a response. Game is unplayable. 
  • RuneSR2RuneSR2 Posts: 7,100 Valuable Player
    edited May 16
    Been playing the game for like 10 - 15 hours, all settings maxed but with real-time shadows deactivated and using TAA instead of SMAA. Using Rift CV1 ss 2.0. 

    Never had a single crash - my GTX 1080 is oc'ed to a few Mhz below the beginning of gpu instability, lol. 
    Intel i7 7700K (4.5 GHz); MSI GeForce GTX 1080 8GB Gaming X (oc 2100 MHz gpu boost, 11 GHz mem speed); 16GB Corsair Vengeance LPX DDR4 3200 MHz; MSI Z270I Gaming Pro Carbon AC (VR-Ready) mainboard; Samsung 960 Evo M.2 SSD + Toshiba P300 HD; Windows 10 OS; Valve Index and Oculus Rift CV1 - the latter nearly always using super sampling 2.0. 

    "Ask not what VR can do for you – ask what you can do for VR"
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 16
    RuneSR2 said:
    Been playing the game for like 10 - 15 hours, all settings maxed but with real-time shadows deactivated and using TAA instead of SMAA. Using Rift CV1 ss 2.0. 

    Never had a single crash - my GTX 1080 is oc'ed to a few Mhz below the beginning of gpu instability, lol. 
    what nVidia drivers are you using? Latest (445.87) here. I'll try rolling back to an earlier version, but I don't want to try them all blindly.
  • RuneSR2RuneSR2 Posts: 7,100 Valuable Player
    I'm using 441.87 - but maybe try to deactivate real time shadows first, you'll still get nice dynamic shadows. 
    Intel i7 7700K (4.5 GHz); MSI GeForce GTX 1080 8GB Gaming X (oc 2100 MHz gpu boost, 11 GHz mem speed); 16GB Corsair Vengeance LPX DDR4 3200 MHz; MSI Z270I Gaming Pro Carbon AC (VR-Ready) mainboard; Samsung 960 Evo M.2 SSD + Toshiba P300 HD; Windows 10 OS; Valve Index and Oculus Rift CV1 - the latter nearly always using super sampling 2.0. 

    "Ask not what VR can do for you – ask what you can do for VR"
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 20
    EDIT: removed double post.
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 18
    Fixed! PSA for those having the same issue: in nVidia Control Panel, set Power Management Mode to "Prefer maximum performance". I had mine set to "Adaptive" - which worked fine with all games, VR and flat, and all stress tests / benchmarks, except Stormland. Don't know if the default value for PMM "Optimal Power" also works, will test and report back.

    PS: Thanks for the reply RuneSR2!
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 19
    Confirmed. Anything but "Prefer Maximum Performance" will cause a crash, every time.
  • Ovi_SOvi_S Posts: 6
    NerveGear
    edited May 24
    Oh boy, here we go again: turns out there's another culprit, and the power profile might be a red herring. Yesterday I had an almost instant crash on "Prefer Maximum Performance", 1 minute after starting play.

    Turns out I had switched on another setting as well while I was debugging, trying to make the game work, one that I forgot about, and this one seems to be the real fix:
    In Asus GPU Tweak II (My RTX is an Asus) there's a semi-hidden option button called "Always 3D Clock". This essentially forces the card to run at 3D clocks always, regardless of what the drivers/application usage tell it to run at. 
    With this turned on, I can play just fine, with it off the game crashes.

    Apparently it's a software bug, not a power issue (which explains why I was able to pass all the stress tests and don't get crashes in other games). The bug in Stormland has the GPU clock turn down to 2D speeds (essentially desktop, as if no game was running). This causes the crash. If the card is forced to run at 3D clocks all the time, the bug is circumvented.

    The devs have responded to my email asking for more info and I've pointed them to this thread. Will make sure to update them on this.
Sign In or Register to comment.