New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

No audio when using Oculus Link

NalinNalin Posts: 19
NerveGear
edited November 19 in Oculus Quest
I have no audio on my Quest headset when using Oculus Link.  These are all the things I have tried to resolve the issue:
  • Reboot PC and/or Quest and plugged things back in in many different orders.
  • Restarted the Oculus service.
  • Tried different USB ports.
  • Tried different USB cables.
  • Tried both an active and a passive extender.
  • Tried throwing a USB 3 hub into the mix just because, both as the first part of the chain and as the second part.
  • Tried with headphones plugged into the Quest and with them removed.
  • Tried toggling all the options related to sound that I could find within the software (Devices > Quest and Touch, all those sound options).
  • Repaired / reinstalled Oculus software.
  • Uninstalled Virtual Desktop Streamer app and its audio driver.
  • Changed my desktop speakers from 5.1 to stereo.
  • Attempted setting every single audio output device as default in Windows.
  • Plugged in my CV1, went through the setup, and then tried piping audio through the Oculus Rift Headphones audio output adapter.
  • Reinstalled oculus-driver.exe.
  • Opened a ticket with Oculus Support (they told me they won't support beta software, lol)
Is there anybody with the same issue who found a solution?  Or at this point is my only bet to wait a year until it stops being beta and Oculus Support actually tries to help?
EDIT: I finally got it working after uninstalling the NVIDIA HD Audio driver.
  1. On your keyboard, press Win+X > Select "Device Manager"
  2. Open up the "Sound, video and game controllers" node.
  3. Right click the NVIDIA High Definition Audio driver and choose "Uninstall device".

«13

Comments

  • Protocol7Protocol7 Posts: 317
    Trinity
    Does the Quest appear as an audio output device in Windows?
  • NalinNalin Posts: 19
    NerveGear
    edited November 18
    It does not.  I'm not sure if it is supposed to.  I've heard at least one person say they don't have it.
  • SpuzzumSpuzzum Posts: 823
    3Jane
    Cas from Cas and Chary had the same issue when just using a usb-c cable, but after connecting a 5m Cable Creations active usb 3.0 cable on top of that, she had audio. Not sure why.


  • NalinNalin Posts: 19
    NerveGear
    I used that exact same extender cable that she uses in the video with a 3 foot Anker cable and got no audio.  I also tried using the 3 foot cable by itself and also got no audio.
  • SpuzzumSpuzzum Posts: 823
    3Jane
    You have audio with the CV1 though, correct?
  • vargabloodvargablood Posts: 51
    Hiro Protagonist
    i have audio with the anker usbc cable, only microphone seems to be not supportet at the moment. But i had to activate it by enabling the Audio switch in the oculus pc software under quest device settings.
  • NalinNalin Posts: 19
    NerveGear
    Yes, I have audio with the CV1 with no problem.
  • SpuzzumSpuzzum Posts: 823
    3Jane
    Sounds like a settings issue then. Maybe the same as what vargablood had to do, enabling the Audio switch under the Quest settings in Oculus Home(?).
  • CrixUKCrixUK Posts: 6
    NerveGear
    Try selecting a different audio output (click on speaker icon in taskbar).
    for some strange reason selecting my 2d monitor as audio output sent it to the quest.
  • nalex66nalex66 Posts: 5,027 Volunteer Moderator
    I have the same problem (no audio with the 3’ version of the recommended Anker A to C cable). I tried with the cable alone and with a short passive extension in a couple different USB ports, but I haven’t yet tried with an active extension. That’s probably my next step. 
    CrixUK said:
    Try selecting a different audio output (click on speaker icon in taskbar).
    for some strange reason selecting my 2d monitor as audio output sent it to the quest.
    I’ll try changing my default Windows audio too, although that’s never been an issue with my Rift. Audio works fine when I switch back to the CV1 without touching anything else.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • CrixUKCrixUK Posts: 6
    NerveGear
    nalex66 said:
    I have the same problem (no audio with the 3’ version of the recommended Anker A to C cable). I tried with the cable alone and with a short passive extension in a couple different USB ports, but I haven’t yet tried with an active extension. That’s probably my next step.


    i don’t believe it’s a cable problem, like I said it’s a software audio routing problem.

    if your cable displays video then it’s not the cable.

  • Sofian75Sofian75 Posts: 22
    Brain Burst
    Check if the audio isn't running on your pc instead of your Quest.
  • nalex66nalex66 Posts: 5,027 Volunteer Moderator
    CrixUK said:
    nalex66 said:
    I have the same problem (no audio with the 3’ version of the recommended Anker A to C cable). I tried with the cable alone and with a short passive extension in a couple different USB ports, but I haven’t yet tried with an active extension. That’s probably my next step.


    i don’t believe it’s a cable problem, like I said it’s a software audio routing problem.

    if your cable displays video then it’s not the cable.

    The Oculus PC app says that Quest Headphones are the active audio device, but there is no sound. Some people have had success with this issue by adding an active cable to the mix, so it's worth a shot. But I will also try setting different Windows default audio devices, since you said that worked for you. My current default device is set to my USB headphones, and I wondered vaguely whether that could be a problem because it's another USB device. Switching to my speakers will also tell me if the sound is going to the Windows default audio instead of the Quest (my USB headphones were turned off when I tested last night, so it's conceivable that the sound was going there without me knowing).

    Like I said though, my Rift has no trouble with audio regardless of my Windows default device setting.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • DraidenDraiden Posts: 3
    NerveGear
    Had the same problem using my front USB 3 Input.
    Changed to a USB Port on the back and solved, works perfect with Sound on the Quest.
  • rokcysamrokcysam Posts: 3
    NerveGear
    same issue. Is there any way to solve this.
  • DivivorDivivor Posts: 1
    NerveGear
    edited November 19
    My solution was to repair the Oculus Software by opening the Installer again.

    I had this problem the whole day with multiple cable setups. I now have audio, but in my case it also turned out to be my actual monitor in the audio settings. There is no "Quest Audio" entry.
  • NalinNalin Posts: 19
    NerveGear
    edited November 19
    I have already tried switching the Windows default audio device.  I have already tried all the device settings within the Oculus Software, including adjusting which output device is used.  I have tried all permutations of the other options, too.  That means I've tried mirroring the audio.  No luck.
    I have tried with a passive USB extension cable and an active USB extension cable.  I've tried with my case's front USB 3.0 ports.  I've tried in my motherboard's USB 3.2 Gen 2 port.  I've tried in a StarTech USB 3.0 PCIe expansion card (the powerful and expensive one with a dedicated controller for every port).
    I always get rock solid video but no audio.
  • sdubbinsdubbin Posts: 1
    NerveGear
    I have same problem with quest audio not showing in Windows It acutually comes out of the pc speakers and the quest although if you mute the quest audio from within the headset it stops it coming out of the pc seapker and comes out of the quest speakers but very quietly
  • Scratty84Scratty84 Posts: 14
    NerveGear
    I have got the same issue on my desktop with 1070ti. If I have my Oculus Rift connected sound comes from my Oculus Rift instead of the Quest. If I disconnect the Rift sound is coming from my speakers. Oculus is set to use the Quest headphones and I tried all sound devices in Windows. It is always coming from the speakers if my Rift is disconnected.

    On my Laptop with 1050ti sound is working fine but performance is only acceptable in simple games.
  • PhenixS1970PhenixS1970 Posts: 31
    Brain Burst
    Initially I had no sound with Link either but in the Oculus Dash Quest settings I marked ‘play all windows audio in VR’ and I was good to go (btw Quest is not detected as an audio device in my win10).
  • mushymessmushymess Posts: 1
    NerveGear
    Same issue here I have managed to get audio working from the quest only a couple of times by restarting both computer and quest. Otherwise it just comes out the default computer speakers.

    Hopefully a software issue?
  • dburnedburne Posts: 2,850 Valuable Player
    It's a shame Oculus did not have their new cable for the Link available when the beta software became available.
    I expect going to be a lot of folks getting very frustrated trying different cables to find one that will work for them - some likely will just give up.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • NecaroNecaro Posts: 10
    NerveGear
    dburne said:
    It's a shame Oculus did not have their new cable for the Link available when the beta software became available.
    I expect going to be a lot of folks getting very frustrated trying different cables to find one that will work for them - some likely will just give up.
    Well or they just need to wait 1 or 2 days. There are already tons of working suggestions in the forum :)
  • kenf1071kenf1071 Posts: 110
    Hiro Protagonist
    edited November 19
    hi,ive got sound but through both my quest and coming from my monitor speakers,wife is moaning saying she can hear it and cant seem to get it coming from quest headphones only ? anyone know what that would be

    its only when i use link 
  • TomCgcmfcTomCgcmfc Posts: 1,505
    Project 2501
    Anyone tried using Oculus Tray Tool (OTT) with their Quest/link yet?  It's audio/mic switcher works great with my Rift cv1.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti (from my old AGA), 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors. Vive Cosmos, currently work in progress.

  • NalinNalin Posts: 19
    NerveGear
    I got it working finally!  I did a couple things at the same time:
    1. Turned off exclusive mode on my speakers.
    2. Disabled my Yeti microphone "output" (why this is even a thing I don't understand).
    3. Removed the NVIDIA HD Audio driver.
    Once it was working, I turned exclusive mode back on and enabled my Yeti microphone "output" and the sound still works.  My only conclusion is that it was the NVIDIA audio driver, although I can't say with 100% certainty because I did a bunch of things at the same time.
    1. Win+X > Device Manager
    2. Open up the "Sound, video and game controllers" node.
    3. Right click the NVIDIA HD audio driver and choose "Uninstall device".
    Hopefully this works for somebody else.
  • jim2011jim2011 Posts: 1
    NerveGear
    I also found it was related to the audio device but don't think i would want to uninstall the driver since I output to HDMI to my TV.  After completely uninstalling and reinstalling Oculus software for it not to work, I remembered a trick I had to do once to get audio to my rift in certain situations:

    1) Switch the audio output from 5.1 to Stereo in Windows
    2) Unplug and replug in the Quest, I now had audio.

    I think this definitely needs to be resolved by Oculus but it seems to be working for now.  I don't want to have to manually change it every time I switch from Quest to Non-VR games.
  • falo209falo209 Posts: 4
    NerveGear
    Still no luck.  I've tried the speaker configuration change, removing the NVIDIA audio drivers, and all sorts of other switching, reinstalls, cable changes and the like.  What's interesting for me is that when I'm connected to Link, changing the sound device in Windows using the speaker icon doesn't actually do anything - still leaves the audio coming through my PC speakers.
  • SnavigIIISnavigIII Posts: 1
    NerveGear
    Same audio issue as above, different cables combos, etc.  Video and tracking works fantastic, no audio...

    However, I have three VR Machines, all with Rifts that work flawlessly, varying specs but all Nvidia GTX 1070 or better.  Lack of audio issue on Quest Link is across all PCs, regardless of audio settings.  Rifts operate fine.
  • falo209falo209 Posts: 4
    NerveGear
    OK, it's definitely a choice being made by the Oculus software for output device.  If I have some audio playing on my desktop (say another game in the background) and activate the link, I hear both the link audio and the other audio playing through speakers.  If I then switch the audio output in Windows to my headset, the other audio goes to my headset and the Oculus output stays on my speakers.  Is it maybe making a guess about what device to use and getting it wrong?
Sign In or Register to comment.