New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Wont Install = "It looks like we can't reach the Oculus server..."

smokeyj91smokeyj91 Posts: 3
NerveGear
edited November 29 in Support
I'm having trouble Re-installing the OculusSetup.exe 

I bought the Rift around June and its worked perfect with no issues, the software and installation initially was smooth and everythings been great. Until now.
Haven't used it in a month or so and was prompted to do some updates, in doing this my problems started:

• Locked into update loop with no actual updates happening.
• Attempted to repair with installer which took me back to the update loop in the end.

So i uninstall & wipe of Oculus from my system (Not a single trace - there isn't even logs i've tried to find them for support) and downloaded the Setup.exe. new problem starts

• After getting past accepting terms i get " Can't connect      It looks like we cant reach the Oculus server. Please check your connection." 

Spent hours on this last night and hours again today, i'd really appreciate some help.

Comments

  • smokeyj91smokeyj91 Posts: 3
    NerveGear
    Support seem to be no "Support" at all with this either, i have had nothing after telling them there is no logs to provide.
  • smokeyj91smokeyj91 Posts: 3
    NerveGear
    Just to update - support still dont seem to be able to fix this.

    I have returned my Oculus Rift to Argos as its less than 5 months old, and purchased a HTC Cosmos.
    This little bit of info might help anyone having the issue im having,
    The HTC Software comes with Rift support - worth checking out if you got stuck like me.
Sign In or Register to comment.