New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S : Oculus software restart required every boot up or when HMD goes to sleep

DentifreakDentifreak Posts: 20
Brain Burst
Hi,

I bought a Rift S two days ago. Every time I boot up my PC, I have a red circle in the device tab. It says connected but also « Oculus software restart required ».
To fix this, I have to unplug the USB cable of the Rift S and plug it back, then it works until the next reboot.

I also saw that when I don’t use it for a while and it goes to sleep, I have the same error. Sometime disconnecting the USB cable isn’t enought, I need to manually restart the oculus services.

Note that my drivers are all up to date.

On my motherboard, I have 6 x 3.0 USB ports.
4 of them are 3.0 gen 1 (Intel Z370). This problem happens on all of them. My Rift S is the only thing connected to these ports, nothing else.
2 of them are 3.0 gen 2 (ASMedia). The problem does NOT occurs on these ports BUT I have constant stuttering so I can't use them.

I tried to repair the installation, it didn't fix the problem.

any idea ?
Thanks

Comments

  • jiabao9166jiabao9166 Posts: 7
    NerveGear
    i got same problem ,it almost  drive me crazy 
  • fishhuntfishhunt Posts: 34
    Brain Burst
    edited December 5
    I got same problem as well tried this on 3 computers same problem messed up my windows 10 so had to do a fresh install, still same problem, I think there is a fault in the unit causing the trouble, if you leave the usb in, then you reboot
    the computer then go to device manager you see 1 "oculus usb hub" in there, should be 2 "oculus usb hub" to make the unit work. I brought my oculus rift s 4 days ago might be faulty batch
    I have sent  a perflog file to oculus support  had a look into  the file, notice it saying unknown "USB3"
  • flightofthebumbleflightofthebumble Posts: 1
    NerveGear
    I have the exact same issue. I just submitted a support ticket.
Sign In or Register to comment.