New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How do you play steam vr games with the link?

PeterDoubtPeterDoubt Posts: 21
Brain Burst

I have both a working cable and an active extension cable that works with Rift games, although I'm having trouble with audio not coming out of the headset. When I try to run Steam games, they won't start. I'm using virtual desktop on the Quest app to start the steam vr games. They try to start and I get a small black screen, then nothing and back to the play icon.

Answers

  • michael.a.mcgheejrmichael.a.mcgheejr Posts: 4
    NerveGear
    Are you selecting the "Oculus VR mode" option? Do not use the "Steam VR mode" option when starting up the game. It should ask you which one before the game runs
  • michael.a.mcgheejrmichael.a.mcgheejr Posts: 4
    NerveGear
    Audio is a pain though, make sure you set your audio both on the headset setting while wearing it and on the app on the computer

  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    Are you selecting the "Oculus VR mode" option? Do not use the "Steam VR mode" option when starting up the game. It should ask you which one before the game runs
    I don't get that option when I start a game. What steps should I use? I start the Oculis pc software and then plug in the Quest. I've got steam open in the background. I select the virtual desktop and then click the game I want and hit play ( all with touch controller, of course. I get a smaller black screen and then the play button returns.

    Thanks
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    Have you turned on “Allow Unknown Sources” in the PC app Settings menu?
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    nalex66 said:
    Have you turned on “Allow Unknown Sources” in the PC app Settings menu?
    If you're talking about the Oculis app, sure have.
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    I did get an option to open the Steam Vr mode or to “play (title of game)”. No Oculis vr mode.
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    I’ve found that some SteamVR games don’t launch properly unless I start them from within SteamVR Home. I always launch SteamVR from the desktop with the Oculus app already open. Then I put on my headset and from the menu inside SteamVR Home, I launch the game.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    nalex66 said:
    I’ve found that some SteamVR games don’t launch properly unless I start them from within SteamVR Home. I always launch SteamVR from the desktop with the Oculus app already open. Then I put on my headset and from the menu inside SteamVR Home, I launch the game.
    Thanks Nalex. That's how I'm doing it. I have a possibly stupid question, though. Is SteamVR a different app from The regular Steam app? Maybe I'm missing something...
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    You do need to install SteamVR in addition to the main Steam app--in your library, there is a drop-down to switch from Games to Tools. In the Tools section, you should be able to find SteamVR--click on that and hit Install.

    In the Steam desktop app, you should see a VR button at the top right part of the window if SteamVR is installed (beside the Big Picture Mode button). Press that to launch the SteamVR app.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    nalex66 said:
    You do need to install SteamVR in addition to the main Steam app--in your library, there is a drop-down to switch from Games to Tools. In the Tools section, you should be able to find SteamVR--click on that and hit Install.

    In the Steam desktop app, you should see a VR button at the top right part of the window if SteamVR is installed (beside the Big Picture Mode button). Press that to launch the SteamVR app.
    I figured that out right after I posted. Just got done checking out Skyrim VR...Boy I feel stupid, but I searched for Steam VR on google a few times and never found the right information. There isn't a good complete tutorial on setting the link up with Steam that I could find. Much thanks to you and Michael!!
    Now if I can get the sound working on Oculus. It does work with Steam VR but comes from both my laptop and my headset. I'll look into Windows settings. I just got a new laptop for this (and more uses) - an MSI GE 75 BF deal. I'm new to gaming ps's but not to computers by any stretch.

    Again, thanks!!
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    Audio is a pain though, make sure you set your audio both on the headset setting while wearing it and on the app on the computer

    @michael.a.mcgheejr, what headset setting are you referring to? I get sound with Steam games but not through the Oculus app. I've got the headset checked on the app, but no sound. The oculus doesn't show up in Windows, either...
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    When I started using Link, I wasn’t getting any sound through the headset (except sometimes in SteamVR). Here’s what I had to do to get it working:
    • Opt into the PTC beta version of the PC Oculus software. That installed virtual audio device drivers. 
    • Opt out of the PTC to roll back to the stable version of the PC software (1.43). The drivers remained installed. 
    • With the Quest connected over Link, go to the headset settings in the Dash menu and make sure the Quest headphones were selected and the volume was at 100%. 
    Once I did that, the audio automatically switched to the Quest when Link was active, and I could adjust the volume with the Quest’s volume buttons. 
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • PeterDoubtPeterDoubt Posts: 21
    Brain Burst
    edited December 4
    nalex66 said:
    When I started using Link, I wasn’t getting any sound through the headset (except sometimes in SteamVR). Here’s what I had to do to get it working:
    • Opt into the PTC beta version of the PC Oculus software. That installed virtual audio device drivers. 
    • Opt out of the PTC to roll back to the stable version of the PC software (1.43). The drivers remained installed. 
    • With the Quest connected over Link, go to the headset settings in the Dash menu and make sure the Quest headphones were selected and the volume was at 100%. 
    Once I did that, the audio automatically switched to the Quest when Link was active, and I could adjust the volume with the Quest’s volume buttons. 
    Thanks for your help again, nalex66
    I've tried this, but perhaps not completely. When I opted in to PTC, I got the notice that the new software was loading, but it disappeared and I never saw a notice of completion.  Do yo you have to do anything to roll back to 1.43 or does it do that automatically? I don't have the drivers, so I'll try it again. 
    Edit: I have the Realtek Audio HD driver and audio console on an MSI GE75. I've seen some talk of removing that driver...also, does the headset need to be connected when you opt in to PTC?
    Edit2: okay all, I got it working. It took a few times but it finally updated and then I had to restart. Then it updated again with another restart and I opted out of PTC and restarted again and it reverted back to version 1.43. The Quest headset now shows up ind sounds settings. I did have to revert back manually to Realtek Speakers after using the Quest.. thanks!
Sign In or Register to comment.