New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S crashes with VRChat

LatiprodLatiprod Posts: 2
NerveGear
Hello everyone!
Recently I bought a new Oculus Rift S, but unfortunately I have some problems to make it work correctly with VRChat, and it's really frustrating because it's the main reason why I bought it. So, I'll start from the beginning: first off, the day before the arrival of the Oculus I updated my pc from Windows 7 to Windows 10 with its last version (1909 I think), and the day after I installed the Oculus Rift S. Everything went right, I didn't receive any error and the Oculus worked great with the demo, so I tried to start VRChat to see if it was working, and it start to have some problems. So, VRChat opened correctly and I could see the first world I joined, I can walk around and do all the things I want, but when I tried to change the world the Oculus crashed and disconnected from the pc. I tried to change the usb port and the display port, tried to reboot Oculus Home but the Oculus didn't turn on in any way, the only way was to reboot the pc. I tried to see on internet if there was some solution to this, so I tried to change the setting for the energy saving of the usb port, I tried to use the public beta, I tried all the usb ports on my pc, I tried to reinstall the Oculus Home, I tried to switch back to an older Windows 10 and nothing of this helped, I still getting this same problem everytime I try to go to another world and I really don't know what to do. Oh, and now for some reason Oculus Home say that the usb port is not compatible, but the Oculus still works great, so I'm really confused and I don't know if it would help buy a new pci card or not. So, can somebody help me somehow?
Thanks in advance!

Answers

  • DakalystaDakalysta Posts: 3
    NerveGear
    Hi Latripod,

    Try to gather some logs, maybe that can help you to target the issues : 
    C: \ Program Files \ Oculus \ Support \ oculus-diagnostics \ OculusLogGatherer
  • LatiprodLatiprod Posts: 2
    NerveGear
    Thank you for the help!
    Finally after nearly 2 weeks I found the solution to this problem :smiley:
    So, I tried to look in the logs like you said, and when it disconnected there was an error that say: "USB connection failed via pc_hal_sensor_data_read", so I searched again on internet and, obviously, the problem is the USB port, so first I tried again to install the USB 3.0 driver for my motherboard, then looking to some discussions I've seen that my motherboard (Gigabyte 970a-ud3p) already had some problem with the old Oculus, and looking more into it apparently the BIOS I had was really old, and the most recent one had some fixes for the USB 3 compatibility. I updated it, rebooted the pc, tried the Oculus and everything was working as expected. I hope this to be of help to someone :smiley:
Sign In or Register to comment.