New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S USB Port Incompatible with all USB 3.0 Ports

When I plug my Rift S into my USB 3.0 ports, it tells me that they are incompatible. I've tried unplugging and plugging back in, restarting my computer, resetting the headset, and reinstalling the Oculus Software. I've tried all of my USB 3.0 ports and none of them are compatible. I've also made sure my USB drivers are up to date, and anything else I plug into the 3.0 ports works fine. All but the headset works. Is there some way to fix this?

PC Specs
Processor:     AMD FX-8320
RAM:             DDR3 16 GB
GPU:              AMD Radeon 480
OS:                Windows 10
Motherboard: Gigabyte GA-78LMT-USB3

Answers

  • Crazy_SaneCrazy_Sane Posts: 279
    Nexus 6
    Your best bet is to fill out an "Oculus Support Ticket". This will connect you directly with customer service.
  • fizznickelfizznickel Posts: 1
    NerveGear
    Did you ever find a solution for this?  I am having the same issue with the same PC specs.
  • MeloncholyMangoMeloncholyMango Posts: 2
    NerveGear
    I ended up getting a new motherboard with USB 3.1 ports. Weird thing was, after I set it up, even though it says the 3.0 ports aren't compatible, it works just fine on this new motherboard. Otherwise I'm not sure how to help. 
Sign In or Register to comment.