New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

"Rift S is connected and active but Oculus needs to restart" error loop

JD9852JD9852 Posts: 7
NerveGear
edited December 2019 in Support
I finally got my Rift S working but after a Windows Visual C+ update (KB2565063) it keeps giving me this error loop. I'm not 100% sure if that update is causing it but when I removed it before it was working fine. It says Rift S is connected and active but Oculus needs to restart again. So I restart, it first says not connected then connected and active but needs to restart. The thing is Windows forces me to install this update and I can't find it anymore to uninstall. Can anyone help with this?

Comments

  • kwanlol777kwanlol777 Posts: 1
    NerveGear
    Igot the same problem ...
  • DeafToner4DeafToner4 Posts: 2
    NerveGear
    saaaaaaaaaaaaaaaaaaaame, this is so frustrating 
  • fishhuntfishhunt Posts: 38
    Brain Burst
    Look in device manager there should be 2 "oculus usb hub" to make it work, if it only shows 1 "oculus usb hub" your oculus rift s wont work



  • DeafToner4DeafToner4 Posts: 2
    NerveGear
    fishhunt said:
    Look in device manager there should be 2 "oculus usb hub" to make it work, if it only shows 1 "oculus usb hub" your oculus rift s wont work



    And that's it? it just wont work? 

  • fishhuntfishhunt Posts: 38
    Brain Burst
    only way to get it to work with me is take out usb and put it back in after reboot
  • jiabao9166jiabao9166 Posts: 10
    NerveGear
    same problem  pal....no can fix    oculus sucks
  • jiabao9166jiabao9166 Posts: 10
    NerveGear
    same problem  pal....no can fix    oculus sucks
  • fishhuntfishhunt Posts: 38
    Brain Burst
    This what sent oculus support
    I can confirm I done your steps install windows 10 update still not working
    look in device manager there is only 1 "rift s usb hub" were should be 2 "rift s usb hub" then I tried it on my laptop showing up 1 "rift s usb hub" and
    1 unknown usb device (port failed) then I put in to my usb 2 showing 3 dots in screen tried install oculus drivers again. I think when you boot up computer automatically windows Microsoft usb drivers get put in, not the oculus drivers
    This what they sent me

    Let's make sure that Windows power management is disabled:

    ·        

    ·        Under Related settings, click Additional power settings.

    ·        Select the High Performance power plan. If this option is not available, select Balanced.

    ·        Click Change plan settings next to your selected plan.

    ·        Click Change advanced power settings.

    ·        Expand USB settings and set USB selective suspend setting to** Disabled**.

    While I look into this further for you, I would like to collect some additional information:

    ·        Full name, shipping address and phone number

    ·        Oculus username and/or email address associated with your account

    ·        Headset serial number: which can be found by removing the headset facial interface, and starts with "1WMGH"

    ·        Unit serial number: which is located on the bottom of the black box and starts with "1WMVR"

    ·        Retail receipt or invoice including item, retailer, price, and date -OR- Oculus order number

    If it's determined that a replacement is required, a payment method will need to be added to your account in order to proceed. We recommend you add one now while we continue to review your case. Please note that this is a system requirement and you will not be charged. Instructions for adding a payment method can be found 


  • andrea.davieroandrea.daviero Posts: 10
    NerveGear
    Partial solution is to completely remove the oculus drivers and lets Windows to install generic ones.

    1) Start oculus
    2) Go in device manager and right click on "oculus rift" under USB devices
    3) Select remove drivers, when promped, remove also the software (the most important one)
    4) Probably will ask for a restart.
    5) After the restart, open oculus and cycle the USB connector off and then in.
    If all is good, you can now use oculus with generic Windows drivers, switching on and off oculus app.
    The only remaining problem is at the computer start up. It will Always need to unplug the cable.
    I hope they will fix this issue.
  • douglas.stedfeltdouglas.stedfelt Posts: 2
    NerveGear
    I was just playing DCS last night and all of a sudden I get this error...I attached logs for the past 3 days and screenshots.  Please help!
  • andrea.davieroandrea.daviero Posts: 10
    NerveGear
    I was just playing DCS last night and all of a sudden I get this error...I attached logs for the past 3 days and screenshots.  Please help!

    Douglas, try my steps in the previous post, I had same problem. Now it happens only after computer start up, then I unplug/plug the rift and the error goes out.

  • xWildchildxxWildchildx Posts: 9
    NerveGear
    Partial solution is to completely remove the oculus drivers and lets Windows to install generic ones.

    1) Start oculus
    2) Go in device manager and right click on "oculus rift" under USB devices
    3) Select remove drivers, when promped, remove also the software (the most important one)
    4) Probably will ask for a restart.
    5) After the restart, open oculus and cycle the USB connector off and then in.
    If all is good, you can now use oculus with generic Windows drivers, switching on and off oculus app.
    The only remaining problem is at the computer start up. It will Always need to unplug the cable.
    I hope they will fix this issue.
    Same problem here, done this exactly workaround too. I was initially worried about the "non-Rift" device name but I think it's not so important in order to this shit works fine.
    The problem is the also with this procedure, it takes 4-5 retry with cable "plug-in/out" and software restart before it works!
    I'm really near to surrend myself with the S and bring back my CV1 that ALWAYS works (and worked) at first connection without any of these issues.
    So sad about the S. Really sad.
  • andrea.davieroandrea.daviero Posts: 10
    NerveGear

    I have a walkaround also to avoid plug/unplug:

    1) Start oculus, 
    2) Open device manager
    3) in USB devices remove the two detected devices (both must be removed)
    4) on the USB Controller main icon (on the device manager root) right click
    5) Select "detect hardware modification"

    It works exactly as plug/unplug. 
    I'm "lucky" as my problem is Always that one and I need only one try.
    I'm sure is a software problem. I hope the develops will fix it.
  • fishhuntfishhunt Posts: 38
    Brain Burst
    did not work for me
  • fishhuntfishhunt Posts: 38
    Brain Burst
    edited December 2019
    i have tried my oculus rift s on 3 computers  when you boot up it loses the usb. take the usb out then put it back in all working fine
    so many people having this trouble  thinking it could be a batch of faulty units could be its not putting enough power to the usb
    on boot up, so windows 10 dont recognise usb so it puts windows driver in
  • andrea.davieroandrea.daviero Posts: 10
    NerveGear
    fishhunt said:
    i have tried my oculus rift s on 3 computers  when you boot up it loses the usb. take the usb out then put it back in all working fine
    so many people having this trouble  thinking it could be a batch of faulty units could be its not putting enough power to the usb
    on boot up, so windows 10 dont recognise usb so it puts windows driver in
    I don't think is an hardware problem. However, to check this, it is necessary to try a working headset on the same pc.
    The oculus rift drivers are launched/installed at oculus application start up. I think we need to push oculus to fix the software. My idea is that the drivers are not stable. Has anyone tried a functional rift s on the same computer that gives troubles with another rift s?
  • LegendBaconLegendBacon Posts: 7
    NerveGear
    Hi everyone,

    As people have mentioned here, this is a USB issue.
    I have around 70 Oculus Rift S out there, on the same Windows update (1909), same laptop models, same Oculus App version, same Nvidia drivers, connected to the same networks, etc...

    And yet for some reason only a third of them have this issue.

    I haven't found the cause yet, but I've found a fix.

    If your computer has a USB-C port, get a USB->USB-C adapter and use that with the Rift S. Reboot your computer, and now everything's green. No reinstall needed.

    I've shipped the same adapter to ~20 clients, and it fixed the issue immediately for all of them.

    I still don't understand why it only happens on some of our machines though.


    I hope that helps!
    Cheers,
    ~LegendBacon
  • andrea.davieroandrea.daviero Posts: 10
    NerveGear
    I'll check, I have a USB C port, I only need the adapter.
  • JD9852JD9852 Posts: 7
    NerveGear
    edited December 2019
    I did the firmware update and I'm getting this message again that it's connected and active but needs to restart. In device manager I see a Rift S Usb hub but I also see Unknown USB Device (link in compliance mode). In the bottom right hand corner I also get a message "We cant find your headset. Please connect your headset  {6D809377-6AFO-444B-8957-A3773F02200E}\Oculus\Support\Oculus-client\ . Can someone please help me? Customer support hasn't been able to help me fix it.
  • JD9852JD9852 Posts: 7
    NerveGear
    I got a usb to usb-c adapter, rebooted my PC and the Oculus software and it worked. I'll see how long it stays this way. The fact that this is still a problem for people after several months makes me really lose confidence in Oculus.
  • michaelsuraltamichaelsuralta Posts: 1
    NerveGear
    I have exactly the same problem. Only one Hub detected and i don't have a USB-C Port :( any other solutions ? 
  • nevinjiangnevinjiang Posts: 3
    NerveGear
    Using PCI-E USB 3.0 Ext card will solve this. 
  • Leif.PedersenLeif.Pedersen Posts: 3
    NerveGear
    Using PCI-E USB 3.0 Ext card will solve this. 
    I bought one to fix this, it had no effect....
Sign In or Register to comment.