New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How Do I Get The Oculus Quest Cast Feature To Work With Chrome Cast Ultra?

Ok here we go…

I am having trouble with casting my headset to the TV. When I first got the headset in August of 2019, I had a chrome cast 3gen. I managed to cast my headset to the TV on a few occasions when I wanted to. I stopped playing for a few months and have since returned.

I thought it would be as easy as before to cast but no..

Its like the feature has fallen of the face of this earth…

I cannot get the chrome cast to appear in the app or the headset at all, not even a blink of hope.

My trouble shooting process:

·         Make sure my phone, headset and Chromecast are connected to the same 2.4GHz band Wi-Fi. – DID NOT WORK

·         Make sure my phone, headset and Chromecast are connected to the same 5GHz band Wi-Fi. – DID NOT WORK

·         Factory reset the chrome cast. DID NOT WORK

·         Uninstall the oculus app and reinstall it. DID NOT WORK

·         Use a Different phone. DID NOT WORK

·         Make sure mobile data is off. DID NOT WORK

·         Make sure Bluetooth is on. DID NOT WORK

·         Disconnect oculus account from phone and headset. DID NOT WORK

·         Factory Reset Headset, uninstall app, factory reset chrome cast. Set it all back up. DID NOT WORK

·         Check router settings and make sure IPV4 was running not IPV6. DID NOT WORK

·         Make sure P2P connections are ok. DID NOT WORK

·         Move the router closer. DID NOT WORK

·         PURCHASE chrome cast ultra. Try both 2.4 and 5GHz bands again. DID NOT WORK

·         Try ethernet with chrome cast ultra. DID NOT WORK

·         REPLACEMENT HEADSET…… DID NOT WORK.

·         Went to a friends house, with a different network…. DID NOT WORK

Am I missing something here…… I physically challenge an oculus quest developer to come to my house and try and make it cast on my TV…

NO I don’t want to cast to my phone! My family will not huddle around a 5 inch screen.

The fact that this feature has been taken OUT of its beta stage and is apparently a fully working tested feature is blowing my mind….

I will not be defeated by this and I WILL cast to my TV. And No I’m not using a 2nd gen chrome cast! Yes I have tried turning it on and off again! Unless customer support can provide me with something I haven’t tried yet I don’t really want to read it.

Surely the software just does not work? I have tried more than the average person could put up with and yet no luck.

I have attached some pictures of people with the same problem.

Sorry but its got to the point of frustration.

Help from a dev would be great.

Ben G

Answers

  • MacGyver.VRMacGyver.VR Posts: 2
    NerveGear
    Same problem here: previously worked without a hitch, for months.

    As with the OP, I’ve reset and restarted everything I can think of: my previously-working Chromecast simply doesn’t even appear on the list of available devices any longer (on my phone or on the headset).

    Not a huge show-stopper... and I’m incredibly impressed with everything that the Oculus team has been adding over the last few months. Just figured I’d add to the bug report list. :-)
  • SpifffSpifff Posts: 2
    NerveGear
    As another point of data i can add this. Old routers work just fine.

    If i connect my quest to my old netgear N750 wifi (circa 2013) i CAN cast to my chromecast enabled tv.  
    I setup another dlink router (2013ish) as an access point (Dhcp and firewall turned off) and if i connect the quest to it's wifi i CAN cast to the tv.
    I setup a new  Dlink-867 (2018)  as an access point (dhcp and firewall turned off) and if i connect the quest to it's wifi i CANNOT cast to the tv.  I have the symptoms as described above by the OP.  I just wanted the higher bandwidth wifi to help with casting.

    My phone can cast to the TV when connected to the new DLink-867.  Just not the quest.
  • Crazy_SaneCrazy_Sane Posts: 355
    Trinity
    Hi,

    That sounds pretty frustrating. But this is the community forum for users. Have you filled out a support ticket or chatted to customer support?
  • Benman283Benman283 Posts: 2
    NerveGear
    I can agree i am also really impressed with the new features! extremely! but it feels like they have taken away one of their best ones :( I will try to raise a support ticket now and post the updates.
  • cashxxcashxx Posts: 23
    Brain Burst
    edited December 2019
    Yea, I got my Oculus Quest before Thanksgiving in November and also bought a chromecast 3 to show it off to the family and it never worked.  That was when version 11 was came and people said it stopped working for them after version 11.  Still having issues with version 12 and 12.1 as well.  Was hoping to show it off more at Christmas time now and still not working.  Oculus is missing out on free advertising at this time of the year!
  • MEMPHISJOEMEMPHISJOE Posts: 2
    NerveGear
    I am having the same issue. It says in their troubleshooting to make sure it is on the same WiFi and all of that. Should be easy. I cant believe i have spent so much time on this. They need to fix it soon and it is a deal breaker. It says it will cast and it doesn't so fix it. Now. 
  • SpifffSpifff Posts: 2
    NerveGear
    I have solved all of my problems just by noticing that is something to do with router settings.

    I have a sony x900f chromecast enabled tv on wired ethernet.  On all routers it doesn't matter if i use 2.4Ghz or 5Ghz. i tested both in all cases.

    if i setup my network using an old netgear N750 wifi (circa 2013) i CAN cast to my chromecast enabled tv. 
    if i setup my network using an old dlink router (2013ish) i CAN cast to my chromecast enabled tv. 

    if i setup my network using a new  Dlink-867 (2018)   i CANNOT see the tv as a castable target.
    if i setup my network using a new Tp-link ARcher C7 (2018) I CAN cast my my chromecast enabled

    I am now happy with the TP-link router. All my problems stemmed from something to do with the dlink-867 settings.   I assume it has soemthign to do with how the router handles multicast, IGMP, or ipv6.  Each router does it different and has different modifyable settings.  I could not find a way to make it work anywhere in the dlink settings.   Yet it works perfectly well in the default TP-link settings.

    hope this helps others. 
  • cashxxcashxx Posts: 23
    Brain Burst
    I was told by support that there is a problem with IPv6.  But checked my parents router when I was home for Christmas and IPv6 is disabled by default so I have my doubts on it now.  Something is odd, but it only seem to be with the Oculus stuff for myself and my brother.  Can cast from anything else, but anything Oculus related it won't work.  I found on iOS I can broadcast from the headset to the phone fine, but no sound.   My brother has an android and won't work either way.  So Oculus has something messed up in using chromecast on their end some how.  I changed every setting I could find in my parents router and no luck messing with the settings.
  • ltejada32ltejada32 Posts: 1
    NerveGear
    Hi!, any news on this topic?, still having the same problem...
  • agent_piresagent_pires Posts: 2
    NerveGear
    I'd like to know if there's any solution as well as I can't get this to cast even with a gen 3 Chromecast have done what most suggest and still causing issues.
  • cashxxcashxx Posts: 23
    Brain Burst
    Anyone that isn't working, please submit a ticket to oculus.  The more people that complain, the more chance it gets looked at and fixed.  Submit tickets here: https://tickets.oculusvr.com/hc/en-us/requests/new
  • Nikkins81Nikkins81 Posts: 1
    NerveGear
    edited January 1
    I'll just add that I disabled IPv6 as suggest and still no option to cast via Chromecast, like many others.
    All connections are 2.4ghz.
    We use the router/modem supplied by Spectrum - Arris TG1682G.
    Ticket submitted a couple of weeks ago with no other solutions. 
  • agent_piresagent_pires Posts: 2
    NerveGear
    I tried seperating the WiFi bands putting all devices on 5Ghz still can't find the chromecast 3rd gen. This is even with connecting to the Quest via Bluetooth. It's really bad. Also my app doesn't have a drop down for any of the cast from or to devices. Is this how it should be?
  • razorbacksTXrazorbacksTX Posts: 1
    NerveGear
    Same issue for my quest. Can’t see chromecast as an option to cast to either in app or in headset, and casting to iPhone XS Max does not work. Have been using only 5GHz connection with only 3 devices on it (Chromecast, IPhone, Quest)
  • stnleystnley Posts: 1
    NerveGear
    Okay, i've had the same issue as well and have ran thru most of these troubleshooting steps.  I did find on a forum that putting the Chromecast (i have v3) on a 2.4Gz network and the phone and quest on a 5Gz network somehow allows it to show up on the quest as an option to cast... so i tried it and IT WORKED!  i cast from my quest to my TV with the Chromecast for at least 30 minutes without a hiccup.  Problem is, i tried this same workaround at the office and it did not work so i am thinking it is router settings or something.  One step closer.

    -stnley27
  • SD-QuesterSD-Quester Posts: 1
    NerveGear
    I will just add to this for extra reference to trouble shooters, as I have seen multiple times and have a chance.

    Here is the main problem I have had with casting/airplay and other types of, on my own network. Also basically same thing at work network that needed some custom rules placed.

    *** Look for a setting on routers (usually only a wifi option) along the lines of "Inter-Device Communications" / Device to device communications. They need to be set to ALLOW the traffic or the communications may not happen.  If you are connecting through anything designated as a "Guest" wifi this type of traffic is normally blocked by default. If you have an ultra or 3rd party casting device and can connect via ethernet wire it is a good way to test this setting as usually hard wired devices are always allowed to receive inter-device communications even from wifi devices or network printers / file servers, etc. may not work.

    I find for most wireless systems both the caster and receiver must be on the same wifi 2.4Ghz or 5 GHz. And it does help to not use a system that jumps between them. 5Ghz always better except when flaky or heavy 5ghz traffic.

    Also for google casting you generally must have internet at least for the initial 'handshake'. Official Google Casting devices themselves usually also need constant internet for the constant telemetry whereas 3rd party devices with cast capability often only need the initial contact with internet and then you can disconnect. This is what I have to do when I do remote demo casts. I link my small travel router to my phone data for a few seconds and then as long as I do not shut down the quest or cast receiver it works great with no further internet.

    Another thing is many routers now a days have programming in place to check for questionable traffic on their network and if set too high they will cause blocking or delaying issues with google casting as it likes to switch through port numbers rather quickly when connecting and often uses odd/high number ports. So it gets detected like some sort of network scan that may be a hacker not wanted.

    Last thing I can think of right now is I have run across with google devices and some others. They may be using hard coded DNS addresses for getting out to phone big brother google and they get confused if your router is enforcing its own or your ISP's DNS server which interferes with that initial speedy 'handshake' from happening correctly; even though streaming video shows may work they are only being connected 'to' not 'providing' the connection or acting as a 'host' for other devices to send to.

  • mikebuscmikebusc Posts: 1
    NerveGear
    I'm new to this (just got my Quest yesterday) but I'm hoping this will help someone. I had the same problem casting directly to my TV with a 3rd gen chromecast plugged in to it. I was able at first to cast to my phone then cast from phone to tv with Google home but the picture was lousy. I came to this forum for some answers then I just changed my wifi on everything to the 5g input and "Pow!" my TV finally showed up on list of "cast to's"
Sign In or Register to comment.