New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

I've found a bug causing the bad performance in 12+ firmware

Mazda_RonMazda_Ron Posts: 19
NerveGear
Hi, I've posted this over on oculus Reddit but I am unable to link. Title I FIXED ALL MY V12 UPDATE PERFORMANCE ISSUES

The thread has a video showing the bug which works both ways

what I've found is that I've had low performance headroom since v12 and still on 12.1 by monitoring the performance HUD through oculus debug tool

To fix this I have discovered that toggling the adaptive GPU performance scaling via oculus debug tool to off does not do anything, but when you attempt to toggle back to default, you only have to get as far as clicking on the drop box and depending on if you have low performance headroom ie 30% it will immediately shoot up to 60% or whatever value you had previous to V12 firmware.

I've also found that you cannot repeat a drop or gain once it's happened via this method until a power cycle, I don't think it's one or either settings that cause lower or higher but rather a bug in the firmware that hasn't detected it correctly.

In the case you've already got the performance headroom you expect ie 60% doing this will actually cause it to drop to 30%   showing the issue present since 12.0 

I was curious as to why people were suggesting disabling asw to stop stuttering and frame drops, but this would explain it, the headroom is missing so all your games using higher settings and supersampling have much less use of the GPU it had access to before and if asw is enabled you will be sitting in that, turning it off and being close to low or minus headroom causes the stutters and dropped frames and isn't really a fix like this is.

Hopefully someone can at least link my post and one of the Devs or support team here so they can see what's going on, another user has also confirmed this bug and fixed the performance.

Thanks, Aran.
Cv1 and quest link user, computer and driver's fully upto date and only had issues since v12 which i can resolve with this trick.

Comments

  • Mazda_RonMazda_Ron Posts: 19
    NerveGear
    Anyone viewing, reading and trying this PLEASE could you post your results. I cannot link to my video so if your already familiar with oculus debug tool it's incredibly easy to do and feedback is crucial as this could narrow this issue down that's been present for so long.
  • kojackkojack Posts: 6,171 Volunteer Moderator
    I've verified your account, see if the link can be posted now.

  • Mazda_RonMazda_Ron Posts: 19
    NerveGear
    kojack said:
    I've verified your account, see if the link can be posted now.

    thank you, unfortunately ''i have to be around a while longer'' so i'm guessing post count is the issue as account is 2017
  • kojackkojack Posts: 6,171 Volunteer Moderator
    Damn. The flag says it bypasses spam and pre-moderation filters, but I guess the newer post count filter is separate. You should still be able to post text links without the http part, they just won't be clickable.

  • PhoenixSpyderPhoenixSpyder Posts: 263
    Nexus 6

    I tried your solution from reading the other thread on 12.0 with the link you provided but on my system there is no change. FYI


    i7 8700k @ 5ghz, Asus Rog Strix Z370-E Gaming, MSI 1080ti Gaming X @ 2050Ghz + 11.4Ghz ram, 32 GB Corsair Veng DDR4 2666 Ghz, Adata SX900 SSD, 1TB M.2 SSD, Adata Su800 SSD, Adata SU650 SSD, BarraCuda 2TB HD, Oculus Rift, Odyssey Plus, Windows 10 Pro 1909
    "Presently developing a VR project (outside of my profession) due to the lack of availability of what I would like to experience" Details in a year or two...
  • Mazda_RonMazda_Ron Posts: 19
    NerveGear
    edited January 10

    I tried your solution from reading the other thread on 12.0 with the link you provided but on my system there is no change. FYI


    Can you provide more info, the fix is for the bug shown in the video, you need that specific issue in your update, it's not for anything else that's also broken in the update

    What is your headroom before attempting? What issue were you hoping to fix as this is not intended or works for usb issues or sudden drops related to bandwidth especially rift s
  • Mazda_RonMazda_Ron Posts: 19
    NerveGear
    kojack said:
    Damn. The flag says it bypasses spam and pre-moderation filters, but I guess the newer post count filter is separate. You should still be able to post text links without the http part, they just won't be clickable.


    www.reddit.com/r/oculus/comments/em3oun/i_fixed_all_my_v12_update_performance_issues/

    link to video if can't be viewed in reddit
    www.youtube.com/watch?v=6YWRY7qAqHI&feature=youtu.be
Sign In or Register to comment.