New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Brand new Rift S display will not turn on

STREETBLAZERSTREETBLAZER Posts: 5
NerveGear
After purchasing a new Oculus Rift S from newegg, the display will not turn on.  The issue became apparent during the initial setup- a blue light appears on the anterior section of the headset, while a white light turns on between the lenses, yet once the setup says "continue in VR", nothing appears while wearing the headset.  Also, the only way it plays sound is if I set the device to use windows settings in the app and use headphones.  I've already attempted disconnecting/ reconnecting the USB/ display port cables as well as check my camera settings (on). The app indicates that all my devices are connected properly, yet nothing appears on the display at all.  Further more, I tried it on a friend's computer and had the same results.  I'm personally using a MSI GP63 leopard 8RF w/ a GTX 1070 and mini display port.  I never had any issues like this with my old CV1- I'm hoping someone might be able to help me troubleshoot this before I return this as a defective unit.

Thank you

Comments

  • StreamofConsciousStreamofConscious Posts: 30
    Brain Burst
    I have an EVGA SC17 with GTX 1070 and using adapter with mini display port. I had one unit that worked fine except it would get sparkles on the screen. Oculus had me return it. They sent me another after the holidays and this one is doing the exact same thing yours is doing. My previous one didn't have the dark screen problem, it would work as long as you could put up with the sparkles. I have heard it all started with an update in Mid December. I've submitted a ticket, as should you, but  its seems like it has already been quite awhile that people have been dealing with this. I can get mine to work occasionally for random period of times, but it always returns to black screen after a bit of flickering. So, I've tried all kinds of things but nothing has fixed it. I think it is going to take a firmware patch. The thing that bugs me is why they are not letting people revert back to a previous stable version while they figure out the issues. I don't think its a hardware issue, but I also don't want to get stuck with a bad unit again......and definitely not permanently.
Sign In or Register to comment.