New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Pinned display z-fighting issue bug

MalicTolsenMalicTolsen Posts: 39
Brain Burst
For the last few weeks, using both standard and PTC, have been getting the following issue.

High quality panels has a workaround where if you tweak it enough it can be *seen*, but it takes multiple times to get it to be just right.

It looks to be a z-fighting issue where the gray polygon that is supposed to be "behind" and the image of the display cant tell what is in front of what until I get that perfect storm for it to show.  resizing bigger can get it to go away, but it is then far to large for use for reading when I am streaming

https://www.youtube.com/watch?v=0HpHyYvIezE

Comments

  • MalicTolsenMalicTolsen Posts: 39
    Brain Burst
    Oculus Log attached here:
  • TaomynTaomyn Posts: 54
    Hiro Protagonist
    I can confirm this behaviour, it's been happening for the past few PTC updates and I've reported it after each update through the Home feedback.
    ---
    Rift S | AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | MSI GTX 1070Ti Gaming 8G GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • abz-ukabz-uk Posts: 1
    NerveGear
    I'm having the same problem.
  • MalicTolsenMalicTolsen Posts: 39
    Brain Burst
    This is still an issue with the PTC 15 released on March 11th 2020
  • TaomynTaomyn Posts: 54
    Hiro Protagonist
    I confirm that this issue is still present in PTC 15, no matter what window I pull in, app or screen, it goes grey when I return to the running VR application or game. Pinning has become totally useless to me. I am also running the latest Windows 10 patches and nVidia drivers at the time of writing - submitted a feedback report through home.
    ---
    Rift S | AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | MSI GTX 1070Ti Gaming 8G GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • garrus77garrus77 Posts: 4
    NerveGear
    I haven't heard about this issue and I don't think it happened to me.

  • NetheriNetheri Posts: 400
    Trinity
    edited March 21
    At least you have the panels, some of us don't have anything but exclamation marks on instantly on pull-out. Some have the problem from the secondary monitors, others have even from the one and only monitor. Oculus Support answer for me after some "time playing" recommendations was that the Oculus software is working right. So, that's a feature, not bug. Good luck with it.
    [email protected] 5/4.9GHz, ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 1 x Inateck 4 port USB 3.0 card, 2x3.1 USB, 6x3.0 USB on mobo, 1x USB-C on G-card.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MalicTolsenMalicTolsen Posts: 39
    Brain Burst
    I am using an entire display, not the individual window to try to get around that, I know about the ! issue as well, and use the most stable thing for my streams, but it has not been stable since December of last year.
  • NetheriNetheri Posts: 400
    Trinity
    Yep, i'm using the whole screen of the 2nd monitor as a work around. Also you can use workaround for the exclamation mark issue so that move wanted window to main monitor and pin it from there.
    [email protected] 5/4.9GHz, ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 1 x Inateck 4 port USB 3.0 card, 2x3.1 USB, 6x3.0 USB on mobo, 1x USB-C on G-card.
    Natively Homeless (2.0) Dash, it's a working victory!
  • MalicTolsenMalicTolsen Posts: 39
    Brain Burst
    It is June 5th and this is still an issue, has been since December last year
  • SkymasterptSkymasterpt Posts: 1
    NerveGear
    I suffer from this issue Since that last big update to oculus i cannot precise if it was from december or just after but i also have it and is freaking annoying!!! 
  • TaomynTaomyn Posts: 54
    Hiro Protagonist
    Please Oculus, get this fixed - even when after fiddling with the window position and getting it to work, if you remove the headset or just drop onto the desktop, when returning to my game the window is grey again.
    ---
    Rift S | AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | MSI GTX 1070Ti Gaming 8G GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • DrBo42DrBo42 Posts: 1
    NerveGear
    Please fix this.
  • JJSmashingPumpkinsJJSmashingPumpkins Posts: 1
    NerveGear
    I have the same issue. Please can you fix this.
  • MalicTolsenMalicTolsen Posts: 39
    Brain Burst
    edited July 31
    New version 20.0 PTC update, still does not fix this problem.
  • TaomynTaomyn Posts: 54
    Hiro Protagonist
    Same here, still cannot believe it's been nearly 8 months without this getting looked at or even acknowledged
    ---
    Rift S | AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | MSI GTX 1070Ti Gaming 8G GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • MelantrixMelantrix Posts: 1
    NerveGear
    I have the exact same problem. It's reallly anoying, so much so that it makes Oculus Dash worthless to use. Can you please look into this bug and/or at least awknoledge this?
  • lucasjose501lucasjose501 Posts: 1
    NerveGear
    I bought my Rift-S a few weeks ago and noticed the same problem, also playing Elite Dangerous. This happened with Firefox window with twitch open and sometimes, when I set the mouse over it fix the problem temporally
Sign In or Register to comment.