New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S Can't Hook Up With My Displayport...

Hello,

I'm trying to hook up ''Oculus Rift S'' to my PC. But... I can't get past the set-up process. Step 1 involves sticking in USB 3.0 and DisplayPort. Which I have done. Oculus Rift S connects to the USB but it doesn't connect to the Displayport. It gives me a fat red ''X'' and tells DisplayPort not connected or something along those lines. I've tried re-installing the Oculus app, updating drivers, my system and plugging in cables into multiple other slots but without luck.

Interestingly enough, the headset worked on my friend's laptop via mini DisplayPort. Maybe he has a more powerful laptop than I have my pc/GPU?

My PC specs:

Motherboard: Z77-hd3
Graphics card: GTX 660 2GB
Processor: i5 - 3570
RAM - 8GB
Power supply - Sl-700A
USB - 3.0

Comments

  • dburnedburne Posts: 3,060 Valuable Player
    edited February 9
    I believe you are falling way below min specs there.
    Especially on the GPU.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • MatissSolaMatissSola Posts: 2
    NerveGear
    hmm...
  • kasingsamkasingsam Posts: 5
    NerveGear
    try clean (with clean utility) uninstall display card driver and reinstall it. I worked once , but after i reboot i am blank black again now
Sign In or Register to comment.