New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

VR Compositor Layers Sphere Black line

artemu25artemu25 Posts: 4
NerveGear
Recently i've tried to use VR Compositor Layers for rendering 360 panoramas. I've used Unity and OVROverlay component with equirect shape. And everything is ok except one thing. There is always a black seam backwards no matter what image is (like on image in attachments). How can i fix it?

Comments

  • JeffNikJeffNik Posts: 152
    Art3mis
    edited March 10
    Those went away for me when I turned off compression for the panoramic texture.

    appended: My apologies - turned off LOD option in the texture, NOT the compression.



  • artemu25artemu25 Posts: 4
    NerveGear
    edited March 12
    JeffNik said:
    Those went away for me when I turned off compression for the panoramic texture.

    appended: My apologies - turned off LOD option in the texture, NOT the compression.



    @JeffNik thanks for your answer, but what exactly do u mean by "turned off LOD option in the texture". As I know LOD is the option of a mesh not a texture.
  • kojackkojack Posts: 6,165 Volunteer Moderator
    For textures in Unity, the option is "Generate Mip Maps". Turn that off.
    Mip Maps are basically LOD for textures, smaller versions of a texture to use when a surface is far away. When the panorama gets to the edge and wraps around, there's a giant jump in UV coordinates (from 1.0 back to 0.0). The GPU sees that jump as meaning the surface must be really really really far away (far enough that an entire texture fits in one pixel) so it drops to the lowest mip map level (probably 1x1) along the seam.

    It would be possible for a custom shader to bypass the effect, but the easiest fix is usually to just turn off mip mapping. For normal meshes that wouldn't look good as things get near and far, but a panorama doesn't move (well, usually).
  • JeffNikJeffNik Posts: 152
    Art3mis
    Thanks, @kojack. :-)
  • artemu25artemu25 Posts: 4
    NerveGear
    @kojack, thanks for the explanation)
    @JeffNik, I've just tried to turn off mipmaps, but black line is still there(
Sign In or Register to comment.