New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S Audio issues.

MasterPanzieMasterPanzie Posts: 13
Brain Burst
I've looked as far as I could and have gone through oculus support for a few months to no avail. I've even replaced my rift. 

Here are the details.

My PC
Intel Core I7-5930K
CPU @ 3.5GHz
32GB RAM
Nvidia GTX980 (x2)
Windows 10 Pro v 1909

Upon booting my pc (having my rift plugged in before I boot) and changing my audio to Rift S. My entire PC audio is output to my rift.

Okay so far so good.

It will play audio out like a speaker all day no issues.

I put the rift on. Oculus home loads.

So far so good.

Roughly 5 minutes pass and theres a short freeze. Loss of tracking. Sound halts. Environment does that nuasiating thing where it doesnt stay  on the ground.

This short pause lasts like one second, then everything returns to normal with the exception that the sound is crashed and I will periodically get thos short freezes intermittently.

The ONLY things I've been able to find that restores sound is by going to settings and restarting oculus and also by unplugging and replugging in the headset. But the issue still persists shortly after replugging it in. 

When I say no sound I mean none through oculus period. My game (if attempting to play one) audio stops mirroring on my external audio. My headset doesn't make a chime when I tap the volume selector through my PC. Test this device doesnt make a chime. Nothing. And yes. All of these steps DO work in the short window before the audio cuts out. 

I've reinstalled oculus 100% (manually deleting EVERYTHING) and checked ALL of my USB ports. Including updating them AND plugging my headset into all of them individually. 

Yes I've set it as my default device yes it's on a 3.0 and yes i have run the windows troubleshooter to no avail. 

I've done everything short of swinging it by the cord and vaulting it out my window. 

Please help me. Oculus support has been great but maybe someone else has a stupid fix? I just wanna play games man. 

Best Answer

«1

Answers

  • Crazy_SaneCrazy_Sane Posts: 355
    Trinity
    So you haven't tried the vaulting thing yet? Maybe you should, just to cover all bases.

    Are all of your drivers up to date? Do you have any other software running at the same time? Can you access any logs that might tell you what's happening when it pauses for a moment?
  • RezervRezerv Posts: 1
    NerveGear
    I'm having the same issue. Only way to fix it is restart oculus. At first it happened after about an hour or 2, then 30 min, now it's about 5 minutes of playing, making games unplayable. I'm only trying to play Half Life: Alyx.
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    Yeah all my drivers are updated. no software in the background. and as far as logs go ive sent a few to oculus support but havent looked at them myself in fear it would be over my head. but ill glance through them and update as to weather it helped or not. as far as PC logs, i have no clue how id find what im looking for. vaulting is sounding better and better...

    Sorry to hear you're facing the same issues i am. yes! same thing happened to me! long time at first then shorter over time. I wonder what can be causing it. I'm not happy you have an issue but I'm happy its somewhere else too and I'm not a unique case. That implies a software/hardware issue specific to oculus.

    Rezerv
    are your specs simillar to mine? what steps if any have you covered? any ideas or thoughts?
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    hm. heres a few errors i found (of many many many)

    [Service_2020-03-18_17.51.46.txt] 18/03 18:25:52.056 {WARNING} [KMCore] [VISION][VIPER] IMU is running ahead of cam by 69.091 ms. Dropping frame.

    [Service_2020-03-18_19.46.11.txt] 18/03 19:48:21.868 {WARNING} [KMCore] [Aggregated 25 times] [VISION][VIPER] IMU is running ahead of cam by 92.633 ms. Dropping frame.

    [Service_2020-03-20_15.52.10.txt] 20/03 16:49:09.037 {!ERROR!} [KMHal] (HAL): ERROR: (hidapi.cpp:130): Failed to send feature report (0, -1, A device attached to the system is not functioning.

    [Service_2020-03-20_15.52.10.txt] 20/03 16:49:09.493 {!ERROR!} [KMHal] (FW): 339161712 [error  ] {UUSB}: Unexpected transfer. Status: 1

    [Service_2020-03-20_15.52.10.txt] 20/03 16:49:09.493 {!ERROR!} [KMHal] (FW): 339161712 [error  ] {UUSB}: Unexpected transfer. Status: 0

    [Service_2020-03-20_16.53.04.txt] 20/03 16:53:05.688 {INFO}    [KMHal] (FW): B}: Unexpected transfer. Status: 0

    [Service_2020-03-20_16.53.04.txt] 20/03 16:53:05.688 {!ERROR!} [KMHal] (FW): 339282803 [error  ] {UUSB}: Unexpected transfer. Status: 0

    [Service_2020-03-20_16.53.04.txt] 20/03 17:39:10.173 {!ERROR!} [KMHal] [TrackingHal] [PCHAL] Call 'pc_hal_haptics_setbuffered':2649 returned a device error, Wireless RX/TX error (PC HAL result 18)

  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    edited March 29
    attached full logs here

    or at least im trying too

     nevermind i guess. Wont load
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
     :) 
  • AzaniasAzanias Posts: 5
    NerveGear
    I am also having this exact same issue as described. My PC information is below:

    My PC
    AMD 3800X
    32GB RAM - 3200mhz
    Gigabyte 5700XT OC
    Windows 10 Pro v1909
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    okay! i made a LITTLE headway. My system tray (the bottom right corner near volume) pops up saying "Oculus is using your microphone"  or "recroom is using your microphone" when the issue happens, so i closed EVERYTHING in the system tray AND disabled my internet security. it didnt FIX the problem but it gave me more time before crashing again. Also... when it crashed it would sometimes actually reset the head unit and the sound would come back on. it made me excited thinking it fixed itself, but then it crashed again. this time not playing through my head unit BUT through my speakers for a little. Until it crashed AGAIN and went back to no sound. Also. when it started resetting power, Oculus software noted that my display port plug was disconnected. 

    So to recap here. if you are having the same problem as me try disabling EVERYTHING in your system tray.. Closing EVERYTHING. Disable your security. Tell me what happens for you. We can chip this problem away!
  • AzaniasAzanias Posts: 5
    NerveGear
    OK so after testing a few different things I am very certain it is the microphone in the rift s that is causing the crashes. For some reason if I am chatting to someone on any medium (valve, discord or oculus). To test this even further I joined a room in discord by myself but let the microphone transmit data. It then crashes very similarly to when I was playing with a friend or just chatting with someone. 

    Not sure if this fixes your issue but at least I was able to pinpoint mine. 
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    Hi I have the same issues, now that you wrote your last post, I can confirm similar behavior. Played with Discord and got thos sound issues regularly. Then after restarting the PC Discord was not on and I had no problems at all. Not 100% confirmation, but same direction.
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    I havent been able to verify the additional crashing through chat mediums, but i can say i do think the mic may be a large contender to our issues. i disabled my rift s mic and tried running like that for a little, but unfortunately i still got crashes. I'll keep trying new things and see what else i can find. you guys keep on tinkering away too and hopefully one of us will get the culprit! thank you so much to anybody helping on this solution!!!
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    ITS THE GYROS

    okay. so ive been troubleshooting all darn day. i played my phones music through the rift microphone while in a discord call while playing youtube through the rift speakers. I opened oculus app manually but i did NOT touch the rift. i let that play for a bit and everything worked fine. i then started rocking the unit to activate the gyro sensor and boom. crashed. i had to reset my PC to get audio back. tested again but skipped all the other stuff. i just played audio through it grabbed it and started shaking it around. boom. crashed. i guess the vaulting technique was right all along..
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    oh... ok, but that sounds like a large issue :/
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    I wonder if it has to do with the coding or if it has to do with the hardware?... i hope it isnt too large an issue to be fixed.. hopefully when i reach back out to oculus with this new info we may see a fix? hopefully?
  • AzaniasAzanias Posts: 5
    NerveGear
    OK so after attempting two steps Oculus representative recommended it still did not work. I ordered the Inateck Superspeed 7 Ports PCI-E to USB 3.0 Expansion Card from Amazon and hoping it solves my issues.

    I'll try and post an update when it comes in this weekend.

    Best of luck to everyone. 

    -------------------------------------------------------------------------------------------------------------------------
    With that being said, I have two other steps you can attempt, but be advised if these do not work you may want to look into USB 3.0 PCI-e cards:
    Disable USB power saving mode:
    1. Right click the Start menu and select Device Manager.
    1. Scroll down and open the USB section.
    1. Right click the first option and select Properties.
    1. Open the Power Management tab, and uncheck the "Allow this device to turn off" box.
    • The tab might not be there for all entries. If missing, move to the next one.
    1. Repeat steps 3 and 4 for each item in the USB section.

    Uninstall USB drivers to install Microsoft default drivers:
    1. Open Device Manager.
    1. You can find this through the Start menu.
    1. Locate all of the AMD USB 3.1 eXtensible Host Controllers under the Universal Serial Bus controllers dropdown.
    1. Right-click each of them and select Uninstall.
    1. After uninstalling both of these, please restart your computer so that Windows may automatically install the default Microsoft drivers for them.
    1. Try out your Rift S and check for any changes.
    -------------------------------------------------------------------------------------------------------------------------


  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    edited April 7
    I can't really find a system behind it. Yesterday I had two uninterrupted beautiful hours of Half life and today I had the problem every 20 Minutes.
    Whats special in my case: I unplug the rift after each gaming session (two small toddlers at home and don't want them to frickle around the headset). So maybe it is the USB connection?!

    Edit: Forgot to mention. Screen stays on, however, tracking is lost and if its ingame i keep going the same direction i previously pressed on the joysticks. So it really does look like a connection issue
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    Also ordered the Inateck USB card. Let's see if it helps!
  • AzaniasAzanias Posts: 5
    NerveGear
    edited April 9
    OK so after getting the Inatek card a few days early, it still did not solve the my audio issue. I tried the drivers from Inatek, the generic drivers windows installs and also the usb signed drivers. I got good information from this post. https://www.reddit.com/r/oculus/comments/em1mmy/the_usbdisplayport_undetected_help_thread/

    I have also uninstalled the Oculus software in windows safe mode when I got a BSOD when trying to make the Inatek card work as intended. I followed this post: https://forums.oculusvr.com/community/discussion/74180/bsod-irql-not-less-or-equal-windows-10<br>
    I have updated my AMD x570 chipsets that were release two days ago as well: https://www.amd.com/en/support/chipsets/amd-socket-am4/x570<br><br>I also joined the public (beta) in Oculus software but there was no difference. 

    I did get to play for around 20 minutes when using a USB-C to USB adapter from my motherboard but when the graphics seemed to increase my audio crashed again.

    I am really at a loss on what to do next and after debugging and dealing with this for a few days I think I am done. I will be returning my Rift S and moving on to another brand VR headset.

    I hope everyone can solve their issues someway because I do think the Oculus is a awesome I just wished I didn't spend most of my time dealing with audio crashes.

    Best of luck to everyone!
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    got my innatek as well today.

    The card looks good. however i did get the same error. However, it was on an ok level (90 minutes of playtime and 2-3 errors).
    Still not perfect. Any further ideas?

    I did not try all of azanias points. But actually don't fancy doing these things.

  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    Update:
    Yesterday after I turned off the PC i had another look at the Innatek card. Turns out that the Power supply connector cables are of rather poor quality. The red wire was lose inside the plug. I put it back in and will try it again tonight or tomorrow evening. Maybe the card didn't run on auxiliary power supply.
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    Update 2:
    Today I had about 45 mins of project cars and about an hour of half life alyx. NO Tracking loss or sound loss encountered. Not proofed yet, but looking good.

    However, had a new problem. After Project cars I started Alyx and had - for the first time - quite a bit of lag/stuttering. Not sure if GPU was still on high temperature/power due to project cars. will test again next time.
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    Okay. To be clear. The card worked for you godfather? But it didn't work for you Azanias?
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    edited April 14
    So far yes, Would need some more testing to clarify.
    Worked for a lot of other guys on the forum as well.

    Reason for new stuttering/lag is however not found yet.
    That only appeared yesterday for the first time.
  • AzaniasAzanias Posts: 5
    NerveGear
    That's correct, it did not work for me. 
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    I'm about to give up...

    Can't tell you what is going on exactly....
    Yesterday all was perfect. Due to the stuttering I updated my Nvidia drivers.

    So today I tried it again with the Innateck card. Now i get the following errors:
    I plug it in, the headset-Light (white) lights (which is normal)
    As soon as I put on the headset (or just put my finger on the sensor below the white ligh) it takes the rift about 2-3 seconds until it crashes completely (orange light in the headset, no connection, black screen, Oculus app says "No displayport connection".
    I just tried the normal USB3.0 connectors on my mainboard. Here I can use the rift s again normally BUT with the tracking/audio bug again. (even just after about 2-3 minutes).

    What I tried:
    - All ports on the innateck card (same error)
    - Switching from a common power supply cable to a unique power supply cable for the innateck card
    - Checking all connections (rift s side and desktop side)

    I already ordered a new GPU for higher VR-Performance which should arrive the next two days. This will be my last test, then I'll return that damn thing. And I haven't even finished Half life yet :(
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    Update:
    Seem to have fixed the issue again. Not sure by what means though, as I did two things.

    1) I entered the Oculus Beta (in options menu) and installed the beta drivers and the beta client

    2) I installed the inateck drivers on the cd and then re-installed the windows drivers

    Could only have a short test due to my kids hopping around, but will look further into it tonight.
    However, then as well with a new GPU (2070 Super instead of 1070)
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    man. im gonna buy the innatek see if that helps me. seems to bit hit and miss so far. ill report what my results are when i get it
  • MasterPanzieMasterPanzie Posts: 13
    Brain Burst
    which one exactly did you get godfather?
  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    edited April 18
    This one: (sorry, german amazon description)

    Inateck Highspeed 7 Ports PCI-E zu USB 3.0 Erweiterungskarte - 5x USB 3.0 Ports außen und 2x intern, PCI-Expresskarte mit 15 Pin SATA Anschluss, inkl. 2 Stromkabeln - KT5002


    So after some additional tests:
    - IF the Rift runs on the Inateck, it runs very well, without tracking/audio-issues
    - HOWEVER in 2 out of 3 cases it imediately crashes upon activation (putting it on your head)
    --> Then only driver re-installations or re-starts help until i get it stable.
    I am currently in contact with oculus support and will try their steps.


    EDIT: I currently tried using my only 3.1 USB port on my mainboard. It was ok for a while, but crashed completely during the lab (however the lab has had the most bugs in vr so far for me)

  • GodfatherTBGodfatherTB Posts: 14
    Brain Burst
    UPDATE:

    I found a pretty good workaround for my Inateck problems (being that after pluging in the rift s, I always get a crash upon putting on the headset).
    I plug the headset in and then have to re-start the PC (with plugged in headset). Then it works fine.


    However, I have three new problems:
    1) During "The lab" if I do the slingshot game and shoot the red barrels (loud and bright explosion) the headset crashes instantly and completely. This is repeatable. Haven't found anything about this so far.
    2) If I do take off the headset during a Half Life playsession for a minute or two (toilet break for instance) the headset seems to crash as well. Steam is giving me the "headset not found" error and I have to restart the system completely.
    3) After a longer playsession (encountered it with half life and with project cars). If I re-start the system (due to error 2) ), tracking of the controlers is very laggy. (Encountered this even after the upgrade to the 2070 Super, so I guess it is not due to my stressed system).

    I would like to thank the Oculus support who tried to help me out with this!


    To be honest, I am tired of looking for further solutions to these problems...
    I will sell/return my Rift once I finished Half-Life. It's a shame, as I really liked the experience. Would have loved to go into Boneworks, Stormland and other great content.
    Maybe I'll return if new hardware is available or good updates are available. (Or if Valve Index is finally available at a normal price ;) ).
Sign In or Register to comment.