New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S won't connect to PC, no white LED light...is it bricked?

DyelonnnDyelonnn Posts: 1
NerveGear

Last night, while sitting at my computer, my Rift S started making a hissing noise next to me. It sounded perhaps like static noise but also perhaps like when an electronic device is overheating.

Alarmed, I unplugged the USB cable from the Rift S to turn it off. The sound stopped and I was relieved. I got distracted though, and did not follow up on the situation.

Now, the Rift S won't be recognized by my PC, the white light won't turn on, nothing. I plugged the USB cable back in, obviously, but it's like I'm not doing anything at all. It's like the headset is completely off.

I tried re-seating the USB cable on the HMD-side. I also tried to plug the HMD into every USB slot on my PC. I uninstalled the Oculus software and reinstalled it. No changes.

It's feeling extra shitty because I was attempting to get everything prepped tonight for HL:Alyx launch time tomorrow. If anyone has any advice I'd really appreciate it. Thanks bros

EDIT: I plugged in the USB cable from Rift S to my razer blade laptop. It recognized something connected and a couple USB devices were added to device manager. I don't have a display port on the laptop so I ended the testing there. But still no white LED light on headset.

Comments

  • dburnedburne Posts: 3,173 Valuable Player
    I would open a support ticket with Oculus.
    Sounds like you may need warranty on this one.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
Sign In or Register to comment.