New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Connected and Active, USB 3 Connection required.

kranckykrancky Posts: 2
NerveGear
I had been playing on quest link for ages, got most of the way through virtual rickality, then came back n plugged in my headset, only to find the "Connected and Active, USB 3 Connection required." All that changed was software(An update on quest, aswell as oculus software). None of my 6 usb 3.0 ports will sense as 3.0, and with half-life Alyx now out, I'm dying to play it. Should I just reinstall the pc software and pray? Any help?

Comments

  • HHawk396HHawk396 Posts: 2
    NerveGear
    I got the same problem, every USB port is sensed as USB 2.0, it is literally driving me insane not to be able to worry about head crabs in half-life by now!
  • bigkahunarbigkahunar Posts: 1
    NerveGear
    I have the same problem but only with the official link cable and usb Chris use to work my old ankar cable with usb a is fine. 
  • zed85zed85 Posts: 4
    NerveGear
    no solution yet?

  • Spacejockey426Spacejockey426 Posts: 2
    NerveGear
    I have the EXACT problem.  Everything was working fine earlier in the week. I played Echo Arena without any problems at all.  Then, yesterday I bought Half Life: Alyx, downloaded and installed it, tried to play and got the same error condition that krancky described above.  Are you kidding me?  Do we have to wait until Quest software version 15 comes out before this will be fixed?
  • AnonMomAnonMom Posts: 16
    NerveGear
    Same problem here. I am so mad. I ordered a new cable thinking mine was bad, and new one didnt work either.
  • HasboraeHasborae Posts: 2
    NerveGear
    I've had the same problem for a couple of days as well, but it doesn't really matter because I've had the "No Displayport connection" error for two months and my headset has been a brick since then anyway
  • BlakeAlmo85BlakeAlmo85 Posts: 3
    NerveGear
    I still haven’t received the v15 update on my quest. I’m hoping that will fix my problems with the link
  • GarrettayGarrettay Posts: 2
    NerveGear
    Same problem, even since the recent windows cumulative update. I have been trying to fix it for hours.
    Tried using different usb drivers, repairing oculus software, reinstalling oculus driver.
    Checked everything for updates.

    Going to try a method i found posted elsewhere.

    Oculus wont let me post the link...

    The poster says this fix can resolve usb issues. Involves changing bios settings.
    Ill copy and past the post here if it works for me.


  • KFHviking45KFHviking45 Posts: 5
    NerveGear
    I have the same issue. It worked fine untill a couple of days ago. I reinstalled the oculus software on pc and it worked again for 1 Day. 
    This happened once before as well and again now - i am certain it’s because of a software update (15). 
    The way oculus releases updates has to be improved - and the quality of the updates too! 
  • GarrettayGarrettay Posts: 2
    NerveGear
    Agreed, there seems to be so many conflicts between oculus updates/window updates/graphics updates/steamupdates
    its ridiculous. 

    I went to sleep planning on trying a few new fixes in the morning but not it seems to be working fine..... so bizarre.
    But im not complaining. Ill copy the post i found incase anyone wants to try it .

    "If you've had the issue where you get a hardware error with a yellow warning on "Generic Superspeed USB hub" in device manager that makes you unplug and plug back in your rift cable to clear.. I found the solution:

    (This will likely apply to other USB devices as well.)

     

    .Go into your bios
    and find your USB settings menu.
    .Look for a setting that lets you switch between full initialization and partial initialization.
    .Switch this to partial initialization.

    Your rift or sensor USB's are doing this because they don't like being initialized during bootup.
    It may also be USB 2.0 legacy support kicking in when it shouldn't.

    If you don't have a bios setting like this,
    you may still have other options.
    If you don't mind losing all USB 2.0 device support with your USB 3.0 ports, you can turn off legacy support in
    all of the bios's I've seen. That may fix it too on a hunch, but I haven't confirmed it.
    You may also be able to solve this by turning off fast boot in some scenarios, because I could imagine this 
    full initialization/partial initialization setting could be tied to that on less advanced motherboards.
     

    This has happened with two different motherboards for me so I figure it's somewhat common.

    I'm putting the solution here in this forum to archive it so it's somewhere that people can find on google if they need help with it."

  • KFHviking45KFHviking45 Posts: 5
    NerveGear
    Hi! 
    I had the same issue for days now, meaning everything was fine then all of a sudden my USB port was recognized as 2.0 instead of 3.0 - this is how I fixed it: 
    - Make sure your VR Device and the PC Software is on the same major version (14 in my case), and don`t enable any beta updates. 
    -Unplug the USB cable from your PC! (Not your VR Device) 
    -Turn your VR Device off and on
    -Turn your computer off (restart might work, but I suspect it retains power on USB and it might not work) 
    -Log in, start the Oculus Software, plug the USB cable back in
    After doing this, everything worked fine for me. I don`t really know why but it seems to have something to do with how the USB is initialized and it doesen`t like that the headset is plugged in when booting your PC. 

    I hope this helps someone else, please let me know it if does so we can share this "fix".. 
Sign In or Register to comment.