New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

"General Device Problem" when connecting with the Oculus Link Cable.

ResoluteOnVRResoluteOnVR Posts: 1
NerveGear
So I was playing Half Life: Alyx earlier today when I decided to take a break.  I come back to my Laptop (where I played it from) and tried to connect to it with the official link cable when it comes up with a "general device problem."  I've been working on it for hours trying to fix it, but to know avail.
What I've learned about it is that it is not a broken cable, because it works completely fine when connected to my normal PC.  I know the ports aren't damaged or dirty as well.  Also my drivers on the laptop are completely updated.  My specs are a GTX 1070 Max-Q, i7-8750H, and 16 GB of RAM.  I would assume that the issue has to do with the fact that these specs aren't exclusively supported by Oculus, but I am not so sure as to why it stopped working after a short break.  Any ideas? 

Comments

  • HansaplastiqueHansaplastique Posts: 3
    NerveGear
    Same problem here ... Quest Linked worked since they made the beta available to the public.
    Even used it minutes before downloading Half Life Alyx.
    I've submitted a support ticket and did a log dump.
    My hardware is slightly different (GTX 1060, i7-6700HQ @ 2.60Ghz, 16Gb RAM) and for some reason no longer supported according to the modified compatibility list.
    Not happy, not happy at all  :(
  • HansaplastiqueHansaplastique Posts: 3
    NerveGear
    Woohoo!! I fixed on my PC by downgrading the nVidia driver 

    I reverted back to an older nVidia driver (441.41) and it works!!!

    Note:
    I completely removed everything nVidia (Experience, all drivers, etc).
    Rebooted, and eventually windows installed some old standard driver (v23.21.13.8873 from 2017).
    Next I downloaded 441.41 (Nov 2019) from the nVidia drivers page (make your selection, click search and scroll down for older versions). Link: https:// www. geforce. com/ drivers (remove spaces, I'm not yet allowed to post links)

    I presume a regular install will work, I just didn't want all the nVidia stuff installed so I just installed the driver, like so:

    After downloading the file, I extracted the downloaded EXE (I used WinRar: right click, extract).
    After extracting, I right clicked the display driver in device manager and clicked "Update Driver" and selected "nvtfi.inf" from the "Display.driver" directory (in the extracted directory).
    Next I selected my display driver, did get a warning that it may not be compatible (it shows a long list of same named devices - I looked up the specs of mine (GTX 1060 6Gb) and selected the first match. After installing the new driver, I rebooted and ... my Quest Link worked again and Half Life Alyx is awesome!!

Sign In or Register to comment.