New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Quest wont connect to PC anymore

XiltoXilto Posts: 1
NerveGear
Hi. I got the Oculus Link about a week ago. It worked perfectly fine but since 1 day its just bugging and now it even wont connect to the PC anymore. It started first with something like a loose contact but idk if it was that. Then it just stopped working. Im using the Version 15.0.0... And yes i have connected it to a USB 3.0 and tried multiple Ports. I also tried restarting the Oculus Quest and my Oculus app multiple times. It also said once that a USB 3.0 was a USB 2.0. Can someone help me please ?

Comments

  • enigma01enigma01 Posts: 763
    3Jane
    edited April 4
    What cable are you using, is it damaged perhaps? That could cause a cable to register as USB 2.0 when it's supposed to be 3.0. Have you tried a different USB 3.0 cable? 
  • KFHviking45KFHviking45 Posts: 5
    NerveGear
    Unplug the USB cable from the PC, restart PC, login, start oculus software, plug in the USB cable in the PC again. 
    Might have to restart the quest after that but not usualy. 
  • javieryunesjavieryunes Posts: 2
    NerveGear
    I have the same issue. Suddenly my pc won't recognize the quest anymore
  • tombombaytombombay Posts: 3
    NerveGear
    same issue


  • jdcjdc1993jdcjdc1993 Posts: 2
    NerveGear
    try using usbtreeview for windows to see if your usb connection is seen as 3.0, could be a cable issue if shown as 2.0. but the update has been caused alot of issues lately.
Sign In or Register to comment.