New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

(Solved) Rift S stays black or white points flashing

Hello

I recently bought an Oculus Rift S set and installed it to my PC; as of a misunderstanding or misreading I installed an additional USB 3.1 card with an USB A and C type port.

My system is a rather old one:
CPU Intel i5 3570k
Asus P8H77M-Pro mainboard
16 GB RAM @ 1666Mhz
Gigabye GTX 1660 OC 6GB
SSD storage

As I unpacked and installed the Oculus Rift S set for the first time I noticed problems during the installation / setup process (software) and started to read - finally I managed to get it working within seconds. I stumbled across a thread mentioning installing GeForce Experience software and thanks to this guy (I think it is the main reason).

Problems I encountered:
- random loss of display port connection (USB was always fine and connected to 3.1 A type port of extension card)
- sensor calibration was faulty (there are sensors in the glasses I think)
- no picture (glasses stayed black or I could only see controller lines or three flashing lights)

I re-read the specifications of Oculus Rift S and noticed that it needs a USB 3.0 type A port only, so I decided to change from USB 3.1 port to an USB 3.0 of the mainboard and I installed GeForce Experience (I never installed of used this because I did not need it).

I have not tested it right yet but I do not think it was because of the USB port change, but because of not having GeForce Experience installed - also I have to say, I created an account at GeForce Experience and installed the GeForce Gameready Driver for the card again (also there was a minor version change, because I bought the card two weeks ago).

I re-run setup and within a couple of seconds everything worked as expected ... and still does (knock on wood, press thumbs).

Hope this helps people who encountered the same problems.
Sign In or Register to comment.