New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S dropping DisplayPort connection within seconds of establishing it

KatspybaraKatspybara Posts: 2
NerveGear

So I just laid my hands on the Rift S and can't make it cooperate. When you connect it to the DP and USB 3 ports, it gets recognized instantly and the green checkmarks appear in Oculus software but it drops the DP connection within 2 or 3 seconds and can't establish it again. When you unplug the cable and plug it back in - same story, instantly recognized but drops connection right afterwards. I though the problem may be with the initial config software so I was just pretty swift with my "Next" clicking (before the DP connection dropped lol) which allowed me to successfully finish the process but it did not help as now it just lets me know DP is disconnected in the "Devices" menu.

I know for certain that my PC is VR ready, updated and the DP and USB 3 ports are good cause I used the very same PC and the very same ports for a Valve Index and it worked without hassle. What can I try to make the DisplayPort connection stay? I've tried the obvious like running Oculus software in beta or restarting my PC but to no avail :/


Comments

  • OculusSupportOculusSupport Posts: 895 Oculus Staff
    Hey @Katspybara can you try re-running the setup then repairing or reinstalling the software to see if there's any change. Additionally trying another USB port and removing other USB devices leaving only Oculus devices and the mouse and keyboard may result influencing the issue. If it persists, reach out at http://support.oculus.com/. - Principe
  • KatspybaraKatspybara Posts: 2
    NerveGear
    @OculusSupport Did that, did not help at all... Submitted a ticket with full logs through the support page, thanks.
Sign In or Register to comment.