New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

I need help with oculus link!

I've been trying to do this for a while now and it just never works. I open up oculus link software, go to try and setup the device and it doesnt detect it even though my laptop does? I tried using the reccomended Anker cable and it still didnt work. Any help?

Comments

  • Sekhmet_RaSekhmet_Ra Posts: 1
    NerveGear
    I am having the same issue
  • ninjaz44ninjaz44 Posts: 4
    NerveGear
    Its so annoying
  • matthew.cannamatthew.canna Posts: 11
    NerveGear
    try different usb ports, also load the occuls app first on the pc.  Turn on your quest without the link cable plugged in, wait till you established your guardian, then plug in. enable the link the connection once detected.

    Keep in mind that both the quest and occulus app on the pc should be the most current up to date.

    Close any background apps that may draw some ram and gpu and cpu.

  • JD-UKJD-UK Posts: 2,539 Valuable Player
    edited September 8
    Also remember that Link is still classified as beta. So whilst everyone wants it to work, it wouldn't be right to expect it to work 100% without any issue, every time.
    I tried several USB ports before finding the best one, which has worked flawlessly since, even after windows reinstall and changing motherboards twice etc (because I use an external, mains powered USB 3.0 hub for Link). It's just a case of 'suck it and see' and have some patience, but don't rely on it working until it does.

    I was very surprised when I plugged the Quest into my front socket on the PC case, which is USB 2, to do some sideloading and up came the Link box. Might be worth trying that - using the charging cable.

    There was a huge thread on what everyone was trying for the weeks following Link becoming available - might be worth trawling through that as well. I use JOTO cables - USB 3 3m was my main one for months but just switched to their 5m cable and that works just as well.
    I originally mistakenly bought a quality USB2 cable by Anker thinking it was USB 3 - it didn't work for Link then, but it does now. I really think getting the right USB socket makes all the difference - more than the make of cable.

    Edit: Here's a link to that thread - it was supposed to be about cables, but the USB socket was often discussed, too (this when USB 3 was obligatory):





  • ufcfanufcfan Posts: 84
    Hiro Protagonist
    I have four USB ports on my laptop. All supposedly USB 3.1 and a USB C 3.1. Only one of them works for link, yet all work for everything else. No idea why. Things that make you go wtf?
    Old Guy that's involved in anything Tech, Computer, Hi Fi Audio, HTPC and now VR
  • matthew.cannamatthew.canna Posts: 11
    NerveGear
    it seems you might not have the gpu and cpu required to make it work.  Mobile cpu/gpus don't pack the hardware needed to stream data.

    What is your laptop model?
  • DominatorVIPDominatorVIP Posts: 4
    NerveGear
    You should check your computer specs and make sure they're completely up to date drivers wise. You should also check to see if your USB ports are USB 3.0 or higher. You can do so by going to Device Manager > Universal Serial Bus Controllers. Laptop GPUs are generally less powerful then Desktop ones, so you should check to see if yours is capable of running Oculus well. Also, certain GPUs aren't supported/verified by Oculus to work with Oculus link, though most modern GPUs (GTX 1050 TI, or AMD Variant or newer) should be able to run it. 

    You can also try using different USB Ports, sometimes Oculus just randomly decides to dislike a certain USB port even though they're exactly the same as several others on the same PC. It can take some trial and error, but you should be able to get it to work.

    Also remember, Oculus Link is still in it's Beta phase, so there will be bugs that need to be worked out. Keep this in mind while troubleshooting.




  • ninjaz44ninjaz44 Posts: 4
    NerveGear
    So I got a email from oculus support and they said that they down support intel integrated graphics and my laptop needs to be rift supported so im just gonna wait until its fully released and hopefully it works with intel graphics and stuff
  • ninjaz44ninjaz44 Posts: 4
    NerveGear
     By the way side quest works fine and i tried both usb ports and nothing worked
Sign In or Register to comment.