New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Guardian resets whenever I start Steam games

unknownwarrior33unknownwarrior33 Posts: 2
When I'm playing games from the Oculus store with my Rift S, everything is fine. But when I try to play a game from Steam, it forces me to re-do the guardian setup every single time. And even if I do the setup again, it will just keep resetting until I give up. Does anyone have any idea how I can fix this? If I knew I would be limited only to Oculus games, I wouldn't have bothered. It used to work fine, but now it keeps doing this.


  • Bing567Bing567 Posts: 2
    I've found that games like pavlov with their own oculus specific launch option work but others like superhot and boneworks have suddenly stopped
  • StarmachineryStarmachinery Posts: 1
    edited September 20
    I am having the same problem. No issues if I run a game from the Oculus store, or from the Oculus interface (e.g. I bought Beat Saber on Steam but launch it in Oculus mode from the native interface without SteamVR), but if I run a game through SteamVR it loses the guardian and makes me redefine it. Sometimes I get stuck in a loop constantly redefining it, and have to force close the game and SteamVR to get out of it. Usually it works eventually if I keep trying but it's very annoying to start games in Steam.

    I contacted support and they suggested manually uninstalling the Oculus software and reinstalling it, using the instructions pasted below (I added spaces to the link because I'm not allowed to post links). I will try this and report back.

    *Disconnect your computer from the internet.
    *Backup any necessary content.
    You can find steps on how to do so here: https:// support. oculus. com / 190738628001661
    *Reboot into Safe Mode.
    *Uninstall Oculus Home using the Control Panel.
    *Delete all Oculus folders from the following folder:
    C:\Program Files
    *Remove any Oculus folders from the following locations:
    *Restart your computer in normal mode.
    *Reconnect your computer to the internet.
    *Install Oculus Home again using the setup tool

Sign In or Register to comment.