New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Blue Light On Rift S Not Turning On

MacQuacc69MacQuacc69 Posts: 1
NerveGear
So about 6 days ago, the blue LED on the front of my headset has stopped turning on. This was followed by the error of "DisplayPort Connection not working" and "No DisplayPort connection". I have tried all slots on my graphics card and all USB slots, including a card that houses 4 extra slots, with no luck. I have done a fresh install of the software, tried beta mode, updated windows and graphics drivers. I opened a support ticket, but that was no help whatsoever. I know it's not a faulty cable as i found a software that reboots the "RiftS USB Hub" which turns the light on for 2 seconds. Does anyone know a fix for this or is this an overly specific issue? (I have also tried unplugging all other devices and one of my monitors) If needed, my PC specs are i7 9700f, RTX 2070SUPER, 16GB DDR4 RAM and a 650w power supply
Tagged:

Comments

Sign In or Register to comment.