New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S display issue - USB 3.0 Query

Hi all,

I'll try to keep this brief, about a month ago after a windows re-install of a new SSD my oculus has had an issue where the display stops working and I get a good 1 second of visuals before a black screen takes over. The audio however works fine.

I've been on the line to oculus support and have tried everything that they have recommended however there's one thing (they didn't recommend this) that I haven't tried and that was people in the forums have said a third party PCIE USB 3.0 seemed to resolve the issue? I've got no issue purchasing one at all but I just want to ensure it will help of course. Would also be considering a much cheaper usb C to 3.0 usb adapter as I can then connect both to my GPU. It might also be worth it to mention my motherboard is an ASUS HERO IX z170, I've heard people complain of USB issues with this motherboard.

Any help considered

Thank you
Sign In or Register to comment.