New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Multi GPU Nightmare using Link and Quest with an Asus Zephyrus G14 - I assume a generic issue

BigKid1973BigKid1973 Posts: 1
NerveGear
I´d like to use my Asus Zephyrus G14 and Oculus Link for playing PC VR games with my Oculus Quest. However there is a strange issue with that device.

This is what I found out so far:
The Asus Zephyrus has a powerful AMD Renoir CPU (Ryzen 4800) and therefore also sports an iGPU (AMD Vega (not very powerful as it is just an iGPU) ). But it also has a medium class GPU (NVidia RTX 2060 Mobile) which is powerful enough for most games - at least in lower detail settings.

It seems like Oculus Link gets confused which one to use or most probably which frame buffer to access. Here is why:
- if I force the usage of the RTX2060 using the Nvidia control panel I will get a blackout in VR once I activate Link Beta - absolute blackness
- if I do not force usage of RTX2060 as GPU it will use the iGPU of the AMD CPU - it will be terribly slow and stuttering - but at least I will see the virtual home in the oculus software (or steam vr) or the PC VR games  on my Quest Headset (also unplayable slow).

So... After a long time experimenting with this issue I found out that DISABLING the AMD Radeon iGPU in the windows device manager and rebootingt will fix this issue for steam VR, Half Life Alyx and also for Oculus Virtual Home.
Unfortunately it does NOT fix the issue for Oculus PC VR Game Lone Echo (and most probably some other Oculus games too) - I can´t tell whats happening there exactly because I do see a picture in the Quest - but its slow as if it was using the iGPU - which can´t be because its disabled... probably it falls back to software rendering for some reason. 

I assume that this is a general issue with a wider range of multi-GPU setups and I hope Oculus will fix it sometime - it should be possible to tell the oculus software which GPU it should use (or make it more intelligent in detecting).

But any help enabling me to play Lone Echo would be highly appreciated.

Comments

  • PITTCANNAPITTCANNA Posts: 300
    Nexus 6

    Go to nvidia control panel, and add every single executable in the Oculus dir, and the game executables, and force them to use the nvidia card. Doing this worked for me, now i "only" have to disable the vega when first starting link and everything else works as expected (bar Oculus updates mucking things up, see update 12 killing link audio and peformances for a lot of people). Things i played that worked: Oculus and Steam homes, Pavlov from Steam, Superhot from Oculus, EmuVR with Oculus api.

    Hope it works for you. 

  • thiccanimethighsthiccanimethighs Posts: 2
    NerveGear
    You could try disablign the iGPU in the BIOS if possible. This may point oculus at just the 2060.
  • OcalazinOcalazin Posts: 3
    NerveGear
    It should NOT be the users job to fix this a 400 dollar Quest 2 an a 1500 gaming laptop should work flawlessly. Oculus should have the setup program handle all of this. 1900 bucks should be automatic.......
  • TseuTseu Posts: 6
    Brain Burst
    Same issue here with Quest 2 and zephyrus g14 (RTX 2060). Please share if you find a solution !
  • DeepestCloudDeepestCloud Posts: 1
    NerveGear
    I have a quest 2 and Asus Zephyrus g14 with the 4900HS and 2060.

    I have the same issue and so far the only way that has worked for me is disabling my iGPU in device manager and restarting. Except when I do this my gpu an CPU are stuck at less than 10% usage so it's very laggy.

    I'm currently going through oculus' support so I'll post an update with the results 
  • TseuTseu Posts: 6
    Brain Burst
    edited October 17
    Disabling iGPU is a bad solution.

    Finally i have found this solution: https://www.reddit.com/r/OculusLink/comments/hmvj8t/oculus_link_is_laggy_with_my_zephyrus_g14/fxf3wzr?utm_source=share&utm_medium=web2x&context=3

    The important part is adding Ovrserver_x64.exe, oculusdash.exe and oculusclient.exe in the Graphics Performance Preference. 

    If you don't see the nvidia gpu option, you have to plug in the power cable.

  • OcalazinOcalazin Posts: 3
    NerveGear
    Best solution?  return the quest 2 back to the retailer. I just got a message from Oculus yesterday they say 96 hour more hours will be needed to figure it out. I have never seen dual switchable graphics EVER work with VR and I just spent the last 96 hours friday through 3 am this morning trying,. NADA ZIP..... and they want more time? No way back to best buy I;m done with VR especially anything with the name oculus.......
Sign In or Register to comment.